Aquaria > General Discussions > Topic Details
Username Sep 19, 2013 @ 10:24am
wasd keys not moving me
i'm having an annoying issue where the wasd keys just turn my character in place, instead of actually moving her.

Edit: for anyone else experiencing this, the fix is to go into the game files, run AQConfig.exe, and enable vsync.
Last edited by Username; Oct 1, 2013 @ 10:32pm
Showing 1-10 of 10 comments
< >
Username Sep 19, 2013 @ 11:19am 
I'd really appreciate an answer on how to fix this, its the primary thing stopping me from playing the game because I can't move.
Hoshi Sep 20, 2013 @ 2:33pm 
Have you checked the key bindings? Other than that I can only suggest reinstalling or just use the mouse to move. I prefer that anyway and you are going to need to use it for some of the jumping puzzles anyway as you need the increased precision.
Username Sep 20, 2013 @ 2:59pm 
maybe i didn't explain well enough. The keyboard and the mouse only turn my character in place. The only way to actually move is to boost around everywhere, which is annoying because i have trouble aiming the boost so i always get stuck on the walls.
Vecchio Sep 20, 2013 @ 5:19pm 
That never happened to me... Try reinstall, is the only way I can see that may solve this problem...
cyanic Sep 21, 2013 @ 8:48pm 
Might be an incompatibility between the old default key config file and the new one (they were different names AFAIR). I don't have the game installed right now, so I'll have to dig around the source code or something.
Username Oct 1, 2013 @ 2:21pm 
Originally posted by Pilsu:
Can you move after the initial dash? It seems some areas are bugged and don't allow movement without it, such as the beginning. As long as you have momentum of some sort, you should be able to swim around after that.

yeah, this sounds like what I'm experiencing. So I guess its just something I have to put up with. Thanks.
fg Oct 1, 2013 @ 5:47pm 
This is a bug caused by very high FPS. As a quick workaround, enable vsync either in the game or your graphics driver to limit your FPS to ~60, that should fix it.

EDIT: For completeness, the fix:
* https://github.com/fgenesis/Aquaria_clean/commit/7891a2f0113d8b9508bad01dd1b7e62e771862ab
* https://github.com/fgenesis/Aquaria_clean/commit/f8ed78d33192db3a5ba5cd1d8fed4b5ba418d65c
Last edited by fg; Oct 1, 2013 @ 5:52pm
Username Oct 1, 2013 @ 9:47pm 
Originally posted by fg:
This is a bug caused by very high FPS. As a quick workaround, enable vsync either in the game or your graphics driver to limit your FPS to ~60, that should fix it.

EDIT: For completeness, the fix:
* https://github.com/fgenesis/Aquaria_clean/commit/7891a2f0113d8b9508bad01dd1b7e62e771862ab
* https://github.com/fgenesis/Aquaria_clean/commit/f8ed78d33192db3a5ba5cd1d8fed4b5ba418d65c

thanks i'll try this now
Username Oct 1, 2013 @ 10:31pm 
turning on Vsync seems to have done the trick, thank you so much! :)
Triton Apr 14 @ 1:59pm 
Oh my god thank you.. I've just started playing this (bought a long time ago), and this was driving me insane. It was nearly impossible to move around smoothly!

Enabling V-Sync did the trick!
Showing 1-10 of 10 comments
< >
Per page: 15 30 50