Aquaria > Discussions générales > Détails du sujet
honeybadger 28 déc 2012 à 19h35
12.10 Ubuntu Aquaria Crash
Game crashes after displaying loading screen.
Any solution? May be some library is missing?
Affichage des commentaires 1 à 15 sur 35
< >
Tweakedenigma 28 déc 2012 à 23h19 
I am having the same issue. Loading screen comes up and then crashes, Ubuntu 12.10 (32-bit)
mTUX 29 déc 2012 à 16h11 
It's crashing with Segmentation Fault. Somebody should report this bug to the developer.
Backtrace:

Thread 1 (Thread 0xb7bcb700 (LWP 14134)):
#0 0x08239973 in HalfSize (filter=<optimized out>, d=<optimized out>, data=<optimized out>, height=<optimized out>, width=<optimized out>, components=<optimized out>) at /home/icculus/projects/aquaria-nongpl/BBGE/glpng/glpng.c:145
#1 Build2DMipmaps (components=<optimized out>, width=<optimized out>, height=<optimized out>, format=6408, data=0xa5e39008 "\377\377\377", filter=1) at /home/icculus/projects/aquaria-nongpl/BBGE/glpng/glpng.c:232
#2 0x0823aae4 in pngLoadF (fp=0xe2aee58, mipmap=-1, trans=-2, pinfo=0xbfff8758) at /home/icculus/projects/aquaria-nongpl/BBGE/glpng/glpng.c:542
#3 0x0823b0ae in pngLoad (pinfo=<optimized out>, trans=<optimized out>, mipmap=<optimized out>, filename=<optimized out>) at /home/icculus/projects/aquaria-nongpl/BBGE/glpng/glpng.c:361
#4 pngBind (filename=0xde9a004 "gfx/menu.png", mipmap=-1, trans=-2, info=0xbfff8758, wrapst=33071, minfilter=9987, magfilter=9729) at /home/icculus/projects/aquaria-nongpl/BBGE/glpng/glpng.c:684
#5 0x082c9cbe in Texture::loadPNG (this=0xe348470, file=...) at /home/icculus/projects/aquaria-nongpl/BBGE/Texture.cpp:485
#6 0x082ca41c in Texture::load (this=0xe348470, file=<error reading variable: DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjunction with DW_OP_piece or DW_OP_bit_piece.>) at /home/icculus/projects/aquaria-nongpl/BBGE/Texture.cpp:361
#7 0x08265ae8 in Core::doTextureAdd (this=0xbfffbf50, texture=..., loadName=..., internalTextureName=...) at /home/icculus/projects/aquaria-nongpl/BBGE/Core.cpp:4597
#8 0x08265d2c in Core::addTexture (this=0xbfffbf50, textureName=...) at /home/icculus/projects/aquaria-nongpl/BBGE/Core.cpp:4648
#9 0x08295b86 in RenderObject::setTexture (this=0xe2a2268, n=...) at /home/icculus/projects/aquaria-nongpl/BBGE/RenderObject.cpp:1491
#10 0x0828997f in Precacher::precacheTex (this=0xbfffe500, tex=...) at /home/icculus/projects/aquaria-nongpl/BBGE/Precacher.cpp:95
#11 0x0828a37a in Precacher::precacheList (this=0xbfffe500, list=...) at /home/icculus/projects/aquaria-nongpl/BBGE/Precacher.cpp:116
#12 0x080f4775 in DSQ::init (this=0xbfffbf50) at /home/icculus/projects/aquaria-nongpl/Aquaria/DSQ.cpp:1638
#13 0x0817b9f9 in main (argc=1, argv=0xbfffed54) at /home/icculus/projects/aquaria-nongpl/Aquaria/Main.cpp:201
Syzygy 26 jan 2013 à 8h59 
I also get an immediate crash on Ubuntu 12.04 LTS.
Arcanoxer 2 fév 2013 à 13h02 
Syzygy a écrit :
I also get an immediate crash on Ubuntu 12.04 LTS.
Same here.
cyanic 6 fév 2013 à 19h49 
IIRC there should be a log file in ~/.aquaria. See what the last few lines look like. If anyone would like to dig into the code, try http://hg.icculus.org/icculus/aquaria/. The official code hasn't been updated in a long time, and it's the GPL codebase, but stuff shouldn't be that far off.
intok 14 fév 2013 à 9h45 
Also crashing in Mint 13 32-bit.
cyanic 15 fév 2013 à 4h37 
On Ubuntu the user data path is ~/.local/share/Aquaria. Check the log.
EuPhobos 15 fév 2013 à 21h46 
Not working >:-(
dancemasterglenn 16 fév 2013 à 12h08 
I do hope this can be fixed at some point... my old version from the humble bundle used to work fine. :( Is this just not using the most recent build from that bundle?
Captain Picard 16 fév 2013 à 13h41 
Same Xubuntu 12.10 32bit

My Log[pastebin.com]
Dernière modification de Captain Picard; 16 fév 2013 à 14h35
dancemasterglenn 16 fév 2013 à 20h42 
two things that stuck out in my logfile:

precache[songhints/*.png]
PRECACHING: songhints/*.png
searching directory
forEachFile - path: gfx/songhints/ type: .png
FAILED TO OPEN DIR
precache[collectibles/*.png]
PRECACHING: collectibles/*.png
searching directory
forEachFile - path: gfx/collectibles/ type: .png
I think that's for songhints, but I kept the part after it as well. Also, at the end:
PRECACHING: gfx/collectibles/sporeseed.png
pos [-1], file :gfx/collectibles/sporeseed.png
LOADED TEXTURE FROM DISK: [collectibles/sporeseed] ref: 1 idx: 631
precache[end]
PRECACHING: end
pos [-1], file :gfx/end
***Could not find texture: gfx/end
LOADED TEXTURE FROM DISK: [end] ref: 1 idx: 632
precache[missingImage]
PRECACHING: missingimage
pos [-1], file :gfx/missingimage
LOADED TEXTURE FROM DISK: [missingimage] ref: 1 idx: 633
precache[menu]
PRECACHING: menu
pos [-1], file :gfx/menu
lminiero 17 fév 2013 à 14h32 
Not working for me either, and I get the same log as dancemasterglenn about the missing image, even though I don't think that's the cause, otherwise it would work for nobody, would it?
BrolinOfVandar 17 fév 2013 à 16h28 
Also not working here, on opensuse 12.2. Tried turning off the Steam overlay (which I needed to do to get The Book of Unwritten Tales to run) with no change. Log looks about the same as shown here. No errors in /var/log/messages or any other indication of the problem. There was a reference to a missing directory (songhints), so I created one to see if it made any difference. That only got rid of the error about the missing directory. I've presently uninstalled it. Hoping this is resolved soon, hate paying (even a small amount on sale) for a game that never loads...
cyanic 18 fév 2013 à 9h32 
gfx/end doesn't exist in my Windows build, so I don't think that's a big problem.
cyanic 18 fév 2013 à 9h45 
It's sort of hard to tell what's going wrong just be looking at source code. My guess is that menu.png is corrupted or somehow the program didn't pass in the proper buffer. As for the other problems, you can remove their entries in data/precache.txt.
Affichage des commentaires 1 à 15 sur 35
< >
Par page : 15 30 50