Sid Meier's Ace Patrol: Pacific Skies
Warduke Jan 4 @ 12:29pm
Will this run on Vista?
I know it says Windows 7 in the system requirements but was curious if anyone has this running on Vista? Thanks in advance.
Showing 1-6 of 6 comments
< >
social_distortion Feb 5 @ 2:18pm 
I wondered the same thing.
Warduke Feb 5 @ 3:48pm 
It does.. I went ahead and bought it on sale awhile back and it runs on Vista.
Well, proves this game is messed up. Won't run on my High End, new computer, but runs on a Vista. :I
txmale1977-firefox Feb 14 @ 9:27am 
I have Vista and can't get it to run. crashes on start.
Bacon.熏肉.[DK | Newbee] Feb 15 @ 9:46am 
There is also an OpenGl requirement (not sure which version # though). The game renders in OpenGl mode only.
Faenix1 May 18 @ 11:59am 
Works fine for me, the first one crashes my PC though. Really weird.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50