bishop590 Sep 1, 2013 @ 7:37pm
Possible solution for the green screen issue
When I tried to start the game all I had was a green (it's a yellowy green colour) screen and the sound. Even though I couldn't see what I was doing I could click around and get it to start a campaign - the pilot pcitures showed, as well as the objective, but the rest of the window was solid green.

After a bit of trial and error, I discovered a solution to my issue - turns out my problems were being caused by the on screen display (OSD) component of EVGA Precision X! Once I toggled the "Show On-Screen Display" to off in RivaTuner (the program that actually does the on screen display) everything worked perfectly! Hopefuly this'll be of help to anyone else having this specifc green screen issue!
Showing 1-8 of 8 comments
< >
Nowater Sep 4, 2013 @ 12:59pm 
Strike! This fixed it for me, have had MSI Overlay running...Thank you
bishop590 Sep 4, 2013 @ 2:20pm 
Pleased to help! It's rare I figure out a solution; I'm normally the one searching the forums in hope of a fix!
OpusTheFowl Oct 3, 2013 @ 4:26pm 
Thanks! Worked for me too. Had MSI Afterburner running and turned-off OSD...restated and poof..no problems...

TY Bishop!
Last edited by OpusTheFowl; Oct 3, 2013 @ 4:26pm
Bonder Nov 19, 2013 @ 12:27am 
Originally posted by bishop590:
When I tried to start the game all I had was a green (it's a yellowy green colour) screen and the sound. Even though I couldn't see what I was doing I could click around and get it to start a campaign - the pilot pcitures showed, as well as the objective, but the rest of the window was solid green.

After a bit of trial and error, I discovered a solution to my issue - turns out my problems were being caused by the on screen display (OSD) component of EVGA Precision X! Once I toggled the "Show On-Screen Display" to off in RivaTuner (the program that actually does the on screen display) everything worked perfectly! Hopefuly this'll be of help to anyone else having this specifc green screen issue!

Thank you sir. worked for me, too.
PCPlayerZero Dec 8, 2013 @ 10:20am 
Didn't work for me. I have to close MSI Afterburner completely if i want to see anything in the game. Running MSI AF 3.0.0 beta 16.


Last edited by PCPlayerZero; Jan 13 @ 4:56am
PCPlayerZero Jan 13 @ 4:56am 
UPDATE: Now with MSI AF 3.0.0 beta 18. Making some adjustments on MSI:AF not only made the game work but also made it possible to record the game.
Jesus Faction Feb 11 @ 9:12am 
wow thanks, had this same issue and this fixed it
Anna DeWitt Feb 19 @ 4:54am 
Unbelievable!, thanks, worked for me as well, don't think i would have ever found out the issue, works with pacific skies as well, a stickie might be a good idea.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50