King Arthur - The Role-playing Wargame
Τhe Rolling Egg Apr 8, 2013 @ 7:07pm
Jesus Christ bad performance
Game looks like utter crap, yet runs at 20 fps while games like shogun 2 runs at 60. Amazing.
Showing 1-11 of 11 comments
< >
StormWyrm Apr 17, 2013 @ 11:51am 
It may be your setup, or just that Neocore are in general, lax with supporting their games.

However, my performance is similar to Shogun, maybe my settings will work for you. The only things I have on max are textures, animations, and resolution. Most other things are low or off: shadows, AA on 2x, fancy vid effects. It always helps to prioritize settings, I only have things on that actually make a serious difference.
Τhe Rolling Egg Apr 17, 2013 @ 11:54am 
Originally posted by StormWyrm:
It may be your setup, or just that Neocore are in general, lax with supporting their games.

However, my performance is similar to Shogun, maybe my settings will work for you. The only things I have on max are textures, animations, and resolution. Most other things are low or off: shadows, AA on 2x, fancy vid effects. It always helps to prioritize settings, I only have things on that actually make a serious difference.

I actually put everything to minimum and it's still the same fps. I'm not a beginner when it comes to troubleshooting :>.. I read forums, and the general consensus is that this game has terrible performance.

Also resolution is bugged, changing resolution just makes everything blurry, the screen size is still the same.

If this is an example of neocore's work, I am definitely not looking forward to playing King arthur II.
Live Slow Die Whenever May 8, 2013 @ 3:55am 
I am experiencing the same thing. I reinstalled the game last night to see if any updates had improved the performance but it's just as bad as when I bought it. Like you, I can run Shogun 2 nearly-maxed out with a steady sync'd 60fps (or varying 80-120ish with screen tearing). There is no reason that a game should run at 20fps on bare minimum settings other than developer incompetence.

The screen tearing is so bad that I can clrearly see the image being drawn across the screen when I move the camera on the battlefield. It's actually quite nauseating.

I searched for any obscure troubleshooting tips or clever performance tweaks but I came up empty.
Arkveveen Jun 21, 2013 @ 6:18pm 
I just bought this game today, and it was a complete waste of money, even if it was only about 7 bucks for the original game AND The Saxons expansion. I want my money back, the performance is TERRIBLE. I wish there was a fix, but sadly it looks like you guys haven't found one. Really, what a joke!
I N D U S T R I A L Sep 14, 2013 @ 1:43pm 
7 bucks is not a bad waste of money compared to what I paid for the game.
Damedius Sep 14, 2013 @ 2:36pm 
We tried to warn you.
Demented Mind Oct 31, 2013 @ 2:58am 
I always check gameplay videos and reading forum to pick up the general feedback of the game before purchasing.
jonnireno Mar 22 @ 12:37pm 
I don't think Jesus Christ is in this game...Just a hunch.
Azazel Mar 22 @ 7:42pm 
This game runs just fine for me.
dragonslayer_34 Apr 6 @ 1:55am 
i have a pretty nice computer and i run it full everthing and i get 58 fps and it runs smooth and no crashes adn mines a quad core everyone else i know who has a quad core is having crash problems but not me
Aurumlamina Apr 18 @ 12:56am 
Honestly, the game has run perfectly for me on both the computer I've recently built and an old one that I used to use when this game first came out. Maybe I've just been lucky with whatever compatability issues some people are running into.

Either way, I hope you guys figure them out. This is one of my favorite games of all time!
Showing 1-11 of 11 comments
< >
Per page: 15 30 50