Phunk  [developer] Sep 24, 2013 @ 1:10am
OFFICIAL: Windows 64/32 bit support (and forcing 32-bit)
NOTE:
as of the Pumpkin update, the launch options will have no effect on the version of the game that is launched; please instead right-click the game in your library to select the 32-bit version.

Hi all,

With the Dead Haggis update, we've included the Windows 64-bit version of the game, which will automatically launch if your OS supports it.

If you would prefer to force Sir to run as 32-bit, you can do so like this:
  • right click the game in your Steam Library and select "Properties"
  • click "set launch options"
  • type "-force32" into the box (without the quotes) and press OK
  • close the properties window and launch the game as normal.

If for some reason the 64-bit version is not launching on your machine and you want it to, you can also use "-force64" - but please post something so we know this is happening and we'll try to address it.
Last edited by Phunk; Oct 17, 2013 @ 2:25pm
Showing 1-15 of 16 comments
< >
Pawpad Sep 25, 2013 @ 5:51pm 
Steam automatically tries to run the 64bit version and the game crashes instantly. It works fine when I run the 32bit exe however. Oh and I have Windows 7 64bit so the game should be working for me. In fact it was working the other day. I was playing right after the newest update. Now it just crashes.
Last edited by Pawpad; Sep 25, 2013 @ 10:51pm
Phunk  [developer] Sep 26, 2013 @ 12:55am 
For a short while after the update, 64-bit wasn't working - we pushed a second tiny fix to enable that. That's probably when your cashes started.

Unfortunately there seems to be a missing dependency on our 64-bit build. We know what's missing, but the dependency shouldn't be there at all - so we don't want to push the dependency out until we know whether it's really necessary.

We're working to address this as soon as possible, as we'd really like people to be able to play the 64-bit version!
Last edited by Phunk; Sep 26, 2013 @ 12:56am
Pawpad Sep 26, 2013 @ 2:30am 
Ok cool, good to know your team is on it. :)
Last edited by Pawpad; Sep 26, 2013 @ 3:51am
GameBeast Oct 18, 2013 @ 8:36am 
I don't see the option to run the 32-bit version on Linux.
Also, the 64-bit version crashes on start, so I can't play it at all.
Phunk  [developer] Oct 18, 2013 @ 8:36am 
There is no 64-bit version on Linux; only Windows has 64-bit support at the moment. Which version are you actually running - Linux, or Windows? Is there any error message with your crash?
GameBeast Oct 19, 2013 @ 12:28am 
Originally posted by Phunk:
There is no 64-bit version on Linux; only Windows has 64-bit support at the moment. Which version are you actually running - Linux, or Windows? Is there any error message with your crash?

I'm running the Linux version (I wasn't aware it was just 32-bit on Linux). There is no error with the crash, though. I tried verifying the integrity of the game cache, and it said 37 files were missing, but after 're-downloading them' it didn't change a thing, and there are still 37 files missing.
Phunk  [developer] Oct 19, 2013 @ 1:37am 
Okay - thanks for the info. We'll look into it right away!
Ash_Ketchup*CleanSkrub* Oct 22, 2013 @ 11:07am 
I am running 64 bit windows, launching either 64 or 32 bit will make my game crash when loading up a newly made island as soon as i click- it freezes, but wont 'stop responding' untill i physically click. Forcing 64 or 32 bit changed nothing. Bought the game after pumpkin update, and as it keeps doing this am yet to even play it. PLEASE HELP!!!
Dr Strangehate Oct 22, 2013 @ 11:16am 
I also wasn't aware the game would not work on 64 bits Linux. Is there a work around for it? I tried -force32 and it of course didn't work as I expected? Is it going to work soon because I'm just a bit irked I paid that money on a game I can't play.
Phunk  [developer] Oct 22, 2013 @ 1:40pm 
Hi Dr Strangehate. Unfortunately we have a bug at the moment that affects some but not others - unfortunately it seems to affect Linux more than others. Please rest assured that this isn't a 64-bit specific issue - the game *should* be working, and we'll have a patch in the next couple of days. Sorry for the inconvenience - and thanks for your patience.
Dr Strangehate Oct 22, 2013 @ 6:00pm 
If you are currently working on this I will wait then.
Adafal Dec 19, 2013 @ 11:47am 
I did everything right, I tried both ways, but the error continues
Dr Strangehate Dec 19, 2013 @ 1:18pm 
It was fixed for me in an update the week after I posted my message.
Adafal Dec 19, 2013 @ 4:39pm 
I bought the game this week, I downloaded and installed, and the error appears when I try to start the game

how do I update the game?
Phunk  [developer] Dec 20, 2013 @ 1:02am 
Adafal, what error message are you getting? Does it happen for both 64 and 32 bit? And are you running through Steam?
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Sep 24, 2013 @ 1:10am
Posts: 16