140
140 > General Discussions > Topic Details
Valfaun Jul 21, 2014 @ 1:48pm
Level 2 progress issue
seems i'm too stupid to beat level 2. got to the part with the reverse gravity where there's a long corridor and a gap up in the middle with a field of static at the top. no matter what i try, the gravity pulls me upwards into the static. i watched a couple of videos of that stage, but apparently i just have to stand still and the gravity pull ends just before reaching the static. however, it doesn't for me.
i tried various resolutions, high and low detail, windowed and fullscreen, but it's always the same. the gravity inevitably pulls me up into the static
< >
Showing 1-9 of 9 comments
Winter Fox (Q) Jul 22, 2014 @ 1:05am 
Are you jumping before getting pulled up?
Valfaun Jul 22, 2014 @ 10:12am 
Originally posted by Tails ^_^:
Are you jumping before getting pulled up?
nope, tried it in various ways, too. without jumping or moving, with jumping, with horizontal movement, with diagonal jumping from the left, without movement/jumping and a position on the left so the gravity had to pull me diagonally first... i even tried to rotate the triangle during the pull so it pointed downwards
Carlsen  [developer] Jul 23, 2014 @ 12:48am 
I am sorry you experience this. It is indeed a bug. For some reason the timing between the audio and the game differ on your machine, and I honestly have no idea why. The only way you might be able to tackle it is to jump early, so that you have a downwards momentum when the gravity pull starts. But maybe you already tried that.

Alternatively, you could hack the save data, to skip the rest of level 2, so you at least can check out level 3. To do so, find 140 in you registry, on Windows I believe it's stored here: HKCU\Software\JeppeCarlsen\140

You should simply add one to the integer LevelProgress.

If you are on Mac, you can find it here: ~/Library/Preferences folder, in a file named unity.JeppeCarlsen.140.plist,

Again, I am sorry you are having this problem. Feel free to contact me via the email on our website.
Valfaun Jul 24, 2014 @ 10:40am 
thank you, Carlsen. i tried it a couple of times explicitly with the downward momentum in mind and eventually succeeded with the right timing. that bit was even trickier than the level 3 boss, heh.
i heard of this kind of bugs before. i know there was a game where certain CPU configurations caused some gamebreaking AI bugs. must be really hard for a developer to fix a bug they can't replicate.
anyway, the problem aside, i still really enjoyed the game. the music is great, the levels and bosses require some thinking and rhythm without being frustrating and i like static. also, i'm unsure why exactly, but i really liked the little scene after beating level 3
Carlsen  [developer] Jul 24, 2014 @ 2:27pm 
Ah, nice to hear you were able to pass it, and thank you for your positive attitude. You hit the nail on the head - the problem is that I can't reproduce this bug on the hardware I have available.

140 does the slightly risky thing of controlling the gameplay elements from the audio thread, which is probably what causes the bug on rare systems.

I am glad you enjoyed the game anyhow, and were able to see the ending :)
Demodulated Aug 25, 2014 @ 9:46am 
Originally posted by Carlsen:
140 does the slightly risky thing of controlling the gameplay elements from the audio thread, which is probably what causes the bug on rare systems.

I hope this doesn't mean that the game will stop working 5 years from now when CPU architecture changes. Video games have a long history of timer bugs. Does Unity shield us from this?
SlideDrum Dec 27, 2014 @ 6:54am 
I'm having the same issue. I knew it had to be a bug. Too bad there is still no fix for it. I would really like to play the rest of the level.
Valfaun Dec 27, 2014 @ 9:03am 
Originally posted by Slidedrum:
I'm having the same issue. I knew it had to be a bug. Too bad there is still no fix for it. I would really like to play the rest of the level.
unless your instance of the bug is worse than mine, you can still progress. gotta time the jump so you have downward momentum when the pull kicks in. might take a bit to get it right, but it worked
Carlsen  [developer] Feb 3, 2015 @ 12:03pm 
If you have this issue, please send me an email (my email can be found on our website, game140.com). I am working on a patch, that should fix this, but I need help to verify if the patch works.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

140 > General Discussions > Topic Details