Space Hulk

Space Hulk

View Stats:
Space Hulk > General Discussions > Topic Details
Zuggi  [developer] Nov 29, 2013 @ 2:13am
Known Crash Problem with Unity + Corrupted Font Files
Borrowed this from the Realms of Arkania forums

Recent investigation with some helpful users has shown that our current Unity Version 4.2.0f4 is making serious trouble on some users systems, e.g. the game crashes without any usable information, without showing even the intro, just a short flash of a white screen, then something about a crash folder that was created.

On the computers of two users this was caused by corrupted fonts installed in their windows fonts directory. After removing them, the engine started as expected, and they can now both play the game in its current state.

If - and only if - you are experiencing this since about Patch 1.12 (where this problem was introduced by our upgrade to Unity 4.2, which solved different other problems), please try and check your fonts directory with one of the tools available. This is not intended to sell *any* software, please don't buy anything unless you really need it for something despite this onetime font check, but the programs below helped these users fix this specific problem:

You would only need them to "find and fix corrupt fonts".

We hope that Unity will soon fix this problem of the engine themselves.
< >
Showing 1-15 of 15 comments
aardvarkmcme Jun 22, 2014 @ 7:00pm 
how do these programs work? I can't figure it out
Zuggi  [developer] Jun 23, 2014 @ 1:48am 
So you're having issues getting the game to run ? Please send your output.log./player.log to support@fullcontrol. Can also write about your issue here.
Conor Jun 24, 2014 @ 6:07pm 
What is the email? I'm getting a crash on load in OSX 10.9.2

Originally posted by Zuggi:
So you're having issues getting the game to run ? Please send your output.log./player.log to support@fullcontrol. Can also write about your issue here.
cancelHoo Jun 24, 2014 @ 7:31pm 
Hey Zuggi. Might this be the reason that my game won't even finish downloading? It gets to eta 10 seconds and then fails. I did the appcache delete thing, but to no avail. If you guys are working on a fix, that's completly understandable.
Zuggi  [developer] Jun 25, 2014 @ 12:20am 
I highly doubt it, I suspect that would be due to the server load on Steam's side
Conor Jun 25, 2014 @ 11:53am 
What is the best way to submit the crash report? I just purchased and it is crashing before it loads....
IzNoGood  [developer] Jun 30, 2014 @ 3:26am 
Unity support is on the case now - this seems to hit a lot of Unity games, and they are looking into it
Zuggi  [developer] Jul 16, 2014 @ 2:05am 
Could you send the output.log to ?
CukiMonster May 19, 2015 @ 4:18pm 
CukiMonster May 19, 2015 @ 4:19pm 
Originally posted by Yes.:
im having trouble anyone know what this means???

AppName=Unity Player
Info=Unity 4.5.0f6_fd4616464986
FilesPath=C:\Program Files (x86)\Steam\SteamApps\common\Unturned\2014-07-16_035636\
File01=C:\Program Files (x86)\Steam\SteamApps\common\Unturned\2014-07-16_035636\error.log|Error log
File02=C:\Program Files (x86)\Steam\SteamApps\common\Unturned\2014-07-16_035636\crash.dmp|Error dump
File03=C:\Program Files (x86)\Steam\SteamApps\common\Unturned\Unturned_Data\output_log.txt|Output log file
yea this means ur playing unturned but if anything will work it will be this or that installer marine s .hit
Last edited by CukiMonster; May 19, 2015 @ 4:20pm
CukiMonster May 19, 2015 @ 4:21pm 
Originally posted by Zuggi:
Could you send the output.log to ?
THANK YOU YOU ARE NOW JUST 1 DM under being as good as Gabe newl our steam lord and savior
pR0phet Nov 27, 2015 @ 10:35am 
Guys my game crashes all the time i jus bought it! and i rlly want tomplay it! pls help ! add me as friend to msg me!
Zuggi  [developer] Nov 29, 2015 @ 3:52am 
Try verifying your cache files.

Go to "Library". Right-click on "Space Hulk". Go to "Properties" and click it. On the window that opens, go to the "Local Files" tab. Go to the bottom of this tab and click the button with "Verify Cache files" on it. Wait for the application to run, this could take 5-10 minutes. When it finishes completely, close your Steam browser. Exit Steam completely by right-clicking the Steam icon in your Toolbar and then clicking "Exit. (instructions by datguy13)
Emsqueek Oct 10 @ 9:43pm 
Did the second link. It's called Font Expert. It's a 30 day trial, then you have to buy a key to keep using it. Anyway, Under Tools, click 'Detect Font Problems'.
Select 'Font Substitutions'.
It will show a single error. The problem one is highlighted. Click Remove from registry.
Restart Game.
It's what worked for me.
Windows 10, Alienware
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Space Hulk > General Discussions > Topic Details