Space Hulk > General Discussions > Topic Details
Bunga Feb 26, 2014 @ 9:35am
Constant Connection Errors
Hi there, really hoping a developer sees this post and can help me out :(

I love this game, and I bought it with my brother on iPad so we could play asynchronous multiplayer together but I am getting constant connection errors which make the game unplayable. It'll error half way through turns, at the end of turns, between turns, you name it, it's doing it! He seems to be having no problems on his end, and neither do any other randoms I've tried to play online.

What's more when I get the connection error message and it says "press any key to continue" I have to exit the app and restart it to get to do anything again.

Everything else works fine on my internet connection/Wi-Fi. I've not got any crazy router ports/firewalls running. Perhaps somebody could tell me what ports need forwarded in order to play Space Hulk online and I can look at that as an option? I've tried restarting the app when it happens, disabling and re-enabling Wi-Fi on the iPad, turning router on/off, even deleting and reinstalling the game.

Please help, love your game and want to use it to spend quality time with my brother who I don't see much anymore.

Thank you!
Showing 1-15 of 17 comments
< >
Bunga Feb 26, 2014 @ 9:37am 
I should add that this happens with any opponent.
illitrate Feb 26, 2014 @ 12:38pm 
I've noticed similar before when playing on my iPad too. Usually if I'm playing multiple async games - I can play one turn on one game fine, but generally the game quits as I move to the next game so I have to restart it.

Might be worth waiting until the forthcoming update, hopefully due within the next week or two. They've got the patch for the next release all ready to go, so probably too late to do any tests with the current version and could be the new patch will solve the issue anyway.
datguy13 Feb 26, 2014 @ 1:00pm 
Does the iPad have an idle setting, like a screensaver animation or anything like that? Or a Sleep Mode like a standard PC does? If it does, maybe changing the settings for that can affect the length of time you can be online before a connection error occurs. The only time I've ever had a connection lost error happen was when I let the game sit idle for longer than my monitor and desktop presets allow before entering Sleep Mode, so there might be something to that.
illitrate Feb 26, 2014 @ 1:08pm 
No screensaver, but it will switch itself off after a few minutes, unless you've changed the setting. I'll test it some more after the 1.4 patch comes out.
Bunga Feb 26, 2014 @ 3:03pm 
@illitrate - are you saying that with only one asynchronous game in progress you don't have connection errors but if you do have more, you do? I've always had more than one game open as I wanted to test connections
Leodrakk Feb 26, 2014 @ 8:30pm 
I also have this problem on my ipad. Only with the multiplayer game, not Campaign.
Hoping it will be sorted out with the next update.
Bunga Feb 27, 2014 @ 1:32am 
Is there a changelog for the patch that's coming out soon? Have the developers said anything about these problems?
Zuggi  [developer] Feb 27, 2014 @ 2:50am 
To be honest I haven't received a whole lot of bug reports on thi issue. We put up a change list for 1.4 version here on the forum 1-2 days ago. Connection problems can be really tough to iron out as it can be linked to local internet settings, server issues and so forth. I can talk to the coders and maybe give the server a reset..but we have made some server changes for the next patch yes
Bunga Feb 27, 2014 @ 2:58am 
Hi Zuggi, thanks for the swift response.

I totally understand that, I haven't had any problems with other stuff on my network but do you happen to know the ports that need to be open for SH's multiplayer to function? I could then manually ensure my router has them open and at least that would cross one potential cause off the list (although, I suspect this isn't the cause as sometimes the multiplayer works but only briefly before bugging out again)

A server reset would be amazing if that is a possibility?

Thanks, yeah, I found the patch notes - fingers are crossed, I absolutely love the game and can't tell you how much I want to be able to play the multiplayer properly :(
Last edited by Bunga; Feb 27, 2014 @ 2:58am
illitrate Feb 27, 2014 @ 12:28pm 
Originally posted by Bunga:
@illitrate - are you saying that with only one asynchronous game in progress you don't have connection errors but if you do have more, you do? I've always had more than one game open as I wanted to test connections
Ah, I probably haven't tried it with just one game - I tend to have 5 running at once.
If the 1.4 patch doesn't come out before the weekend then I shall test it with just one async game at a time
datguy13 Feb 27, 2014 @ 4:40pm 
er.. when you say "have more than one game open" do you mean that you run multiple instances of the application, or that you accept and play more than one invitation at a time? Because if you're running multiple instances of the application, that'll cause your problem. If you're running only one instance, but with multiple invitations accepted and only one game active at a time, then we'll have to continue to look deeper into the issue.

And please don't assume that just because "other apps work" that it isn't still your internet causing a problem. Each app is different, and if you're using a wireless network with its own security set-up, it can single out and block specific apps for no discernable reason. Asking fr the ports is a good place to start though.
illitrate Feb 27, 2014 @ 11:20pm 
Can only open one instance of an app on the iPad, no way to hydra
Bunga Feb 27, 2014 @ 11:22pm 
Thanks illitrate, would be interested to hear how that goes.

@datguy - I'm on the iPad version so can only run one instance of the app. I'm running one application with 2+ (up to the full 5 allowed) asynchronous multiplayer games accepted and moving between those games one at a time.

I'm not assuming that it's anything, I know how weird routing can be and the problems it can cause!
Last edited by Bunga; Feb 27, 2014 @ 11:23pm
Zuggi  [developer] Feb 28, 2014 @ 1:20am 
I've told the coders to try and clean up the servers/databases

It shoudl be port 9933
Bunga Feb 28, 2014 @ 3:24am 
You are a legend Zuggi, thanks for the help.

Will keep an eye on how its running over the next few days and report back.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50

Space Hulk > General Discussions > Topic Details
Date Posted: Feb 26, 2014 @ 9:35am
Posts: 17