Space Hulk > General Discussions > Topic Details
Chris Feb 12 @ 1:26pm
I thought this game was optimized?
I have a high end rig. I game at 1080p with a 4770k CPU, GTX 780 ti, 16gb ram and an SSD.
I use vsync on all my games (I hate tearing) which gives me an ultra smooth 60fps on all my titles, Inc BF4, Witcher 2, Civ V to name just a few and have never dropped a single frame.

I have just started the second map on Space Hulk and it also started off butter smooth. On my 2nd turn about 8 genestealers appeared and the scrolling got choppy (caused by the frames dropping below 60fps while using vsync). I only got rid of the choppy scrolling by turning down the graphics from "fantastic to simple" then the scrolling was smooth again.

Even at fantastic setting, this title is nothing special to look at, and the Genestealers aren't graphically demanding either, so why is this title dropping below 60fps on a 780ti with a few sprites on the screen??? Also it is a turn based game so the CPU wasn't doing any calculations as it was waiting for my movement.
I can play numerous demanding titles with huge amounts going on onscreen without a hiccup or drop of 1 single frame. The only game I own that can't hit a consistant 60fps is Arma 3, and now Spacehulk is another.

I read on the patch notes that this game had been hugely optimized, well I disagree.
I am not slamming the title, it is a great game but I am disappointed it doesn't run as it should on a big rig.


Edit - Anyone saying it runs smooth for them can only compare it with how I have it set up
"Vsync on, fantastic graphics and a constant 60fps 100% of the time"
Last edited by Chris; Feb 12 @ 1:37pm
Showing 1-7 of 7 comments
< >
Tribaal Feb 12 @ 1:30pm 
Interesting - I have a very smooth experience on a much smaller rig.
Chris Feb 12 @ 1:31pm 
60fps Constantly WITH vsync without a frame drop?
Nightshadow59 Feb 12 @ 6:23pm 
Same very smooth with vsync on. Ive never really looked to see what the frames stay at cause ive never had it not be smooth. Got a decent rig I7 with a GTX 570 with 8 gigs of ram. Not sure whats going on with your system.
supermoto10 Feb 14 @ 11:17am 
Smooth on my system too and i'm only running a GTX 280 with 4 gig of ram.
HAMM3R Apr 18 @ 2:16am 
Old-ish topic but I'll yank it up since I seem to have the same problem as the OP.

I used to have a 1.2GB GeForce GTX 570 and the game ran smooth between 80-100+ fps, zoomed in or out (2560x1440, Fantastic, no V-sync, i7 @ 4.5GHz, 16GB ram).

I didn't play Space Hulk for a while, in the meantime upgraded my gfx card to 3GB GeForce GTX 780 (DirectCU II OC) and now when I got back the game barely goes over 30 fps when zoomed out, even when there's nothing going on on the map except terminators idling where I deployed them. Changing the quality to 'Fastest' gives only some 10 fps more so it barely creeps above 40.

I don't know what's going on but it irritates the living crap out of me especially since the game isn't all that heavy on the graphics. Does anyone know if there's a fix for this? I tried searching the forums but found nothing.
Zuggi  [developer] Apr 22 @ 1:58am 
Unsure what the issue is as it seems to be related to the graphics card. Simplest thing to do is to upgrade the driver..og maybe search for people having issues with the same card in e.g. Unity Games.
Toutatrix Apr 23 @ 10:20am 
I noticed some heavy fps drops also, but only during the kill cam animation, it's like the animation becomes crazy sometimes as if it wanted to pass faster, resulting in heavy fps drops (from 100+ to 13).

Also it's like vsync isn't functioning since I can't get to the 60 limit whatever the option I choose : 0,1 or 2 (which looks obscur to me actually)

EDIT : lowering settings from fantastic to beautiful lower greatly the fps drops during kill cam, but I've noticed another bug : vsync has to be applied with each restart of the game.
Last edited by Toutatrix; Apr 24 @ 8:39am
Showing 1-7 of 7 comments
< >
Per page: 15 30 50