Khan.D.Man Sep 9, 2013 @ 3:19pm
Full Screen framerate very sluggish
Title says it all.

In windowed mode the framerate is fine. In full screen the game play is sluggish and suffers from about a 1-2 second latency, character movement and fire actions take this long to respond.

Anyone else experience this at all.

Cheers

KDM
Showing 1-15 of 22 comments
< >
bidinou Sep 10, 2013 @ 3:37am 
Just as a side note. I'm not affected by the aforementioned issue, but the framerate is definitely not synced to the refresh rate. It was also the case in the original game, actually. It feels like 25 / 30 FPS while a perfectly smooth scrolling would need 50 (on the Amiga) or 60 FPS (most PCs).

Having a perfectly butter smooth scrolling, reminiscent of most Amiga titles, would be nice.
Dean Demon Sep 10, 2013 @ 4:28am 
This does match the original Amiga version so 50 FPS is what you will receive
ThunderPeel2001 Sep 10, 2013 @ 5:35am 
Actually, as with all Amiga games, v-sync was standard -- all the frames were perfectly sychronized with refresh. There was never "tearing" in Amiga games!
bidinou Sep 10, 2013 @ 6:28am 
My message was not clear :-) There is no tearing indeed. There is no sync problem. However, this game (even on Amiga as far as I remember) does not have 50 FPS animations (probably something like 25 I guess, even if the picture is obviously still displayed at 50 Hz). It's not "butter smooth".

For instance, compare the Amiga scrolling in Lemmings 1 and Lemmings 2. The latter has 50 FPS and the former is less.

So, it's also the case in the PC port of Chaos Engine. There is not tearing, it's playable but it could be smoother.
Aulbath Sep 10, 2013 @ 9:55am 
I have the exact same issues, it's basically "unplayable" in fullscreen. For whatever reason, scaling it up to x3 or x4 is perfectly fine though.
Khan.D.Man Sep 10, 2013 @ 10:41am 
I have discovered, by turning off the Bloom effects, the frame rates in full screen are now the same as in windowed mode.

Seems the bloom effects are taking up an unusual amount of resource in full screen mode compared to windowed.
g Sep 10, 2013 @ 5:00pm 
I also have input lag, I hope it is fixed soon.
ThunderPeel2001 Sep 10, 2013 @ 6:59pm 
Originally posted by mahen:
So, it's also the case in the PC port of Chaos Engine. There is not tearing, it's playable but it could be smoother.

Nope. There is tearing on the PC version. It's especially noticable in fullscreen when you scroll left and right.
Last edited by ThunderPeel2001; Sep 10, 2013 @ 6:59pm
GODZILLA Sep 11, 2013 @ 8:06am 
Performance could be better in fullscreen here too - input lag is pretty bad and the framerate is visibly low. Still - a little better after the patch. And it would be nice if the joystick would actually work.
bidinou Sep 11, 2013 @ 2:51pm 
Originally posted by ThunderPeel2001:
Nope. There is tearing on the PC version. It's especially noticable in fullscreen when you scroll left and right.
Ah, I didn't notice it under Linux / KDE 4.11 (and I'm easily upset by tearing :), so it might depend on the platform & other factors.
But maybe it's not as shocking as tearing in the case of a bigger framerate (smoother) because it doesn't look as "clean" anyway.
ThunderPeel2001 Sep 12, 2013 @ 1:36pm 
Maybe it runs better on Linux in Fullscreen, but I can't see why that would be the case :-/ I have a very beefy PC than runs Bioshock Infinite with everything maxed out in full screen, completely smoothly, so I'm not sure why this port should have problems!
bidinou Sep 16, 2013 @ 12:28am 
ThunderPeel : I cannot answer your question, but I'm sure the developers or other people who know the underlying technologies being used coud have some assumptions / hypothesis. Let's hope it gets fixed ! Can you "force" the vsync in your drivers settings out of curiosity ?
WiZZyWiGG  [developer] Sep 16, 2013 @ 11:12pm 
As a few people have mentioned, those with performance issues could you try turning off Bloom and seeing if that helps at all? Would be good to know if this is the main cause.
ThunderPeel2001 Sep 17, 2013 @ 8:21am 
Hi WW, it makes no difference if Bloom (special effects) are turned off. I always turn them off anyway.

As I mentioned before, playing in X3 Windowed Mode works much smoother, strangely.

Here's some of my specs:

Windows 8
ATI Radeon HD 6870
Intel Core i7 3770K
16GB RAM
Last edited by ThunderPeel2001; Sep 17, 2013 @ 8:21am
Khan.D.Man Sep 17, 2013 @ 9:25am 
I am running an nVidia gfx card, and turning bloom off really helped. Maybe it is an ATI card specific issue, or a combination of ATI hardware and the bloom implementation in the game.

KDM
Showing 1-15 of 22 comments
< >
Per page: 15 30 50