Assassin's Creed IV Black Flag

Assassin's Creed IV Black Flag

View Stats:
Hughy Dec 1, 2013 @ 7:27pm
AC4BFSP.exe has stopped working FIX! (AMD Windows 7)
I had the same problem many have been posting about the game crashing on start.
I'm not too Windows sauve, so I'll do my best to explain how I fixed it.

Under the Event Viewer, the error event had "Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Assassin's Creed IV Black Flag\AC4BFSP.exe
Faulting module path: unknown"
Which was pretty useless information, but I clicked on the following event and got the information

Problem signature:
P1: AC4BFSP.exe
P2: 0.0.0.0
P3: 5285f99f
P4: StackHash_0a9e
P5: 0.0.0.0
P6: 00000000
P7: 14c14d74
P8: c0000005
P9: 00000008
P10:

StackHash_0a9e, was the only thing that seemed useful at all so I googled it and found the following forum post
https://forums.geforce.com/default/topic/549500/solution-for-stackhash_0a9e-errors-and-possibly-others-/

The instructions were to
"Go to Control Panel -> Programs and Features.
On the left-hand side, click on 'View Installed Updates'.
Under the 'Microsoft Windows' section, search for and uninstall KB2670838
Restart computer when prompted."

After doing this the game loads fine.

This may have also fixed my COD: Ghosts from not crashing, but I'm not sure if a patch was released while I was away from my rig for thanksgiving.

I hope this helps people.

Also if it does, please pay it forward and post the solution in other threads you have contributed to while troubleshooting the problem.
< >
Showing 1-12 of 12 comments
Red_devil Dec 2, 2013 @ 12:06am 
Thanks, worked also on libx264-138.dll error.
Jive Dec 10, 2013 @ 8:01am 
Thanks. This worked for me too and quite frankly can't believe it!! I tried everything in all forums to try and fix this issue where the game would crash on the startup screen with the dialogue box in the background saying 'AC4BFSP.exe has stopped working'. Seems astonishing that an old discrete Microsoft update would cause this
Anderson Dec 10, 2013 @ 10:23am 
Unfortunately it didn't work for me =/
Secksy_Josh Jan 1, 2014 @ 1:10pm 
Did this then got stuck on "preparing to configure updates" so i restarted it on safe mode to restore but got stuck on the loading screen and did not load. had to restart it 5 times before automatic reverting changes actually worked. An hour of my life i cannot get back and the first problem still not fixed
Asshole Geralt Jan 1, 2014 @ 2:51pm 
Didnt help... :( though it got to Abstergo Industries Presents this time instead of the very first screen.... :p
sionprawn Feb 23, 2014 @ 8:30am 
I never normally post messages but got to say BIG thank you, just waisted my whole Sunday going mad untill I saw this.
Hughy Feb 23, 2014 @ 11:10am 
I'm so glad this comment is still helping people. I wasted a day trying to figure it out too :-)
crysis2020 May 4, 2015 @ 1:13am 
Originally posted by Anderson:
Unfortunately it didn't work for me =/
=EGC= LyrickCZE Sep 29, 2015 @ 9:45am 
Having same error but I don't have that Windows update installed : /
Djtmk Sep 29, 2015 @ 10:00am 
I am getting that for windows 8 and when fraps is open. I need fraps to record
=EGC= LyrickCZE Sep 29, 2015 @ 10:57am 
I don't have Fraps at all. I might try to disable Shadowplay though, not going to record this. Already tried verifying game cache with no success.

Edit: And yea I also have Win 8 (x64)
Last edited by =EGC= LyrickCZE; Sep 29, 2015 @ 10:57am
Found a Real Fix

So Basically navigate to your ASBF steam folder > steamapps> common > Assassins Creed IV and then right click on "AC4BFSP.exe" and select properties, then go compatibility and check "run this program in compatible mode for" and choose your OS (Windows 10 = 8)
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Dec 1, 2013 @ 7:27pm
Posts: 12