twan2017 Feb 24 @ 5:42pm
Crashing, Low FPS, and Ultimately Disapointment
Well, I just purchased Assassins Creed 4 being that it was on sale. Anyway, once I downloaded it I verified the files to make sure nothing was missing. Nothing was and once I start the game for the first time it worked fine..... Until I started a mission. It ran at top about 35 FPS and I have a pretty nice rig and on MSI Afterburner it showed that my GTX 760 wasn't even running at a 100%. After about 5 minutes into the first mission which was hell running at such low framerates the game froze.. I've been researching and tried multiple things to fix it. Changing the graphics setting , going into the document and changing the height and weight, going into the Nvidia's control panel and turning on triple buffer and turning off vsync and also turning to run at best performance.... Nothing seems to work and in fact I did turn it off and turn it back on again and still nothing. It just keeps crashing. Please help it kinda sucks paying all this money just for it to not even work.. Thanks in advanced.
Showing 1-14 of 14 comments
< >
trek554 Feb 24 @ 5:51pm 
triple buffering does nothing from a cards cp nothing for DX games. and turning off vsync would mean that triple buffering would not be needed anyway as its a setting to use with vsync and does nothing without it on. again though triple buffering from cp is only for opengl games.

and how about listing the rest of your specs and the settings you were trying to run.
Last edited by trek554; Feb 24 @ 5:51pm
twan2017 Feb 24 @ 5:57pm 
Motherboard : Asus P8Z68-V PRO/GEN3
CPU : Intel i7 2600k
GPU : GTX 760 w/ 4gb of vram
PSU : Corsair TX750
Memory : 16gb Corsair ram
Storage : 120gb Kingston SSD & 1TB Western Digital Caviar Black

Those are my specs. Can you help me any farther? Thanks in advanced.
twan2017 Feb 24 @ 6:21pm 
Originally posted by trek554:
triple buffering does nothing from a cards cp nothing for DX games. and turning off vsync would mean that triple buffering would not be needed anyway as its a setting to use with vsync and does nothing without it on. again though triple buffering from cp is only for opengl games.

and how about listing the rest of your specs and the settings you were trying to run.

Motherboard : Asus P8Z68-V PRO/GEN3
CPU : Intel i7 2600k
GPU : GTX 760 w/ 4gb of vram
PSU : Corsair TX750
Memory : 16gb Corsair ram
Storage : 120gb Kingston SSD & 1TB Western Digital Caviar Black

Those are my specs. Can you help me any farther? Thanks in advanced.
Dark Fox Feb 24 @ 10:30pm 
Undo all your changes from the graphics card control panel, some console ports like this one dont like you messing with settings outside of the games own files.
Sonic's Pleasure Palace Feb 25 @ 3:10pm 
Great lol. I got this game with my GTX 760 and was kind of looking forward to it being a silky smooth game and experience...I should have been skeptical that it would be an unoptimized mess haha. What a way to promote your game! Geez why can't anyone do proper PC ports...
twan2017 Feb 25 @ 3:15pm 
Originally posted by † Sonic's Pleasure Palace †:
Great lol. I got this game with my GTX 760 and was kind of looking forward to it being a silky smooth game and experience...I should have been skeptical that it would be an unoptimized mess haha. What a way to promote your game! Geez why can't anyone do proper PC ports...

what is that supposed mean?
fnflq91 Feb 25 @ 3:24pm 
Originally posted by twan2017:
Originally posted by † Sonic's Pleasure Palace †:
Great lol. I got this game with my GTX 760 and was kind of looking forward to it being a silky smooth game and experience...I should have been skeptical that it would be an unoptimized mess haha. What a way to promote your game! Geez why can't anyone do proper PC ports...

what is that supposed mean?

Well aside from the "promoting the game" bit: A lot of people have gotten AC4 as a gift with 760's recently (myself among them) and have been looking forward to playing AC4. Hearing that it won't run properly with a brand new high end card is a bit of a dissapointment.
Smokey the Bear Feb 25 @ 3:25pm 
Triple buffering works on DX, no idea what the first post is talking about.

I use it on every single game.
twan2017 Feb 25 @ 3:25pm 
Originally posted by fnflq91:
Originally posted by twan2017:

what is that supposed mean?

Well aside from the "promoting the game" bit: A lot of people have gotten AC4 as a gift with 760's recently (myself among them) and have been looking forward to playing AC4. Hearing that it won't run properly with a brand new high end card is a bit of a dissapointment.

I know right
trek554 Feb 25 @ 3:27pm 
Originally posted by Smokey the Bear:
Triple buffering works on DX, no idea what the first post is talking about.

I use it on every single game.
triple buffering from the cp does NOTHING for DX games. if you think it does then you have no clue what you are talking about.
Last edited by trek554; Feb 25 @ 3:28pm
고수 Feb 25 @ 3:27pm 
"Here is your promotional code, good luck running it with your new card thought"

Huehuehuehue
Last edited by 고수; Feb 25 @ 3:27pm
Spawk Feb 25 @ 4:46pm 
Originally posted by JohnDoe:
"Here is your promotional code, good luck running it with your new card thought"

Huehuehuehue
http://www.youtube.com/watch?v=blpe_sGnnP4&index=66&list=PLrwnbK575LByauUcZgPWQpXFXzEbsLs99
Nuttydave Feb 27 @ 9:43pm 
i got a brand new computer 2 weeks ago this game constantly kept crashing and having problems as did other games

turned out my ram was defective and they said the video card was slightly loose, regardless they gave us 2 new sticks of ram and replaced the video card
they reintalled direct x and the drivers

game runs like butter and doesnt crash anymore

running a higher end i5 chip with a r9 280x

everythings as high as it goes on ultra settings
Smilodon Feb 28 @ 12:42pm 
Disabling PhysX helped a ton of people with low FPS issues - not sure about the crashing though.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Feb 24 @ 5:42pm
Posts: 14