Kaelexx Jun 13, 2013 @ 4:39pm
LaunchPad unable to Connect
I've had this problem since I've downloaded the game a few days ago. When the launchpad appears it just says it was unable to connect, and then nothing else happens. I can't find any answers anywhere since this is the steam version. Wondering if anyone else has this happen.
Showing 1-7 of 7 comments
< >
Crimson4assassin Jun 13, 2013 @ 8:58pm 
i have this problem too, trying to fix, no solution yet sorry.
Grimjaw Jun 14, 2013 @ 3:40am 
Happening to me too, though was working earlier today no problems, i'd say the servers are down or sumthin.
Grimjaw Jun 14, 2013 @ 6:17am 
Thanks frost, this helped.
Alesso Jul 15, 2013 @ 1:31am 
i tried deleting the "LauncherPad-User.ini" but i still have the same problem? :(
Mr. Owl Aug 13, 2013 @ 2:35pm 
Start > Computer > C: > Program Files > Steam > Steamapps > Common > dc universe online > Double click on "RegionalSettings.bat"

A window should appear for a brief second and disappear, after that try launching
Nalazi Apr 15, 2014 @ 7:11am 
I recently downloaded this game and this problem came up. I tried Mr.Owl's solution but when I looked inside my folder, I was unable to find RegionalSettings.bat
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jun 13, 2013 @ 4:39pm
Posts: 7