TheNon-Creeperslayer01 Jun 25 @ 8:46pm
Help with launcher
It will let me open the launcher and let me click play but it crashes soon after what do I do?
Showing 1-3 of 3 comments
< >
Djozar Jun 26 @ 4:02am 
forget running from Steam...all the fixes that everyone used before don't work...I have spent the last week uninstalling and reinstalling the game at least 5 times a day. I have tried every method, every guide, EVERYTHING...only way I can play this game is DIRECTLY from the SOE website.Steam will tell you to go to DCUO/SOE to get the fix and DCUO will send you back to Steam since it was downloaded from Steam and has Steam signatures and certificates in the files. Means I can't access my achievements from Steam but the game has achievements for skill points ingame so Steam isn't necessary. Planetside 2 and all other SOE games work just fine for me. Only the DCUO launcher has any issues. Steam Support will come in here and put their one cent in (ain't worth the two cents they think it is) and will equate to you uninsalling, reinstalling, sending tickets, ignoring tickets, and you'll be here for months trying to get it to work. I even tried copying the SOE launcher and just editing the .ini launcher files as per other threads here and still hang up after logging in right before character selection.
Rangod Jun 27 @ 12:19am 
I got the same problem
Rangod Jun 27 @ 6:27am 
DON'T BOTHER with the Steam client got to the DCOL SOE website and get the game from here https://www.dcuniverseonline.com/home works fine with out STEAM
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jun 25 @ 8:46pm
Posts: 3