DC Universe Online

DC Universe Online

View Stats:
I'm Batman Jun 24, 2014 @ 9:59pm
Launchpad unable to connect?
so i just downloaded this game and when i opened it, i got this error:

LaunchPad was unable to connect. Please check the network connection or try again later. If the problem persists, please visit http://www.soe.com/help for assistance.

i tried fixing this problems in many different ways, but just cant fix it. i tried doing the regionalsettings thing, i tried resetting my browser, firewall is allowing the program, i tried running it in different compatibility modes, but it just wont work.
< >
Showing 1-10 of 10 comments
ShutTheFullCup Jun 25, 2014 @ 4:19am 
Me and my friend just download this game as well and are having no luck on actually running it. We get the error message and sometimes it actually starts up but the force quits on us.
Djozar Jun 26, 2014 @ 4:12am 
delete from Steam and use SOE version..
ShutTheFullCup Jun 26, 2014 @ 4:01pm 
Mine was going screwy cause of the sever being down for maintence.
My friend however had a different problem and fixed it by this. http://www.youtube.com/watch?v=bJ6anVwndKA
I'm Batman Jun 26, 2014 @ 9:02pm 
Originally posted by Djozar:
delete from Steam and use SOE version..
i have tried that but that dont even launch
Shalom Jan 17 @ 9:41am 
H1Z1 UNABLE TO CONNECT! LaunchPad was unable to connect. Please check the network connection or try again later. If the problem persists, please visit http://www.soe.com/help for assistance. ЧТО ДЕЛАТЬ ПАРНИ!!!????
Arkham Knight Jan 17 @ 11:00am 
just go into the local files and use the larchpad form there. it work for me
Last edited by Arkham Knight; Jan 17 @ 11:00am
Arkham Knight Jan 17 @ 11:03am 
or just do what this guy said. go into the LAN settings in the internet connection settings. you might have a proxy virus. if it keeps cheching the proxy settings
Last edited by Arkham Knight; Jan 17 @ 11:04am
Arkham Knight Jan 17 @ 11:06am 
because proxy virus will take your connection to a deffent server
SaiyanYoshi50 Nov 18 @ 3:19pm 
Originally posted by Arkham Knight:
just go into the local files and use the larchpad form there. it work for me
doesn't work for me
Owedevil Nov 22 @ 9:56am 
A little late on this but here it is.
Some (possibly) helpful info

Originally posted by ♠๖ۣۜƘƗƬƬƴcrλfter™:
so in detail, the game says your playing it but it closes then your profile icon goes blue.
go to steam > C:\Program Files (x86)\Steam\SteamApps\common\DC Universe Online
and then locate LaunchPad.exe and Rightclick > Properties > Compatibility > privilege level > Run this program as an administrator
This should fix the problem and if this game works on mac sorry if i didn't help if you even have this problem.
Originally posted by LadyLightning:
This (clicking play on the launcher but nothing happening) tends to happen, when the system doesn't have the minimum system requirements:
Originally posted by Frost:
Problems and possible solutions.
Problem: Launcher stuck at the black screen.
Delete "LaunchPad-User.ini"(or LaunchPad-User if file format is hidden) in the "Steam\steamapps\common\DC Universe Online\" folder.
Update Flash Player[get.adobe.com] for Internet Explorer(Launcher is based on it).
Replace "LaunchPad.exe" in the "Steam\steamapps\common\DC Universe Online\" folder with version of this file from official site[www.dcuniverseonline.com](probably this works for the eu version[www.dcuniverseonline.eu] too)

Problem: "Unable to download Bad stream" error
Solution: Disable your firewall/anti-virus. (I recommend making exceptions instead of disabling.)

Problem: Cant launch the game after update - game crashing.
Solution: Click the "Advanced tools" option in your launcher and then go to "Validate game assets -> Validate"

Problem: LaunchPad was unable to connect.
Solution: Double click on "RegionalSettings.bat" in the "Steam\steamapps\common\DC Universe Online\" folder.

If nothing from this guide works you should contact SOE Customer Support: http://help.soe.com/

Originally posted by Frost:
If anyone got any other helpful info about some possible game technical bugs, feel free to post them in the comments (on his account page.)
Google keywords DCUO launcher fixes and you'll get multiple helpful sites including "http://segmentnext.com/2011/01/12/dc-universe-online-errors-crashes-freezes-fixes/" which has some good info.
For those having issues with the update (I.E. the update starts gets a small way through then the entire launcher just disappears).
Open up your task manager and go to processes, have it sort by alphabitical. Now open launchpad, watch the task manager closely. you should see two awesomium processes there. Now quickly end one of the two awesomium processes before the update starts (this may take a couple tries).
Originally posted by Owedevil:
Update your software, particularly your graphics drivers, make sure DCUO is allowed in your system security, if you dont have any system security get one and scan your PC for maleware, run DCUO as administrator, validate game assets through Steam, if nothing works reinstall your game.

Tons of good general info can be gotten here, but careful of outdated/obsolete things;
Originally posted by LadyLightning:
Almost all of your questions can be answerd with this:

Originally posted by LadyLightning:
Remove all adware and malware from your PC.

Then do this: https://help.daybreakgames.com/app/answers/detail/a_id/37726/kw/
Originally posted by Frost:
Originally posted by Bardor:
make sure launchpad.exe file isnt in compatability mode it wont start that way i had it in that for the longest time started working as soon as i turned it off.

Originally posted by TreDizzyDog:
Product key for DCUO is invalid. .... put the code in on the DCUO website and not on steam.

Originally posted by [DSL:
TimTheBretonFromCyrodiil] It seems like this game REALLY does not like my computer...

It crashes whenever I:
-Disable Fullscreen
-Disable V-Sync
-Mess with ANY settings that affect the window resolution or size.

Also, the steam overlay broke after my first time running the game.

I'm on Windows 10, I have 12 gigs of ram, a GeForce GTX 760, And an AMD FX 6300 x6 processor.

Can anyone help me out here?

UPDATE:I figured it out. NVidia Shadowplay, the program I was using to determine FPS, was ♥♥♥♥ing with it.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50