Foucheur Aug 8, 2013 @ 4:06pm
The game won't Start (Rogue Legacy has stopped working)
Hi everyone !

Last week, i had some problems with Rogue Legacy. The Game did not want to start because of NET Framework 4.0... i fixed it and reinstall the game and now, when i launch RL i have this windows :

"Rogue Legacy has stopped working"...

I tried many things... (Right access in the propreties, reinstall every software...)

Please help me :(
Showing 1-4 of 4 comments
< >
Cellar Door Games  [developer] Aug 9, 2013 @ 4:29pm 
We'll need a little more information regarding the crash. If you can access your Event Viewer to see if anything else might be causing the problem, it would help us out.

Access the event viewer:

- In Windows XP, click the Start button, choose Run, and type in eventvwr and press Enter.

- For any other version of Windows, click the Start button, click into the "Search programs and files" bar, and type in Event Viewer and press Enter.

Navigating the event viewer:

- To make things as easy as possible, I've attached a picture of what your event viewer should look like. On the left side, please make sure you are in the correct folder (Windows Logs > Application). Then in the centre, please scroll down until you see an Error with a source that says "Application Error" or ".NET Runtime". The "Application Error" is just a log of your APPCRASH, but the ".NET Runtime" error is what we're interested in. If you could paste the error message in the General tab below it, it will help us isolate the issue you're experiencing.

Hope this helps!

http://www.cellardoorgames.com/temp/eventlog.jpg
Foucheur Aug 10, 2013 @ 1:29am 
Thanks for help :)


Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileLoadException
Stack:
at RogueCastle.Program.Main(System.String[])
Cellar Door Games  [developer] Aug 10, 2013 @ 10:09am 
Have you tried the instructions in this thread:

http://steamcommunity.com/app/241600/discussions/1/846957366857195088/

These steps should fix that particular .NET exception. An alternative method would be to do the following:

Go to C:\Windows\Microsoft.NET\assembly and adjust the settings on the GAC_32 and GAC_MSIL folders as follows:

Right click, go to "Properties"
Select "Security" tab
Click on "Advanced" button
Select "Owner" tab
Click on "Edit" button
Select "Administrators"
Select "Replace owner on subcontainers and objects" option
Click "Apply"
Foucheur Aug 11, 2013 @ 4:04am 
Great ! Awesome ! It works !

Thank you so muuuuuuch !
Showing 1-4 of 4 comments
< >
Per page: 15 30 50