Rogue Legacy > General Discussion > Topic Details
nthrow Apr 18 @ 10:14am
RL crashing on start [LINUX]
First of all, I love the game and really appreciate the work put into it. I just reinstalled it after a couple weeks (during which I moved to a new Linux distro). Now I'm experiencing an immediate crash upon starting the game. Here's the crash log for more info:

System.DllNotFoundException: opengl32.dll
at (wrapper managed-to-native) OpenTK.Graphics.OpenGL.GL/Core:GenFramebuffers (int,uint*)
at OpenTK.Graphics.OpenGL.GL.GenFramebuffers (Int32 n, System.Int32& framebuffers) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.SDL2_GameWindow..ctor () [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.SDL2_GamePlatform..ctor (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.GamePlatform.Create (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.Game..ctor () [0x00000] in <filename unknown>:0
at RogueCastle.Game..ctor (System.String filePath) [0x00000] in <filename unknown>:0
at RogueCastle.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0

Please let me know if any information about my system would be relevant here. Looking forward to getting this sorted.
Showing 1-3 of 3 comments
< >
Crazy Dave / Chicken Apr 18 @ 10:24am 
Rogue legacy uses Microsoft XNA, so only can run on windows, or try reinstalling the game
nthrow Apr 18 @ 10:37am 
I noticed the Microsoft Xna Framework errors in the crash log, but this game definitely does run on Linux and it is still labeled as Linux-friendly in the Steam store. Here's some more info on my video card:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Lenovo Device 21da
Flags: bus master, fast devsel, latency 0, IRQ 49
Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 5000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features
Kernel driver in use: i915
Kernel modules: i915
Last edited by nthrow; Apr 18 @ 12:04pm
smacd Apr 18 @ 4:13pm 
I've been playing RL in Ubuntu 13 (which is actually running in VMware Player on a Win7 box), so its definitely playable in linux. I did notice some issues with it crashing during the splash screen yesterday several times as well, but after rebooting my VM its been working fine. I have noticed some slowdown sometimes, which can get pretty bad (1 frame every 10 seconds or so), but I'm assuming its more because of playing in a VM rather than the host OS.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50