ShamisOMally Jun 2 @ 10:23pm
To AMD users having problems with graphics glitching out, roll back to 14.4 WHQL drivers
The problem right now with State of Decay and AMD users is from the 14.6 1.0 Beta drivers, which are causing problems with a lot of DX9 games ATM, and in the case of State of Decay its causing the various geometry stretch out into infinity.

The game runs perfectly fine on 14.4 drivers, so unless you REALLY need to play Watch Dogs, just install the 14.4 drivers to fix the games graphics glitching out.
Showing 1-12 of 12 comments
< >
massdev Jun 2 @ 11:10pm 
Just some fyi I use the 14.4 drivers and I was having all sorts of issues with my profiles since the incremental patches for the lifeline dlc. I purchased the dlc still had issues, with black screens and game freezes, then after searching the internets I ensured that application settings override all amd CCC enchancement and once again still had no joy.

Then I read on the forums that they rolled back some patch that was messing with profiles, I then created a new profile starting a new save and haven't had any issue since then in breakdown or basic SOD however there are still weird artifacts particularly with shadows in lifeline.

I would imagine that given enough time these things will be ironed out but I think getting to the bottom of what has went wrong since lifeline isn't as simple as use 14.4 drivers.
The doctor is in Jun 3 @ 1:17am 
thanks but i dont ever use beta drivers cause they are nothing but problems, like you post about.
Niko Jun 3 @ 5:20am 
Originally posted by The doctor is in:
thanks but i dont ever use beta drivers cause they are nothing but problems, like you post about.

I tought the same, but i had to change my mind in order to be able to play watch dogs, was having 22 FPS no matter what graphic level. Now i'm able to play it at decent frame rate. Let's just hope they are able to fix this in the game, if not the case we will have to wait till new stable drivers...
Ronald Raygun Jun 3 @ 5:44am 
I rolled back my drivers last night and I'm still having the same abysmal artefacting as I was before. I'm certain this isn't an overheating issue (monitoring with OpenHardwareMonitor, temps never got any higher than usual in-game.) so I'm not sure what could be causing it still. Any ideas? I should add that I'm experiencing artefacts in Lifeline and Breakdown, though I haven't tried the base game yet.
Niko Jun 3 @ 6:50am 
i'm gonna try the others too, but i think the problem is software related. Maybe a modification in the render process that's not optimised for AMD graphics solutions.

I'm getting bored to see that lot's of recent games dont work well with AMD. Come on, every time a game is out, it's always the same question: what graphics constructor will be supported by the game? This constructor war is starting to ♥♥♥♥ me off, since it's always the players who pay the price. When it's a NVIDIA game, 40 % of players are tied to low performances, and When it's a AMD game, the others 60 % are screwed...
ShamisOMally Jun 3 @ 11:44am 
Originally posted by Ronald Raygun:
I rolled back my drivers last night and I'm still having the same abysmal artefacting as I was before. I'm certain this isn't an overheating issue (monitoring with OpenHardwareMonitor, temps never got any higher than usual in-game.) so I'm not sure what could be causing it still. Any ideas? I should add that I'm experiencing artefacts in Lifeline and Breakdown, though I haven't tried the base game yet.

Like I said I was only having problems with 14.6 Version 1.0 beta drivers, game works perfectly fine with 14.4 drivers.

I even turned my overclocks down to stock, and below stock for the game and 14.6 beta's refused to work, 14.4's work great for me, same deal on Guru3D where tons of people rolled back to 14.4 and game is working fine.
Ronald Raygun Jun 3 @ 1:27pm 
Okay, I got it working right, here's how: I completely uninstalled all of my AMD drivers using the install manager (again), restarted my system (again), and, finally, reinstalled the 14.4 drivers (again). Threw in another restart at the end of the process for good measure and now I'm golden. Not sure what went wrong the first time, but it's all good now. Thanks for the helpful post, I had almost forgotten I'd installed the beta drivers in the first place let alone thought to roll them back :P
ShamisOMally Jun 4 @ 5:14pm 
To those still having trouble, like Ronald said the problem stems from installing 14.4 drivers directly over 14.6

You're going to have to uninstall the drivers, reboot, as a precautionary step you can reboot to safe mode and use display driver uninstaller from Guru3D and clean out your old settings, reboot to desktop, install 14.4's, reboot computer and you should be good to go
Dedlokk Jul 1 @ 11:36pm 
Crytek's new Free to Play fps shooter Warface also seems to suffer from the same issue State of Decay has with graphical geometry stretching. Heats up my card quite quickly, drops fps, and causes very high gpu usage. Seems to maybe be an issue with the 14.6 drivers and the engine these games use seeing that both use cry engine 3. Rolling back to 14.4 drivers solves the issue of course.
Last edited by Dedlokk; Jul 1 @ 11:36pm
Lord Flashheart Jul 2 @ 6:41am 
Good thing I found this post, screen tearing was insane with the 14.6 driver. Thanks :)
ShamisOMally Jul 2 @ 7:16am 
Originally posted by BlackFlame:
Crytek's new Free to Play fps shooter Warface also seems to suffer from the same issue State of Decay has with graphical geometry stretching. Heats up my card quite quickly, drops fps, and causes very high gpu usage. Seems to maybe be an issue with the 14.6 drivers and the engine these games use seeing that both use cry engine 3. Rolling back to 14.4 drivers solves the issue of course.

As it is right now, most DX9 games have problems with the 14.6 drivers

Why AMD doesn't FIX this, hell if I know
Barl0we Jul 3 @ 3:27pm 
You think using the 14.6 drivers might be what's causing me to get Blue Screen of Death when I try to launch the game?

I mean, I could launch the game two times, and now it just BSOD's on me whenever I try :/
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Jun 2 @ 10:23pm
Posts: 12