Ittle Dew > General Discussions > Topic Details
Oakleaf Jul 24, 2013 @ 6:13am
controller issue
Hi
I bought Ittle Dew and used my Xbox controller to play it. It worked well first but next time I played the game the character was automatically running like if the stick was stuck. I have tried to re install the game and a lot of other stuff but I can't get it to work.
Anyone know how to fix this issue?

I'm using windows 7 and a "PC Wireless Gaming Receiver for Xbox 360 Controller"
Showing 1-15 of 58 comments
< >
.pxl | Haku  [developer] Jul 24, 2013 @ 7:04am 
We've never encountered this error before. Does other games auto move as well?
Oakleaf Jul 24, 2013 @ 7:35am 
No, other games works perfectly with the controller.
.pxl | Haku  [developer] Jul 24, 2013 @ 7:38am 
That's strange, did you mess with the key bindings in the launcher?
Oakleaf Jul 24, 2013 @ 8:09am 
Yeah, it said joystick 0 and I was using joystick 1, but this was working a little while.
Oakleaf Jul 24, 2013 @ 8:35am 
Is there any way to reset the key bindings in the launcher? I have tried to re installing the game but the settings was still saved.
LAMP Jul 24, 2013 @ 3:06pm 
Oh awesome, I've had the same issue and I thought I was just some weird edge case. I had to rebind everything in setup, since the setup lists Joystick 0 as the default for all relevant bindings- except the map movement controls, which are not bound to the controller at all by default. After doing that, it worked fine for the first session with the controller, but it hasn't worked since.

(There was a brief period where I was able to trick it into using the d-pad by binding thehorizontal axis to the horizontal d-pad axis and the vertical to the horizontal on the right analog stick, but this also only worked for one session so you can probably disregard that.)

I hope that I've provided any little insight at all for this, because I still completed the game and loved the hell out of it, but it'd be easier to gift/recommend if the controller support was stable.
DarthSyphilis08 Jul 24, 2013 @ 6:52pm 
having the same issue. I try to customize the controller settings, but it wont even detect the d-pad. When I start the game the character just wants to move right.
WC Jul 25, 2013 @ 4:30am 
I'm having the same issue. Win8-64. Character wants to run automatically. I tried remapping and ended up with him running in a different direction. I noticed that there were 2 controllers in my control panel, so I uninstalled my drivers for my Razer Nostromo. And I'm back to the original problem.
Oakleaf Jul 25, 2013 @ 5:07am 
I got 2 xbox controllers, could that be a problem?
Btw, if i remove the battery from the controllers the problem is still there.
WC Jul 25, 2013 @ 9:34am 
Also, my controller is not wireless. It's the wired 360 controller.
DarthSyphilis08 Jul 25, 2013 @ 2:33pm 
yeah, I have win 8-64, a razer orbweaver that I tried disabling to see if it was the culprit, but the same results. My controller is a wired Power A fusion. Its a tournament style xbox 360 controller.
DarthSyphilis08 Jul 25, 2013 @ 3:09pm 
So, this is what I was able to do, but I have to do it every time I start the game, because it doesn't seem to save my settings or something like that. I map the configuration like so:
Horizontal Joystick 1 axis 0 (Analog Joystick)
Vertical Joystick 1 axis 1 (Analog Joystick)

This next part is important or else it doesn't work for me. Go down and find the second set of
Horizontal and Vertical controls. (Below the "Map" setting)

Horizontal Joystick 1 axis 5 (D-pad)
Vertical Joystick 1 axis 6 (D-pad)

Give it a try. And remember you'll have to do this EVERY TIME you launch the game! Hopefully they can fix this.
LAMP Jul 25, 2013 @ 5:13pm 
I can confirm that Darth's fix works: I was able to get my wired 360 controller to work by binding everything as described, and then after closing and reopening the game the controller went back to being non-functional, although the Y axis was just flipped on the d-pad so I was able to navigate down to quit instead of having to close it through other means.
WC Jul 25, 2013 @ 6:20pm 
Yeah, I tried binding the d-pad instead of the analog stick, and that worked except that it was upside-down on the vertical axis. Ugh. I'll have to try binding the second set to the d-pad instead and see what happens. Thanks!
TrolleFar Jul 26, 2013 @ 1:38am 
Hi, one of the old developers here.

I have previously experienced some problem with 360 controllers and Unity (which the game is made with). Some other games could use the controller, but Unity required the official Microsoft drivers to be installed in order to work correctly with the controller.

To check if they are installed, just press the "xbox" button on the controller when you are at the windows desktop. A little menu should appear on the screen.

If it does not, try installing the drivers http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows and restart the game.
Showing 1-15 of 58 comments
< >
Per page: 15 30 50