MotoGP™13 > General Discussions > Topic Details
RetroGamer Nov 2, 2013 @ 3:44pm
Poor frame rate after 1.2 patch
Hi ever since the patch my frame rate is now very choppy with vsync on. if i turn it off, then it gets better, but then of course i have to deal with screen tear. GFX is an ATI 7950, 2600k 8gb ram, game running off an SSD. So its not my hardware. As i said, the game ran a lot better before the patch. Anyway idea's ? As it stands it looks awful.
Showing 1-12 of 12 comments
< >
Kyllin Nov 2, 2013 @ 7:38pm 
agreed
snu_snu Nov 2, 2013 @ 7:52pm 
I thought it was my imagination or because I was trying a different track, but come to think of it I've noticed the same.
Last edited by snu_snu; Nov 2, 2013 @ 7:53pm
RetroGamer Nov 3, 2013 @ 9:36am 
yes, after spending some time, upgrading all my drivers, trying different settings, such as no FSAA, turning off graphical enhancements, which really I shouldn't have to do, given my hardware for what is a standard looking game AT BEST, it still runs horribly. what looks between 20-30fps. Whereas before, it ran mostly at 60fps, with the kind of stutter you'd expect from a poorly exectuted direct port of a console title. Bad as that was, which left me the sinking feeling of being a huge motogp fan, and paying full price, expecting something to blow me away but just left me with meh.... this now being stuck at such a low framerate is beyond bad. so much so, it makes me think to never pay full price on a game again. This is the sort of junk that is really killing the pc market. Such a shame for us PC gamers. We spend a fortune on the latest hardware, and then the game devs as the ones who made this title, get lazy and fob us off with this junk... a bad day for video gaming.
snu_snu Nov 3, 2013 @ 3:12pm 
Thanks for the tip for turning off vsync. It helped a lot with getting rid of the choppy frame rates, but as you noted the screen tearing is more prevalent.

I wonder if there is a trick to getting the vsync working without the choppiness, like the trick they had with the black screen on the top half of the screen issue they had before.

There's a lot of potential in Motogp 13, but a lot of silly small problems that make the experience poor which wouldn't be so bad if they actually tried to keep up with updates. Shame.
Spunkfire Nov 4, 2013 @ 6:35am 
Same hear 60fps down to 20/30 patch fixed sweet FA but broke all sorts this game has got worse not better now i'm left bitter,a lot of my friends wanted to buy this game but i had to tell them to leave it alone as milestone dont care about it.Motogp 2014 should be a codemasters game they do driving games a lot better.Gp bikes also blows this out of the water maybe they should give the next license to piboso now he can code my 2 cents.Milestone are amature/lazy/incapable at best as this latest patch shows untested and pushed out the door.
Doctor Hades Nov 7, 2013 @ 2:56pm 
I'm getting 30 fps too with the retail disc version and the v1.2 patch. It was running at 60 fps constantly before with v-sync on. Not only that but I'm now prompted to insert the DVD to play the game which didn't happen with v1.0 or v1.1! Annoying. I can't believe how rough and buggy Milestone's games are.
tigereyezz Nov 8, 2013 @ 10:38am 
Hey Milestone any answer on this issue?!

Is there AT LEAST any way to revert my game back to b4 patch-status?!

I'd really love to play but right now it's IMPOSSIBLE due to the above mentioned problems, when it was running GREAT b4.
realkman666 [FR] Jan 16 @ 4:29am 
Any fixes for 30 fps?
Oh, the game V-sync goes to 30, but the Nvidia settings let it go to 60. Great job, guys.
Last edited by realkman666 [FR]; Jan 16 @ 4:40am
Doctor Hades Jun 24 @ 2:45pm 
Disable in-game V-sync and force through the graphics driver profile seems to work great for me as the game now runs at 60 FPS, albeit with some hitches. GTX 780, 16 GB, i7-4770K and Windows 8.1 Pro by the way.
Putz Jun 25 @ 6:39pm 
yes, turn off vsync on the launcher..use vsync from nvidia control panel or amd catalyst instead..that's fix my problem ;)
RetroGamer Jul 14 @ 11:13am 
Still doesn't work for me. With game VSYNC to off, and forced to On, in my Catalyst, the game is a screen tearing mess. I would have probably bought MotoGP14 had this been fixed. But you know what, (actually ♥♥♥♥♥ that lsat bit !!! it was still a micro stuttering mess, even at 60fps) Anyway, where was I ? Yes a company that doesn't care enough to fix such a huge graphical glitch, is never going to see my money. I'm even hearing that the new MotoGP14 on the PS4 runs only at 30fps... What a joke Milestone is.. Whoever is in charge over there, needs to be fired !!!! and the devs should probably stick to making flash games ! and not full retail titles.
Last edited by RetroGamer; Jul 14 @ 11:13am
realkman666 [FR] Jul 14 @ 11:41am 
Still a console port. Always console ports. Milestone. ;_;
Showing 1-12 of 12 comments
< >
Per page: 15 30 50