MotoGP™13 > General Discussions > Topic Details
dr.x913 Nov 8, 2013 @ 3:44pm
failed creating the direct3d device - Help?
Hi,

I have just purchased the champions DLC, however whenever I try to load the game is get a popup message "failed creating the direct3d device", I was playing the game only a few weeks ago and it was fine. I have uninstalled the game and re-installed it, I have tried to set my resolution Launch parameters, I have updated my GPU drives but nothing works. Has anyone had a problem like this? Does anyone know how to fix it? No other game in my Steam library is doing this.

AMD Radeon HD 7970M
Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz (8 CPUs), ~2.4GHz
16 GB RAM

Thanks!
Showing 1-2 of 2 comments
< >
dr.x913 Nov 8, 2013 @ 3:58pm 
UPDATE: I have also done this and it still failed

Exit Steam entirely.
Browse to your MotoGP 13 installation folder (Usually C:\Program Files\Steam\steamapps\common\MotoGP2013\)
Run the following installers:
...\Steamapps\common\MotoGP2013\DirectX\DXSETUP.exe
Reboot your computer and test any issues again.
KING KONE Mar 27 @ 3:57pm 
You probably have already figured this out but... I just bought this game and got the same error msg. failed to create the direct 3d device. all I did was when you hit play and the configuration menu comes up. go in to the video setting and un check the setting "Wait for Vsync" I did this and the game worked fine.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50