Mizkelele まあちん Mar 25, 2014 @ 6:04am
Crashes on Mac
Hello, I bought this game recently, reminded me of my childhood, Anyways.. When I'm starting it on my mac it crashes, no error messages...nothing. Can anyone help me?
Showing 1-15 of 21 comments
< >
MaxSavini Apr 5, 2014 @ 2:30pm 
I have the same thing - the game doesn't start :(
Mizkelele まあちん Apr 5, 2014 @ 10:57pm 
:/
MentalFloss Apr 8, 2014 @ 11:56am 
Myself as well. We Are Not Alone.

Have either of you filed a ticket yet with either Steam or the developer? I've just checked in here first so far, but we may all have the same issue.

Here's what I get after the crash in my console log:

2014-04-08 2:47:55.000 PM kernel[0]: process steam[1348] caught causing excessive wakeups. Observed wakeups rate (per sec): 409; Maximum permitted wakeups rate (per sec): 150; Observation period: 300 seconds; Task lifetime number of wakeups: 45001
2014-04-08 2:47:55.464 PM ReportCrash[1679]: Invoking spindump for pid=1348 wakeups_rate=409 duration=111 because of excessive wakeups

note: PID 1348 in that error may have been Duke Manhattan's PID before it quit out.
Maverick Apr 16, 2014 @ 1:28am 
I have the same problem when you turn on the game icon disappears ;/
MentalFloss Apr 16, 2014 @ 7:01am 
I submitted an email to the developer last week but haven't heard anything back yet.
Maverick Apr 16, 2014 @ 7:16am 
ok :( How will you know something about this let me know. Thx
MentalFloss Apr 17, 2014 @ 9:57am 
Yeah I'll come back here if I find out anything. If others are reading this thread and have the same issue, there's no need for you to post in this thread to get up dates -- just click the Subscribe To Thread (or similar wording) button in the top upper-right of this entire message thread.
Maverick Apr 22, 2014 @ 7:17am 
Hi
I know how to turn on the duke nukem. You have to click the right mouse button on the Duke Nukem select properties then local files. Then select browse local files. Click on the icon Duke nukem and change the renderer DirectX to OpenGL and click Play :)
http://i.imgur.com/TylnNDW.png <--- see here
I hope I helped :)
Last edited by Maverick; Apr 22, 2014 @ 7:23am
MentalFloss Apr 22, 2014 @ 7:24pm 
Oh man I can see why the crash is happening. Sounds like bad DirectX tanslation through WINE (which it's running in since it wasn't ported to OSX) and OpenGL likely works better as that's what OSX uses natively.

But I'm not able to get to the same Settings screen you are.

Once you're looking at the "Duke Nukem Manhattan Project" listed in Finder, how do you get to the Settings screen? Is it a double-click to run it and then it presents the options? My copy of Duke Nukem just sits in my Dock (even though it's running) and doesn't run the game. Actually now that I've run it once and had to Force Quit it it won't run again until I reboot my computer. :( (just shows in the Dock and then quickly pops away)
Last edited by MentalFloss; Apr 22, 2014 @ 7:26pm
MentalFloss Jul 7, 2014 @ 5:29pm 
Oh hey, if anyone finds this thread again in the future, the message above left by Marcinx199 above has the right idea, but I had to take it a step further: I had to update the WINE wrapper used to get Duke Manhattan running.

You may need to go to winehq.com and install the currenct version of WINE (or winewrapper) first.

Then follow Marcinx199's steps to browse the local files, but you'll want to run "Wineskin" inside Finder. Once it runs, click on Advanced, then click the Tools tab, and under Wrapper Tools section of the screen click the Update Wrapper button.

Until I did the steps above I couldn't even run Duke Manhattan and get the configuration screen where I could select OpenGL instead of DirectX.



Last edited by MentalFloss; Jul 7, 2014 @ 5:29pm
rennais0101 Aug 13, 2014 @ 4:37am 
Bought it yesterday, y mac is on mavericks (the last version) and it's impossible to play to this game. Please refund, or find a quick solution. This thread begun nearly 6 months ago...
Mizkelele まあちん Aug 13, 2014 @ 5:22am 
Originally posted by rennais0101:
Bought it yesterday, y mac is on mavericks (the last version) and it's impossible to play to this game. Please refund, or find a quick solution. This thread begun nearly 6 months ago...
Have you read this?
Minimum:
OS:OSX 10.6.8 or later
Processor:Intel Core Duo 2GHz+
Memory:1 GB RAM
Graphics:64MB Video memory
Hard Drive:235 MB HD space
dv8godd Aug 13, 2014 @ 8:30am 
Originally posted by Kazutoki:
Have you read this?
Minimum:
OS:OSX 10.6.8 or later
Processor:Intel Core Duo 2GHz+
Memory:1 GB RAM
Graphics:64MB Video memory
Hard Drive:235 MB HD space

If he's running Mavericks, he's got a machine that beats those specs. Oldest Mac capable of running Mavericks (a 2007 iMac) exceeds those requirements.
Turbo Aug 24, 2014 @ 10:28pm 
Works fine on my 2012 iMac running Mavericks, but does not work on my 2013 Macbook Pro Retina running Mavericks. This isn't native, it runs under Wine.
Turbo Aug 25, 2014 @ 12:52am 
In the Wineskin screen options, I changed 'rootless' to full screen and it worked. I changed it back and it continued to work...
Showing 1-15 of 21 comments
< >
Per page: 15 30 50