Duke Nukem 2 > Discusiones generales > Detalles del tema
Roxor128 10 de Jul, 2013 a las 1:29
Too fast!
I think you've goofed up on something, because compared to my original copy of the game in my own copy of DOSBox, this one runs like it's on fast-forward.
Mostrando 1-11 de 11 comentarios
< >
KickinChicken 10 de Jul, 2013 a las 5:35 
Maybe it's your machine?
Roxor128 10 de Jul, 2013 a las 5:47 
Tried loading it up in my copy of DOSBox instead of the one which shipped with this version and it runs normally. Maybe the copy which ships with the game is mis-configured?
KickinChicken 10 de Jul, 2013 a las 5:55 
They both run the same for me. (I have all my old Apogee games on a CD.)
Komenja 14 de Jul, 2013 a las 4:18 
You can slow down the game speed in the game options menu.
Roxor128 14 de Jul, 2013 a las 4:32 
Publicado originalmente por Komenja:
You can slow down the game speed in the game options menu.
The game's settings aren't the problem. The problem is that the emulator runs too fast. The game runs just fine in my own copy of DOSBox, though.
Frederik Schreiber  [desarrollador] 15 de Jul, 2013 a las 14:10 
Roxor, the game was pretty fast originally.
Launch the game, and go to the "Options" menu In-Game. Here you can set the default speed for the game :) Should work like a charm!
Roxor128 15 de Jul, 2013 a las 23:01 
Publicado originalmente por Fresch:
Roxor, the game was pretty fast originally.
Launch the game, and go to the "Options" menu In-Game. Here you can set the default speed for the game :) Should work like a charm!

It's not the game options which are the problem. It's the copy of DOSBox you're shipping with the game. If it were just the game settings, only the gameplay would be affected. It's not. The intro with Duke doing his target shooting also runs too fast. If I run it in my own copy of DOSBox instead of the one shipped with the game, it runs correctly.

I've looked at the DOSBox config file which shipped with the game: v0.72. The current version on the DOSBox website is v0.74. Perhaps an update is in order?
Roxor128 19 de Jul, 2013 a las 21:54 
The update didn't fix the problem, but with a common version to use as a reference point, I've figured out how to fix it:

In the CPU section, cycles=max is the problem. Set it to cycles=auto and the game runs normally.
Roxor128 28 de Dic, 2013 a las 22:21 
Seeing as you guys won't fix the game's DOSBox config, I've gone and done it myself by starting with a default dosbox.conf for DOSBox 0.74 and editing it to fit.

https://docs.google.com/file/d/0B55c2HyHlJetRlFrWTMzVFRaVVE/edit

Download this and put it in "%steamdir%\steamapps\common\Duke Nukem 2", replacing the existing DNII.conf file.

It'll fix the speed issue, run the game at the right aspect ratio and improve the sound quality compared to the one currently shipping. And yes, it does still auto-start the game and start up in fullscreen.

Now that there's a fixed version available, will you guys please update your distribution to include it?
Asian 29 de Dic, 2013 a las 4:38 
virus!
Shikapantera 26 de Jun a las 12:32 
.
Mostrando 1-11 de 11 comentarios
< >
Por página: 15 30 50