Train Simulator

Train Simulator

View Stats:
Problem Trying to Create a Scenario on the Kingwood Branch
I decided to create a short Standard scenario for the Kingwood Branch, but it is "So Dark", that I cannot see where to put any of the Rolling Stock.
It start off as per normal at 12.00 {noon}, but it is like midnight in the middle of winter. So I altered the time several times from between 09.00 and 20.00 hrs, but each time you are in the Build/Edit it is almost "Pitch Black".
I managed to get a loco and 4 wagons on one piece of track, but it is too dark to do anything more. This is definitely some sort of Glitch, so I hope it gets sorted soon.

GreatNorthener, has very quickly fixed this bug with a patch, see post No.5 below.
Last edited by RolandBP; May 21 @ 6:02am
< >
Showing 1-12 of 12 comments
RolandBP May 19 @ 10:17pm 
I decided to try creating a scenario for this route on my Win 10 machine and it worked perfectly normally. Can it be a problem with my Windows 7 professional programme not working with 'this' route?
All My US routes are on my Windows 7 Pro, portion of my PC and I have never had a problem creating scenarios on any of my other US routes.
Hi Roland, thanks for the heads-up. At the moment, I don't quite know what might cause this, but I'll definitely investigate.

Trying to narrow it down, might I ask a few questions? Does it happen all the time, occasionally or was it just this once? Also, how did you enter the editor, from the main menu or from inside a scenario?

Thanks!
RolandBP May 20 @ 2:49am 
Hi, thanks for getting back.
In reply to your first question: On my windows 7 machine it has happened every time.
Now on My windows 10 machine, the scenario I was working on, which started normally for several times, suddenly has become almost impossible to work on for the same reasons.
In reply to your second question. I have gone in from Build/Scenario/Edit.
I did on two ocassions try from inside the scenario, thinking because it was lit normally, while in play, that it might remain so - unfortunately not.

I have just completed the scenario, but I had great difficulty adding the last AI train, I had to move near a signal to have some idea where the track was and instead of having various wagons on this mannifest train, I decided it was easier to just whack down 20 of one type.
There was one more thing I wanted to do, which was to add a Destination marker at one point, but I just had to give up.

Anyway that one scenario is about to be uploaded, but I will not be doing anymore until you can hopefully find out what the issue is.

Best Regards, Roland.
Thank you very much for your reply, it helps a lot. I may still need some time to sort this out, at the moment I have no idea what could be causing it. I could however replicate the issue a couple of times here on my PC (running with Win8), it probably didn't show up before because I routinely build my scenarios from the main/build menu and restart the sim very often too (probably out of sheer superstition).

Cheers!
Michael
Hello again,

I may have already found the culprit through sheer luck. I decided to look at the RouteProperties.xml and TemplateRoute first and noticed that there were some discrepancies between both. I fixed that also also the default weather pattern to one of the "2D" ones and now I can't force the bug to appear any more.

I have uploaded a zip file containing both updated files to our blog here:
http://vnhrr.blogspot.cz/2017/05/scenario-editor-black-screen-hotfix.html

Please know that I cannot guarantee this to work, keep a backup of the two files in case it doesn't.

I'll send this and fixes to the few other bugs that got reported here and at RWA to DTG soon too, for inclusion in an official patch through Steam.

Thanks again for your kind help with this one!

Cheers
Michael
RolandBP May 20 @ 10:07pm 
Hi Michael, many thanks again for your quick reply. I will give the zip file a run.
Hmm, I installed both files Assets and Route, loaded up RailWorks, went into Build?Scenario and Edit of the last scenario I tried that was as black as being inside one of these underground coal mines and it started with proper lighting.
So I thought great the fix has it beat.
But to be sure I decided to start with a new Standard scenario at the Default position on the route and "Bother and Darn" it was as bad as before.
I am going to go to my Win 7 Pro system, download the fix again, install it, start Railworks and see if that may have fixed that installation.
Last edited by RolandBP; May 20 @ 11:22pm
RolandBP May 21 @ 12:24am 
Hallelujah - it worked, it worked. Many thanks Michael, The copy and paste worked differently on my Windows 7 Installation, than it did to the Win 10 installation.
I thought it slightly unusual that there was no asking if I wanted to overwrite the original when I did the W.10 version {Not checked it to find out why, but will later}.
But it certainly did ask if I was to "Merge" the file/s with the Win 7 version.
So I started Railworks, went to Build/Scenario/Edit/Create New Scenario and created 5 new Standard scenarios, each in different locations around the route and everyone started with proper lighting.
Now that is the system {Win 7} that I have all My US routes on, so I am most pleased.
Now to create some more scenarios for the Workshop.
I will be uninstalling my copy of the "B & O Kingwood Branch" from My Win 10 installation, as that Drive is getting quite full and want it reserved for my UK routes.
Last edited by RolandBP; May 21 @ 12:26am
Hi Roland,

Thank you very much for the detailed test with the patch. I'm glad and relieved to hear that this is now working. It is still a rather strange bug though, especially since it doesn't seem to affect all users the same, or some not at all, according to what I've just read in the thread at UKTS. Well, who knows what was going on here, I'm certainly glad this seems to have fixed it.

Cheers!
Michael
RolandBP May 21 @ 3:58am 
Hi Michael, back again with more "GOOD News".
I took a look at how I had done the patch with my Windows 10 installation and while I had put the Assets in correctly, I had not installed the Content correctly. So I corrected it.
Then Did 5 more Build/Scenario/Edit/Create New Scenario and did 4 new Standard scenarios, in 4 locations on the route and they all opened up with the correct lighting.
Marvellous, now I need to copy and paste "My Scenario" "More Coal Needed Quickly" from my Win 10 system to My Win 7 Pro system, then "Untick" the "B & O Kingwood Branch" from my Win 10 UK Drive.
So many thanks again for your very quick fix.
Last edited by RolandBP; May 21 @ 3:59am
Change the string on the stock. Done.
RolandBP May 21 @ 6:04am 
Originally posted by Lord Haart:
Change the string on the stock. Done.
I have edited the original Thread, but am not sure if this is what you meant or how it is done.
Hi again, Thanks for confirming that it now also works on your other computer/partition. Good news indeed!

Cheers!
Michael
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: May 19 @ 4:27am
Posts: 12