Spelunky > Technical Support > Topic Details
ThatGinge Nov 1, 2013 @ 5:08pm
Screen Resolution Problems
I just got this game, and it defaults the screen resolution to a resolution that doesn't fit my screen. When I go into the options to change it, it crashed the first couple times, and now the screen changes, but I can't exit that section of the options, not allowing me to save the setting. I have to force quit the game. Like I click adjust screen settings or whatever, and it works fine, but then when I click the back button, or press esc, nothing happens. It would be nice to play this game in a correct resolution, so if anyone knows how to fix this or if I'm doing something wrong, help would be appreciated.
Last edited by ThatGinge; Nov 1, 2013 @ 5:08pm
Showing 1-12 of 12 comments
< >
ryfry Nov 6, 2013 @ 3:01pm 
I have the same problem. 1600x900
}{O0LIG@N Nov 7, 2013 @ 4:40am 
I had this problem. But after restarting the game i managed to change resolution.
BabboFantasmaヽ༼ຈل͜ຈ༽ Nov 14, 2013 @ 11:44am 
Same thing here.

Launch Game
Game is in Full Screen at resolution X
Navigate Menus to Graphics settings
Change Resolution
Turn Full Screen Off
Update Graphics
Game switches to new resolution in Windowed mode.
Click Esc to leave the Graphics Options menu..
Nothing happens
Mouse-over Esc/Exit button on the hud and select it
Nothing happens

Cannot exit the Graphics menu after making changes to the resolution/fullscreen mode.
Nubnuber Nov 23, 2013 @ 7:00pm 
Same here.
hullandy  [developer] Nov 27, 2013 @ 11:18am 
I'm am working to correct this in the upcoming patch. In the meantime, you can open up the config.txt file in the Spelunky directory and switch the resolution in that file. Apologies for the trouble!
ThatGinge Nov 28, 2013 @ 3:25pm 
Originally posted by hullandy:
I'm am working to correct this in the upcoming patch. In the meantime, you can open up the config.txt file in the Spelunky directory and switch the resolution in that file. Apologies for the trouble!
No worries man :) its a sweet game. Its cool that you're involved in the community like this! :D
Nubnuber Dec 7, 2013 @ 4:22pm 
I fixed it by setting it to "compatibility" in the steam launch options.
Doki Dec 27, 2013 @ 1:37am 
Originally posted by hullandy:
I'm am working to correct this in the upcoming patch. In the meantime, you can open up the config.txt file in the Spelunky directory and switch the resolution in that file. Apologies for the trouble!

This answers my post in the other thread about this bug. Now time to hunt down and edit that config file! Thanks. I didn't give the 2008 version much of a shot and shrugged it off a bit but I'm really enjoying the gameplay and visuals in this updated version of the game so far. Kudos!
Amoomoo Dec 27, 2013 @ 8:19am 
Originally posted by hullandy:
I'm am working to correct this in the upcoming patch. In the meantime, you can open up the config.txt file in the Spelunky directory and switch the resolution in that file. Apologies for the trouble!
So how do I open that?
Amoomoo Dec 27, 2013 @ 8:23am 
Oh Hell yeah, I got it. Thanks so much dude!
shtkck Jan 4 @ 4:44pm 
Yeah, I set it to my eyefinity resolution and completely borked the game.
Good thing for that txt file config!
Scooby Snacks Jan 11 @ 6:30am 
Originally posted by hullandy:
I'm am working to correct this in the upcoming patch. In the meantime, you can open up the config.txt file in the Spelunky directory and switch the resolution in that file. Apologies for the trouble!
What must you type in to change it back to fullscreen(i accidently changed it to windowed)
Showing 1-12 of 12 comments
< >
Per page: 15 30 50