Spelunky > General Discussions > Topic Details
Malku Aug 10, 2013 @ 11:58am
Game Not Saving?
Now before you all start jumping down my throat I do know what this game saves. It saves shortcuts, journal entries, character unlocks, etc. But as the game stands now it is not saving any of these thingsl for me.

I played for about an hour yesterday (after spending god knows how long just getting the game to launch without crashing) and I made it to the jungle, had the short cut to the jungle open, and had unlocked two characters. I launch up the game today and I have nothing. The tutorial isn't even finished.

I've probably done the tutorial six or seven times now trying to find a way to exit the game and let it save but even when I go all the way to the main title screen it doesn't save.
Last edited by Malku; Aug 10, 2013 @ 12:27pm
Showing 1-14 of 14 comments
< >
hullandy  [developer] Aug 10, 2013 @ 12:00pm 
I'm looking into this. You are the first to report this issue. Anybody else?
Malku Aug 10, 2013 @ 12:03pm 
I'm running Windows 7 64 bit if that helps at all.
hullandy  [developer] Aug 10, 2013 @ 12:05pm 
Also- Do you see the little red save book popping up in the lower right corner on the game over screen?
Malku Aug 10, 2013 @ 12:17pm 
Yeah the red journal is there shaking like it's supposed to.
hullandy  [developer] Aug 10, 2013 @ 12:19pm 
Have you ever successfully saved/loaded? (Especially yesterday?) I'm trying to work out if this was cause by the update, or has always been an issue.
Malku Aug 10, 2013 @ 12:27pm 
When I put in the new config file that you posted yesterday the game was playable so I played it for around an hour before I went to bed and didn't relaunch it until today so I dont' think the update caused the save issue.
hullandy  [developer] Aug 10, 2013 @ 12:31pm 
Sounds good. Thanks for you help. This is near the top of my priority list for the next update. Apologies.
Malku Aug 10, 2013 @ 12:42pm 
Might I add that it's awesome that you're willing to chat with somebody like me about an issue like this? That's awesome customer support man.
Last edited by Malku; Aug 10, 2013 @ 12:43pm
hullandy  [developer] Aug 10, 2013 @ 4:06pm 
No worries. Quick question: is the game generating a config.txt in your Spelunky/Data folder? If that isn't generating either, their may be an issue with your folder permissions that is preventing the game from writing to any files at all. If you do have that file, it would confirm that this is save game specific.
Malku Aug 11, 2013 @ 9:37am 
I just deleted the config.txt and did a quick run and it regenerated it. I also checked to make sure that all of the folders have full control in the permisssions.

Still no save :c.
hullandy  [developer] Aug 11, 2013 @ 9:51am 
Thanks!
Malku Aug 15, 2013 @ 10:48am 
So... Is there any news of a fix coming soon or what?
hullandy  [developer] Aug 15, 2013 @ 12:46pm 
Yup- next update should be up either tonight or tomorrow morning. I did alter the save stuff to hopefully fix this, but I can't repro it, so I don't have a good way to test if it will work for sure for ya.
dacur7 Nov 2, 2013 @ 3:13pm 
In case anyone else is still having this issue like I was, I changed the data files from a "read only" state and then the game seemed to save my progress past the mines (i.e. allow for the shortcut). Thank jeebus it freaking finally worked! :P
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Aug 10, 2013 @ 11:58am
Posts: 14