Solamon77 Sep 10, 2013 @ 1:09am
Getting Surround Sound working.
The first game needed a bunch of crazy work arounds to enable surround sound. Has this problem been solved for the sequel?

Edit:
Here's how to enable surround sound.

Originally posted by from Frictional's forum:
Now here is some trick that should work for everyone. There is a software implementation of OpenAL called OpenAL-soft that supports surround sound setups on pretty much any capable sound card. You can get it here: http://kcat.strangesoft.net/openal.html#download. Just download the Win32 binary package and look for a 'soft_oal.dll' (should be located in the openal-soft-<version_number>-bin/Win32 directory in the package). This 'soft_oal.dll' file should be copied to the game redist folder, i.e. where the game exe is located. After having done so, in the launcher and game options there should be a new selectable sound device. Make sure to configure your speakers properly in control panel, and select this device in the game options. And voilà.
Last edited by Solamon77; Sep 10, 2013 @ 1:46am
Showing 1-7 of 7 comments
< >
YoungProdigy209 Sep 10, 2013 @ 1:10am 
surround sound as in with speakers or 3 way monitors?
Solamon77 Sep 10, 2013 @ 1:11am 
Speakers of course. If I was talking about monitors I wouldn't have said "sound." I would have said something like " Does the game support proper 21:9 monitor resolutions?"
Solamon77 Sep 10, 2013 @ 1:40am 
Seems like Amnesia still doesn't support surround sound out the box. However, I tried the same workaround I used for the first Amnesia and was able to get 7.1 surround sound working. Incase anyone needs to know, I'm currently using the onboard sound from my GTX 670. I edited my original post with the method recommended by Frictional Games for anyone interested.
Last edited by Solamon77; Sep 10, 2013 @ 1:46am
noTHINGfaced Sep 10, 2013 @ 10:26am 
Doesn't work for me. Im having to use realtek onboard but no surround sound using this method.
soopytwist Sep 10, 2013 @ 10:30am 
No sound for me either after copying that openAL file. I have a creative X-Fi and using 5.1 speakers. ♥♥♥♥, it's like ALchemy all over again, except this time I have no sound at all.
jonathan.blanco241 Oct 3, 2013 @ 7:00pm 
HELLO! i cant get this to work i am using a Soundblaster ZXR and when i put the file in my game directory and go to settings, the new sound device is not showwing up!!! i know what its supposed to look like! it should say (unsupported) Speakers on Soundblaster ZXR. ITs not showing up!!!! WTF sombody help!!! its just this game too.
Paradox^2 Mar 31 @ 5:21pm 
I'm only getting half sound. The game menu music doesn't run, and there dialogue obviously running, but all I get is the subtitles. No actual voices. I can hear everything else, like footsteps, and creaks, and the lantern, etc., but there's no dialogue at all, and I only have two sound settings, volume, and select device, which doesn't seem to help anything. Will this fix that too, or is there something else I can try?
Showing 1-7 of 7 comments
< >
Per page: 15 30 50