Hammerwatch > General Discussions > Topic Details
dorkster Aug 30, 2013 @ 6:44pm
Getting the game to launch on (Arch) Linux
Here's what I had to do to get the game to run. Hopefully it will help some people:

Edit ~/.steam/SteamApps/common/Hammerwatch/RunHammerwatch
And change the last line to:
LD_LIBRARY_PATH=:/usr/lib/mono mono "$DIR/Hammerwatch.exe" $*
Showing 1-15 of 25 comments
< >
Jo Sep 24, 2013 @ 12:27pm 
Bump.

My start script was located at ~/.local/share/Steam/SteamApps/common/Hammerwatch/RunHammerwatch
Jo Sep 24, 2013 @ 3:21pm 
The game doesn't recognize Steam, however. Don't know how to fix.
TroubleHelix Sep 26, 2013 @ 9:42am 
Thanks, this worked for me. I had to first install mono, and then add the line you mentioned to ~/.steam/steam/SteamApps/common/Hammerwatch/RunHammerwatch
Jo Oct 8, 2013 @ 12:28am 
Any news on how to get Achievements to work?
ioluas Nov 11, 2013 @ 6:12pm 
Thanks. This solved my problem.
Valeth Nov 14, 2013 @ 10:47am 
You could also just enter "LD_LIBRARY_PATH=:/usr/lib/mono %command%" in the Hammerwatch launch options. This way you don't have to edit the file.
Last edited by Valeth; Nov 14, 2013 @ 10:50am
toefurkey Nov 16, 2013 @ 5:49pm 
Thanks for the tips! After installing mono and adding that line, everything seems to be working just fine. It seems like they designed the script with only Debian based architecture in mind.
David™ Nov 27, 2013 @ 4:03pm 
So adding that line to the run options makes the game start, but looking at the coins and monsters achievements it appears that they aren't working correctly. Did anyone manage to get that fixed?
Dark Defender Nov 27, 2013 @ 4:34pm 
I had the same problem with gentoo. Adding the LD_LIBRARY_PATH as suggested by Valeth fixed it. :)
Last edited by Dark Defender; Nov 27, 2013 @ 4:34pm
David™ Nov 27, 2013 @ 4:55pm 
Originally posted by Dark Defender:
I had the same problem with gentoo. Adding the LD_LIBRARY_PATH as suggested by Valeth fixed it. :)
It fixed achievements?
Valeth Dec 18, 2013 @ 8:30am 
Looks like the game now works fine after the 1.2 patch.
So there is no need for the LD_LIBRARY_PATH variable anymore. :)
adolson Dec 18, 2013 @ 9:31am 
Originally posted by Valeth:
Looks like the game now works fine after the 1.2 patch.
So there is no need for the LD_LIBRARY_PATH variable anymore. :)
It doesn't work for me with or without the launch options now... Do any of you Arch users run Cinnamon and have the game working?

EDIT: it's *randomly* working for me now after a bunch of testing and strace dumping and trying other DEs, and rebooting a few times.. I don't know...

Oh, and I still need the LD_LIBRARY_PATH for the game to run from inside Steam.
Last edited by adolson; Dec 18, 2013 @ 11:52pm
Jo Dec 18, 2013 @ 11:51am 
I'm on Arch with Cinnamon and it's working for me.
Valeth Dec 18, 2013 @ 1:21pm 
Originally posted by adolson:
Originally posted by Valeth:
Looks like the game now works fine after the 1.2 patch.
So there is no need for the LD_LIBRARY_PATH variable anymore. :)
It doesn't work for me with or without the launch options now... Do any of you Arch users run Cinnamon and have the game working?

Do you have "mono" installed?
I also use "monogame" from the AUR, but i don't know if its required by the game
Jo Dec 18, 2013 @ 2:15pm 
I have "mono" but not "monogame".
Showing 1-15 of 25 comments
< >
Per page: 15 30 50
Date Posted: Aug 30, 2013 @ 6:44pm
Posts: 25