Hammerwatch

Hammerwatch

View Stats:
Hammerwatch > General Discussions > Topic Details
David™ Nov 30, 2013 @ 10:56am
Linux Achievements
Hello. I am running this game on 64bit archlinux. I had to edit the program launch line to override mono libraries, as discussed elsewhere on this forum. Achievements aren't working at all, is there anything that can be done?
< >
Showing 1-11 of 11 comments
Malah Dec 30, 2013 @ 6:12am 
I have the same probleme on 32bit archlinux. And when i go to game.log i can see:
Initialize achievments, Steam and master server Failed to initialize Steam, using Null implementation

Any one have any tips plz ?
abelthorne Dec 30, 2013 @ 8:12am 
Oh, I just noticed that the achievements don't work for me either. Using Ubuntu 13.10 64 bits.
Malah Dec 30, 2013 @ 8:14am 
I have post to the official support forum : http://hammerwatch.com/forum/index.php?topic=1836.0
Vulpes Velox Jan 5, 2014 @ 6:10am 
Same problem here, I'm using Ubuntu 12.04 64 bits .
It's too bad its not working, at least its not game breaking.
Cadre Cola Apr 16, 2014 @ 10:55pm 
I'm having the same issue as you guys. Just to note, I'm using Ubuntu 12.04 (64-bit).
pandialo Apr 21, 2014 @ 10:18am 
It's working neither for xubuntu 13.04 nor 14.04. It's really a pity. On the one hand I would really like to have it working, on the other I feel bad about bothering the devs all the time with such a minor thing.
Skully Apr 29, 2014 @ 7:47am 
Actually you can make them work very easy. Achievements work for 32bit, so make steam launch the 32bit version like this.

In steam, right click game, select properties, select launch options.
In the box write the following

linux32 %command%

Now the 32bit version will be used and achievements work fine.

P.S. You can also edit the launch script in the games folder, but this is much easier.
Last edited by Skully; Apr 29, 2014 @ 7:49am
David™ May 4, 2014 @ 2:09am 
Doesn't work for me..
Skully May 4, 2014 @ 4:29am 
Originally posted by David™:
Doesn't work for me..

Very strange, I have been getting them witht he 32bit version
Cadre Cola May 12, 2014 @ 3:11am 
Originally posted by Skully:
Actually you can make them work very easy. Achievements work for 32bit, so make steam launch the 32bit version like this.

In steam, right click game, select properties, select launch options.
In the box write the following

linux32 %command%

Now the 32bit version will be used and achievements work fine.

P.S. You can also edit the launch script in the games folder, but this is much easier.
Good call, Skully. Once I switched to the 32-bit version, the achievements started working. Thanks for the advice.
a.fettouhi Dec 22, 2014 @ 1:57am 
Originally posted by Skully:
Actually you can make them work very easy. Achievements work for 32bit, so make steam launch the 32bit version like this.

In steam, right click game, select properties, select launch options.
In the box write the following

linux32 %command%

Now the 32bit version will be used and achievements work fine.

P.S. You can also edit the launch script in the games folder, but this is much easier.


Yep, this got achievements working for me on Arch Linux 64 bit with KDE 4.11.4.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Hammerwatch > General Discussions > Topic Details
Date Posted: Nov 30, 2013 @ 10:56am
Posts: 11