Heretic: Shadow of the Serpent Riders

Heretic: Shadow of the Serpent Riders

Cogajon 11/out/2013 às 13:06
How to get Heretic to work on Windows 8 without downloading any sourcecodes or ports
So, getting Heretic to work on Windows 8 is not a long, nor difficult task. I'd like to point out that I did actually get my help from the internet, but I did have to improvise a bit.
First, go to OS (C:) > Program Files (x86) > Steam > steamapps > common > Heretic Shadow of the Serpent Riders > base
Right-click HERETIC and go to 'Properties' then set compatability mode to Windows 95.
Then, go to heretic.conf and open it with Notepad.
Change 'fullscreen=true' to 'fullscreen=false' and 'waitonerror=true' to 'waitonerror=false'.
Then, open dosbox.conf and scroll down to where it says 'waitonerror=true' and change it to 'waitonerror=false'
Make sure you save these changes and close the files.
Go to your Steam Library and go to Heretic: Shadow of the Serpent Riders and click 'Play'
If it still doesn't work, like it did for me, go to doom2.conf and change 'fulldouble=true' to 'fulldouble=false'
After this, it should all work.
Hope this helped you! :)

P.S. This will work in any game that uses DOS box such as Doom, Heretic, or Hexen
< >
Exibindo comentários 115 de 15
richardjam13 29/nov/2013 às 3:39 
I just set fullscreen to false and it worked. However the graphics was too slow. So I changed the output to opengl and it was fine.
cdx 5/dez/2013 às 13:39 
Thanks. =)
eddsjohn 17/jun/2015 às 19:05 
Escrito originalmente por richardjam13:
I just set fullscreen to false and it worked. However the graphics was too slow. So I changed the output to opengl and it was fine.
How you change it to opengl? Im trying to figure out.... without success
robes 21/jun/2015 às 11:58 
Escrito originalmente por eddsjohn:
Escrito originalmente por richardjam13:
I just set fullscreen to false and it worked. However the graphics was too slow. So I changed the output to opengl and it was fine.
How you change it to opengl? Im trying to figure out.... without success

Change output=ddraw to output=opengl in the file mentioned above ^^, heretic.conf
earthleakage 24/jun/2015 às 12:38 
[win 8] ty robes that worked perfectly for me too
ChianaStar 28/jun/2015 às 10:27 
Thank you so much this worked for my game an now my husband asked me to do it for his DOOM's lol
Yeah dude, thx
raspberrykraken 14/dez/2015 às 18:29 
Yes just need to download a source port like zDoom and export the wad file into a folder and your ready to go.
Diablodelta 5 de jan às 21:34 
abra o arquivo heretic.conf dentro da pasta do jogo com bloco de notas e altere output=ddraw para output=opengl , essas são configurações de áudio resolução tela cheia ou não e outras vlws
gintama11 28 de fev às 12:55 
I have tried out the method as this discussion instructed and it worked. But, there's one thing that's bugging me a bit. Do you always need a WAD just to get the WASD controls?
robes 28 de fev às 15:39 
I assume you're asking if you can rebind the keys in DOSBox? When the game is running, hit CTRL+F1 to bring up the keymapper interface. It behaves backwards, so you need to rebind the cursor keys (which should be on the left of the screen) with WASD. Also when you click the key to change, it's probably wise to DEL the old binds before you ADD the new one (they stack up, although it isn't clearly shown in the interface).

This will generate a mapper.txt file in the folder with the heretic.bat, ie the one above \base. You can manually edit it if you prefer.
gintama11 29 de fev às 12:19 
I have tried experimenting with that and it worked out ok. It is a shame that mouselook was not displayed there though. Nevertheless, thanks for the rebinding advice.
robes 29 de fev às 13:25 
I'd forgotten, but there's also an easier way - you can run the game's own setup.exe (in \base). Since I've forgotten how to operate dosbox, you can just drag+drop the exe onto dosbox to boot it and change the keys there, too. No mouselook though, sorry, although you can bind look up and down :P
skippyfox 7 de mai às 20:20 
On Windows 10 here. I changed only the one setting "fulldouble" to false in heretic.conf and this fixed everything for me.
< >
Exibindo comentários 115 de 15
Por página: 15 30 50