Artemisia vulgaris Aug 31, 2013 @ 9:12pm
Bugs so far
I've found a double handful of spelling errors in the script, which is meh. What I am noticing is that I'm having performance issues (slow down/choppy animations, freezing up entirely). I'm running a relatively new computer here with fully updated drivers, so I don't think the problem is at my end.

The graphics are also a problem for me. The game sets my presets at high across the board for graphcs, and the native resolution on my monitor is 1920x1080, but the in-game graphics are fuzzy as hell. I'd guess the resolution shown is closer to 1440x800.
Showing 1-7 of 7 comments
< >
Wuulfebear Aug 31, 2013 @ 11:54pm 
want a list of what i've found so far? I think a few are being addressed in a patch later.. but here's the brunt of it -

Hi there, I've been playing through the game for a few days now. I've been stocking up on a list of the things I've noticed with the game to be glitches, or bugs or graphic issues and so forth. I have no idea where to post this info, but I'm hoping the developers and designers get a read of this to see what issues I've discovered and (possible) solutions to some of these issues I've come across.


--------------------------------


1) Day/Night Time frame issue: I believe this has been addressed, but here's a brief run down. The time phases between day and night happens WAY to quickly. There should be longer in-between times before the dawn/setting of the day. Reasons for this include; to get from the first town to the duke castle, takes two days to reach. Its actually not that far to get from (A) to (B) yet the time rate takes forever and basically you run out of supplies far to quickly which forces you to return to town far too frequently.
If a party member or more get low health (ie. 12/226) or something along those lines, you may as well Rest and waste a food supply rather than spend 2 days running back to town to the healer. 60g for 6x supplies vs 15g for a party heal.. i mean... really?
I've been forced to play as - fight, save/rest - fight, save/rest - etc.. through most of the game so far. Its ridiculous vs. the many other problems in the game that hinder enjoyment in further pursuing the storyline/game. What happens when players travel further out? they'll run out of food by the time they even get 250 squares from the starter town. The time rate really needs to be adjusted. Back in the old M&M days, a day/night was around 15-20 minutes gametime, not every 3-5 minutes.


2) Food Supplies issue: pretty much the same issue as (1). To make it a little more sustainable, something like 12 supplies would work a little better.. maybe even 20. But the count definitely needs to be higher.

3) The Stores drama issue: Ok, this is certainly one that needs to be looked into. Store equipment up to day 193 so far had remained THE SAME. Even stuff I've sold to the stores hasn't even displayed in the list of items available. Its like they just vanish off the game entirely after being sold for the amount in gold. My level 11 dwarf Defender has had the SAME starter axe he began the game with and there's pretty much been no upgrades AT ALL throughout the entire campaign to the point I'm at. Even rings seem to be the same standard +1, weapons (mostly daggers) at +2 magic bonus and stuff you're character is equivalent as say lvls 1-3 could have started with seem to repeatedly drop.
Variety would be a bonus. On top of that, I've gone through so many days (resting) considering that health potions and mana potions do NOT stock in the stores - ever.. In fact, nothing in the list changes. In the old M&M days, I believe equipment stocks changed every 30 days? - game month? or when you town travelled to a place, then back again. I cannot recall which.

4) Monster fights and respawns issue: levelling in the game is hard. Not so much being a challenge, but I pretty much had to clear everything on the outside town map before even trying to attempt the lighthouse. (that's including having to clear the Den of Thieves instance and the 2 cyclops) and I still had problems trying to down that boss in the lighthouse. Respawns to work on gaining a few levels - even if it was when you "zone" out and back, or after a game month, would be most helpful. If you're over-levelled for a particular area, nerf the experience and just make it trashy loot/gold drops so people don't get too over-powered.
One particular graphic issue I've noticed all too frequently is the militia and elite heading for you and past you as you beat down hard and fast on them. You actually have to stop attacking for them to return to their reset point so you can see how far off they're being dead from. That and a few other mobs need to be fixed. The Kenshi for example, far too over-powered for a starter party. The Kenshi elites are far worse and that knock-back and block/miss spam from the light-house boss needs to be dropped down tremendously for a starter boss. I went through 36 heal potions having to down him (I hadn't used any at all because after my third reload of the game redoing my party I knew i needed to stocktake those pots since the stores don't restock).

5) Re-lootable chests/pits?: this one is optional.. maybe like the 30 day reset of spawns, the chests reset? did for the old M&M series.

6) Caster spells, skill increase problems: As you increase your spell-casting abilities for your casters, so too should the output and the decrease of mana cost of those same spells. My freemage had hit expert for earth magic but the cost of the skill was still 30 mana and the inc. healing was still based set to the default 1 point in the skill. Is that even working? I'm not sure if other spells are doing the same thing but since heals are sore in this game with the lack of health pots, its one thing I noticed quickly.

7) Weapons/Armor breakability and skill defects: Weapons break far too quickly in this game. My free-mages dagger broke at a 2-3 square distance from the mob (no ranged attacks from mob/ Militia) yet my dagger broke after i threw a fire attack. I mean seriously? armors no better. Three of my characters are expert medium armors and they still have their armors break as quickly as though their novice. Damage should be reduced with the higher skill, but I'm really not noticing it.

8) Weird map load-ins and save glitches: I've noticed a fair bit, especially as I progressed through the game that the stability of the game seems to break down. I'll reload a game and my character's will be looking skyward as i walk but I can't reset it back to horizon level. I'll log in with different character portraits even though I have the same skills, items ,etc my initial (appearance) characters had.

9) Combat bug: ok this is one I find REALLY annoying... you'll start to get yourself set up to fight something, guiding it to a spot where it'll walk in front of you rather than you get hit by them first and as you go through the turn based set up, suddenly everything goes gray. You can't do any attacks, defends, casting, anything.. both you and the mob just stand there and look at each other. You can still open up character inventory and sheets and skills and all that but you can't actually do anything short of a reload of the game to re-set up the fight all over again.

10) Unconscious/low health-mana characters: One thing I did enjoy about the old M&M is that once you were out of combat if your character was at 0 health, they would awake an regain health sitting at 1. Every step you took, health and mana (depending on vitality i think it was) regenerated at 1-3 per step. Here, if you're character is unconscious, you waste 2 days (if you're at say the Duke's palace) running all the way back to town to get the member healed to then have to run all the way back out. Sure, if you're caster can cast Regeneration or heal, that's no problem.. but in 9 out of 10 times its usually the (healer) that goes down first. If they were at -1 health, every step would drop the health down by -1 till at -10 the character died. Not sure if you're going to impliment that in or not. However since some of the creatures are so over-powered a -20 would give someone a chance to heal them rather than have them get 1 shotted.


That's pretty much at the moment of issues I've noticed. Hope this gives you some idea as to what to fix.. if i come up with any others, I'll be sure to add it to this thread.
Freesoul Sep 1, 2013 @ 2:14am 
I have another game breaking bug to report :
if you use the wind spell that push monster back sometimes you are stuck in the game. I mean all characters have ended their turn and cant do anything more but the turn still not end. You cant do anything more than reload a saved gamed. Very annoying.
Killbomb Sep 1, 2013 @ 7:37am 
@Wuulfebear

A few of your issues are being addressed in the next patch. Day/night cycle, shops restocking and things breaking randomly are being fixed/improved. As for unconscious characters, resting will remove the unconscious state in the next patch. Not sure how much that will help for your issue but at least it's a step in the right direction.

guess ill post some of the bugs and annoyances ive found so far aswell.

1. the wind gust skill just freezes the fights like freesoul has already pointed out before
2. for some reason, now after my last save has been #380 i can not save the game anymore. when i try to save it just takes some time and then does nothing, both on quicksave and on regular saves.
3. whenever i quickload (also after save 380) my party dies and the game shows me the game over screen
4. when i rested my party and saved directly after resting, then reloaded the game later, my complete party would get from the full healthy mode immediately into the red exhaust mode thingy after moving 1 square
5. broken weapons and armor do not seem to affect stats somehow, all my party members deal the exact same damage with broken weapons and normal weapons
6. same thing as 5 just with exhaustionlevel, i still deal full damage while being in the red exhausted state even though the tool tip says something like 70% reduced might and perception
7. i randomly got stuck in opened doors in the bandits den. especially the one that opens with a lever. activated the lever, tried to move through the now open door, got stuck in there.
8. teleporter after mamushi that is supposed to bring you down from the lighthouse did not work. had to quickload to get it to work.
9. most talents seem to be broken, i put all points on my archer into bow (which should increase attack rating by 2 per point) and he still dealt the same damage as my berserker with 1 point in bow, bows were the same since there is apparently only one type of bow currently in the game.
10. hiring the cook in the tavern does not work, it just repeats the same dialogue over and over for me. recruiting the scout on the other hand works, but he just does nothing (maybe thats supposed to be how he works?)
11. sometimes i just cant move while in a fight. happened multiple times in the mamushi fight and was persistent until i reloaded.
12. basically the same as 11. just with turning. moving around works but i cant turn around with q/e (buttons on the bottom left are also greyed out)
13. some items and skills dont have descriptions or wrong names, ive got some screenshots for this in my steam gallery. i noticed bugs like that on the cyclops skills, on mamushis skills and on several items like a 404 torchlight scroll
14. celestial armor seems to be kinda buggy, normally it should shield you for 1 turn, but i had it happen like 3 times that the buff stayed up for more than 1 turn (with the buff icon showing 13 turns)
15. balance wise the kenshi naga are pretty overpowered like wuulfebear has stated before
16. changing areas and resting somehow takes longer everytime. when i started the game, resting was really fast, now i have to wait about a minute until it changes back to the game from the blackscreen
17. npc text popup thingys reappear endlessly. the square in front of the bandits den always made the npc text window pop up, telling me the same thing over and over again.
18. during the first "quest" where that one npc shows you the city and explains about the locations, the camera turned to the wrong direction at the potion store (for every other building it turned the camera towards the entry, for this one it turned the other way)
19. after defeating mamushi i was unable to leave the lighthouse. when i approached the door the naga npc started talking to me, this repeated endlessly whenever i approached the door or when i pressed space. after reloading i was able to leave the lighthouse after the npc talked to me once.
20. i rarely had it happen that my turn ended after i performed my first action, without the rest of my party being allowed to do something
21. brigands sometimes do not have an attack animation, they will just shoot the arrow out of their breast for some reason
22. militia move towards the party whenever they are hit, if you just mash the attack button they will get behind your party where you cant see their health bars anymore, if you wait some time they return to their square.
23. also on militia, i had it happen multiple times in front of the bandits den, that i had one militia on the square in front of me, and another militia being 2 squares behind the first militia, but both were able to attack me (they could even attack me when they were on the diagonally adjacent squares)
24. the bestiary quest does not work, i have all creatures in my bestiary (16 or 18 or so i think) and i cant turn in the quest even though he only wants you to have 10 creatures
25. quest log text somehow bugs out, when i look through the open quests and click on them in the quest log one after the other, it just stacks the texts of the quests i clicked on on top of each other so that you can not read anything. text stays like that until reloading a game.
26. same thing as 25 just for npc text boxes. sometimes the name of the npc moves down in the box, so that it is on top of the npc's text. this also stays there for all npcs until reload
27. after reloading a game, it sometimes shows wrong healthbars next to your characters. i had it show a full healthbar next to my archer and in the next fight he died after the first hit from a militia with only 9 damage
28. whenever i move the torchlight spell to my quick action bar it automatically activates the spell immediately. tried it multiple times, it only happens for torchlight and not the other spells.
29. the boss in the bandits den does not do anything if you just shoot at him with ranged weapons from outside his room.
30. i sometimes get random level up popups on screen after reloading, sometimes they even stay on screen for some minutes.
31. also after reloading, sometimes it changes all 4 pictures of my party, this stays until i reload again.
32. also after reloading, sometimes random tiles/squares do not show up, leaving you with the random blue skybox that looks like a bottomless pit. happened mostly in front of the fourth dungeon and in the lighthouse.
33. sometimes i had random enemies popup in front or behind me after reloading. once when i saved in front of the lighthouse and had a kenshi popup one square behind me after a reload, and once outside of the fourth dungeon (where the last save is that i can actually reload) it sometimes spawns 2 elite brigands one or two squares in front of me. the thing with the brigands however, does not happen everytime. since this is my last working save (thanks to the fact that i can not save the game anymore like stated above) i reloaded it around 10 times with the brigands popping up about 7 or 8 times out of these 10.
34. when i rested and afterwards saved the game, and then later i reloaded this save, it would put me to the old location with the amount of food i had before reloading. which means if i rested and had 4 food supplies left after resting, then saved the game, played normally, moved around and rested 3 more times, then reloaded the old save, it would put me to the old location but with only 1 food supply left.
35. fights randomly freeze, you can not move and use anything, the enemy also does not move, but you can still open the inventory and questlog stuff.
36. more of an annoyance : if you change the gamme value in the options while being ingame and you enter, lets say, a gamma value of 2.3 it will use whatever you have in slot 2 and 3 of your quick action bar. its the same if you rebind keys.
37. rebinding keys in general seems to be a little buggy. i rebound the "toggle interface" from f12 to f11, because i wanted to take screenshots with f12 without the interface disappearing. somehow the game now toggles the interface with f11 and f12, even though the key bindings only show f11.
38. when you rebind a key for something, it will immediately proceed to use whatever you rebound. when i rebound the interface toggle to f11, it asked for a new key and i pressed f11 which immediately toggled the interface. works with other keys aswell.
39. the counter attack skill of elite kenshis / elite brigands / mamushi sometimes does not work, after reloading they work again.
40. the loading zone of the first cyclops cave takes extreme amounts of time for me, like 2 or 3 minutes
41. the cyclops in the cave randomly got stuck while moving towards me, allowing me to kill him with range attacks without him being able to attack once.
42. saving/loading/moving to a different zone in general takes extremely long since the 350th save. about a minute for each of them, and it also tends to freeze the game for short amounts of time (with the window turning white and showing that it has stopped working)

i guess thats it for now, if i remember something else ill post it, if not i will probably just wait for the game release since i can't save my game anyways.
Artemisia vulgaris Sep 2, 2013 @ 4:18pm 
I've also had most of the problems listed above. A really annoying thing, in addition to those, is the fact that the animations for the enemies sometimes cause them to jump back and forth between two squares for as long as 30 seconds before allowing the next round to occur.
Kevorkian_Scarf Sep 2, 2013 @ 4:33pm 
Some additional bugs I found so far (in addition to some of those already posted above or in the upcoming patch notes):

Smuggler's Cove quest - if I obtain the Smuggler's Coffer before getting the quest the group has to travel BACK to the smuggler area in the well before being able to actually turn in the quest.

A spider attacked my Dwarf - did 3 dmg and poisoned. Party killed spider - dwarf took 160 dmg for no apparent reason.

Mobs sometimes die when low on health and attacking the party - no reason or damage information provided. They attack, then they die.

My Dwarf (in position 1 from left to right) gains more experience than the other party members by a small amount (I believe this is due to rounding.)

One firebolt (initial fire spell) used 80 mana for some reason

Resting in the Inn consumes 1 supply if you have more than 0 supplies total

Yellow danger marker kicks in when nothing is even remotely close by

Stormy Tribal Spear of Deadliness gives +2 Critical chance - but on character sheet it increases crit chance to 203%

Flowers for Fallen Heroes - turn in area gave no "hit space to turn in" type feedback.

Regeneration spell does not heal unconscious party members beyond the initial heal amount (HOT does not heal them)

Danger Sense spell does not currently work at all.
Kurazo Sep 2, 2013 @ 5:04pm 
In the bandit Den, in the cave, behind the door that we can open with a lever, with 1 elite archer and one elite militia, when they move the round just don't end and freeze de game when you want to pull them out of the room
Tx
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Aug 31, 2013 @ 9:12pm
Posts: 7