Nox Jan 23 @ 6:49am
BUGLIST - Please report bugs on our official forum
Hello everybody,

As you may know Might & Magic X – Legacy is now released!!

If you have any bug to report, please use the dedicated thread on our official forum: http://forums.ubi.com/showthread.php/826242-BUGLIST-Please-report-bugs-here

For technical information, see our blog article here https://mightandmagicx-legacy.ubi.com/opendev/blog/post/view/technical-information

Edit 31/01

/!\ Please check dedicated thread for more information

Edit 30/01

Important Notice
- Your game should be working on this version: 1.3.1-14561 (you can find it on game main menu)
- If you played Early Access: you need to uninstall the game first and then reinstall it with the patch (1.3.1-14561). Your saves aren't compatible (you may be able to play with them but this can corrupt further saves)
- In order to activate the game you need to be online on Uplay (one time activation but you need to actually launch the game)

Uplay issues: If you can't access act 2
- restart Uplay (be sure you are running it in administrator mode)
- check if you are online on Uplay
- check if you don't have a firewall issue
- check your game version (you need to be on 1.3.1-14561)
- even if you were able to download/update the game, you may also have connection issues with Uplay, some players found a solution on their router (http://forums.ubi.com/showthread.php/826555-Important-Notice-if-you-can%E2%80%99t-access-Act-2?p=9507015&viewfull=1#post9507015) - just in case you can also try to use an Ethernet cable to connect directly to your box instead of Wifi connection.
- try to re-enter your key in the game extras > bonus menu

- If you have missing textures, combat scripts issues, delays on voices etc. please try to reduce your settings (memory issue) – and be sure your game is up-to-date (1.3.1-14561).
- If you have difficulties with your saves, you need to be sure that all your saves were done with the day one patch. EA or non patched versions of the game saves may corrupt the next ones.
- Soundtrack link on Uplay is now fixed
- If you have an Optimus GPU (graphic card) or a recent processor i7, be sure that you are using your main GPU.
- Concerning Bestiary quest, only "unique" creatures are taken into account (normal & elite version counting as one)

-------

Be sure to check the other thread ETA 31/01

We will gradually update this topic with main concerns & solutions.

We hope you will enjoy the game!

Cheers,
Your MMX team
Last edited by Nox; Jan 31 @ 4:02pm
Showing 1-15 of 209 comments
< >
FroBodine Jan 23 @ 6:57am 
Apparently invert mouse is missing. I was going to buy this game, but I am unable to play games like this without mouse invert. Is this indeed missing, and if so, when will it be put back in? It sounds like it was in there during early access.
copper1956 Jan 23 @ 8:29am 
Same. Why is mouse inversion not implemented?!
Franklin Jan 23 @ 1:24pm 
The textured seem way blurrier then the early release. For instance the fences in the first town are like a solid brown, so is the wood on the doors... instead of a wood texture. I have my sliders all on max. How do you fix this?
Necr0niX (NoDota) :D Jan 23 @ 1:26pm 
Originally posted by Guillermo:
The textured seem way blurrier then the early release. For instance the fences in the first town are like a solid brown, so is the wood on the doors... instead of a wood texture. I have my sliders all on max. How do you fix this?

You cannot. It's a bug in the game client itself. Waiting for patches is the only way.
Franklin Jan 23 @ 1:31pm 
Originally posted by Tokisaki \(O_@)/ Kurumi:
Originally posted by Guillermo:
The textured seem way blurrier then the early release. For instance the fences in the first town are like a solid brown, so is the wood on the doors... instead of a wood texture. I have my sliders all on max. How do you fix this?

You cannot. It's a bug in the game client itself. Waiting for patches is the only way.

Figured out my issue, it seems the texture quality slider is missing from the in game options menu, and only appears on the main menus option menu. Must be a bug because in pre-release it was in both.
tommim Jan 23 @ 1:43pm 
Originally posted by Nox:
If you have any bug to report, please use the dedicated thread on our official forum:

You got to be kidding me!
Shouldn't you have been testing this BEFORE you release it? What for the love of God have you been doing the last two months when people during early access tried their very best to provide you with all the bug reports they could?
Also I thought you were right there when people told you time and again long before the end of December you would need more time to test it properly?

You know: the same people who have been begging left and right for you to give them access to the latest patch and be allowed to bug-test this for you BEFORE it was released to the public?

So you ignored everybody. That's fine! But then at least - for all that is sacred - don't give us this crap that only NOW you find that you have need for a bug-report "forum".

Not funny, people. Seriously not funny!
Last edited by tommim; Jan 23 @ 1:45pm
ridcully Jan 23 @ 1:56pm 
well i also happily report here since i bought it here and i can not be bothered to create another account.

* once left the casle in act1 by the front door you seem no longer been able to enter it (i have some rooms to clear there). when entering the castle you end up in the throne room. you should have the option to enter the castle again. preferable either on the third or first floor.

* the F1-F4 keys are not working for selecting a character target for the effects of barrels
ridcully Jan 23 @ 2:05pm 
ah well ignore the first complaint. when hitting the "door" button in the dialog one enters the dungeon again. yet in this case the escape key should work the same way.
ovp45 Jan 23 @ 2:07pm 
Unable to load mono library from "E:/Program Files (x86)/Steam/steamapps/common/Might & Magic X - Legacy/Might and Magic X Legacy_Data/Mono/mono.dll" (error = 193).
RΞV [A] SuperBooM Jan 23 @ 2:23pm 
Originally posted by Guillermo:
The textured seem way blurrier then the early release. For instance the fences in the first town are like a solid brown, so is the wood on the doors... instead of a wood texture. I have my sliders all on max. How do you fix this?

same problem
RΞV [A] SuperBooM Jan 23 @ 2:28pm 
Originally posted by ridcully:
well i also happily report here since i bought it here and i can not be bothered to create another account.

* once left the casle in act1 by the front door you seem no longer been able to enter it (i have some rooms to clear there). when entering the castle you end up in the throne room. you should have the option to enter the castle again. preferable either on the third or first floor.

* the F1-F4 keys are not working for selecting a character target for the effects of barrels


try use the mouse button to select character with the Barrels
tommim Jan 23 @ 3:00pm 
So the description of the weapon slot in the character menu reads "you can equip shoes and boots to this slot".
Somehow I don't think that's the right text, or is it?

Also: is it just me or were the graphics looking much better in the Alpha version of the game? The textured are very low-quality even though I got all settings at "high" and "ultra". Also they changed the color profile, didn't they? The colors are much less vivid now and everything looks kinda washed out.

And another: if danger sense is active when you leave the first town the characters will bark over the voice-over for the narrator since they sense enemies nearby on the first tile.
Last edited by tommim; Jan 23 @ 3:39pm
FastaKilla Jan 23 @ 4:12pm 
Where my 1920*1200 resolution at game?
StorageFacilityManBoy Jan 23 @ 4:41pm 
The battle music doesn't seem to stop when all active foes are defeated. It just keeps playing, while another, more ambient track is playing at the same time.
Sadly, the game looks butt-ugly and with a weird set of resolution options. I thought this was not supposed to be a "made-by-fans-for-fans"-production... :(
solomanstone Jan 23 @ 4:52pm 
There is also this "UPlay" bug / thing. How do I get rid of it? I'm playing through steam. I shouldn't need to authenticate twice. Ridiculous ♥♥♥♥!
Showing 1-15 of 209 comments
< >
Per page: 15 30 50