Oxygenfad May 25, 2013 @ 1:34pm
Stuck on "First Time Setup"
I left the dialog box open for such a long time, at least 20 minutes. It hangs on "First time setup" trying to install .net. I installed .net 4.0 and xna 4.0 manually from the microsoft website and it still doesn't work. Can I get a refund ?
Showing 1-9 of 9 comments
< >
monsterpancake May 25, 2013 @ 4:28pm 
If it hangs again, try CANCEL and relaunch it again. If that doesn't work, restart Steam and repeat. I've seen this problem with other games, too.
Oxygenfad May 25, 2013 @ 5:03pm 
I did this. Tried "Delete Local Content" and downloaded again. still nothing. Rebooted etc. I think it doesn't actually download the file again, rather it "converts the exisiting setup files". I originally choose to install this on a dive which has a reputation to currupt files. I was thinking this might be the issue. If I try to do a fresh install, it's still using the same setup files I downloaded from the bad drive, so my hypothesis is that the setup is currupt.

How would I delete the set up files and make sure steam downloads the game fresh ?
BroDuck-senpai May 25, 2013 @ 5:48pm 
Go into your steam/steamapps/Super Puzzle Platformer Deluxe folder and delete the "_CommonRedist" folder, try and see if that works.
Oxygenfad May 25, 2013 @ 5:54pm 
didnt work.

If I try to launch this game from steam it hangs on the redist setup. If I launch it manually from its root folder it loads fine. Doesn't detect my controller. Pathtetic.
Last edited by Oxygenfad; May 25, 2013 @ 6:10pm
BroDuck-senpai May 25, 2013 @ 6:27pm 
Open task manager and close the redist setups, hopefully that'll work for ya.
bitcrusher May 25, 2013 @ 7:01pm 
You can just verify game cache most of the time instead of downloading it all again.
superjoebob  [developer] May 25, 2013 @ 8:00pm 
I don't know what you can try for the install issues, the XNA framework install stuff is a bit out of our hands. The first time .NET setup can definitely take a while, we're looking into anything we can do to shorten it up. We may be able to switch to a lighter version of the framework, but we're still testing that.

As for the controller, we're working on non XInput controller support right now so it should be fixed within the next few days.
BLUZARK May 26, 2013 @ 7:32am 
same issue here, my .net 4.0 installation is fine. but I can't launch the game because it gets stuck at the so called first time setup. the CMD script it should run is just blank and the installer get stuck at step 1 of 2. launching it from steamapps\common\Super Puzzle Platformer Deluxe does work.
Juuba Oct 14, 2013 @ 11:38pm 
Now, I don't know the answer to this, but in another game (Warthunder) I had the similar issue, with PhysXRedist.

IT was fixed with similar steps as are found here:
http://forums.steampowered.com/forums/showpost.php?p=33074483&postcount=9

The "app id" can be found from e.g the shortcut steam makes on your Desktop.

Now the problem is, I don't know the key-name or value for ".netRedist"... Sorry.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50