Cap'n Robot  [developer] Feb 22 @ 10:48am
Unicorn Beta 0.2
Fixed some bugs, had some leftover debug code messing things up... I forgot to remove it.
Anyhow, things we need to test:
  • Achievements on Mac
  • Achievements on Linux 32bit
  • Achievements on Linux 64bit
  • Saves on Mac
  • Saves on Linux
  • look for random weird bugs that mess everything up

Please let me know!
Showing 1-15 of 23 comments
< >
KingGraham'sPixelatedShoe Feb 22 @ 3:17pm 
Thanks! I have a Mac - will search for bugs! :)
anachoret Feb 23 @ 1:59pm 
Linux saves either are not working, or I am unware how to invoke them. Exiting the game and returning only presents new game options.

edit: Nor does alcohol poisoning achievement seem to work.
Last edited by anachoret; Feb 23 @ 2:06pm
Cap'n Robot  [developer] Feb 23 @ 6:16pm 
Originally posted by anachoret:
Linux saves either are not working, or I am unware how to invoke them. Exiting the game and returning only presents new game options.

edit: Nor does alcohol poisoning achievement seem to work.

anachoret, did you opt into the beta? does it say Unicorn 0.2 in the options?
32bit or 64bit?
anachoret Feb 23 @ 6:17pm 
Originally posted by Cap'n Robot:
Originally posted by anachoret:
Linux saves either are not working, or I am unware how to invoke them. Exiting the game and returning only presents new game options.

edit: Nor does alcohol poisoning achievement seem to work.

anachoret, did you opt into the beta? does it say Unicorn 0.2 in the options?
32bit or 64bit?

yes, beta opt-in, Unicorn 0.2, 64-bit.
[G4S] I am Sam, Seriously. Feb 23 @ 6:50pm 
Same here, no saves - no sign of saves in the game, if it wasn't for the "Reset" option and the beta "unicorn" being shown in there, I'd think it wasn't even there.
Other than that, my (quick) playthru only shows one minor issue. The d-pad right (Next item) still does not quite function.
Cap'n Robot  [developer] Feb 23 @ 7:45pm 
Originally posted by G4S I am Sam, Seriously.:
Same here, no saves - no sign of saves in the game, if it wasn't for the "Reset" option and the beta "unicorn" being shown in there, I'd think it wasn't even there.
Other than that, my (quick) playthru only shows one minor issue. The d-pad right (Next item) still does not quite function.
What OS?
Does assigning "Next Item" to something else work?
Turbulentium Feb 24 @ 7:46am 
Hi, another Linux (Ubuntu 12.04 x64) user here. It seems that in my case the save feature is working, but something is wrong with it.
When I exit the game, then start it again and try to resume, something weird happens. For a couple of seconds there's just a black screen (the inventory is shown though, so I can see that my stats are definitely saved), then my character appears at the top of the screen, falls all the way down and disappears somewhere below the bottom edge. I can choose items from my inventory, use or drop them. I took a couple of screenshots, here they are:
http://cloud-3.steampowered.com/ugc/795187630888594304/94B0DF7A85EFC4E35B057A561547B1BD77546999/
http://cloud-2.steampowered.com/ugc/795187630888605862/78D8F78D82FA6A6985719014DBA1D17662612F00/
Here I tried to fire my flare gun, the projectiles on this screenshot are flying upwards:
http://cloud-4.steampowered.com/ugc/795187630888610524/B26FA662F34614AA75C2849294C8D678FD1526F1/
Everything else works perfectly and nothing like this happens if I resume without exiting.

Ubuntu 12.04.4 LTS x64
Nvidia GeForce 9600 GT
Driver Version: 304.116
Beta opt-in, Unicorn 0.2
Cap'n Robot  [developer] Feb 24 @ 8:58am 
Originally posted by Turbulentium:
Hi, another Linux (Ubuntu 12.04 x64) user here. It seems that in my case the save feature is working, but something is wrong with it.
Any luck with the 32bit version of Unicorn?
Turbulentium Feb 24 @ 9:30am 
Originally posted by Cap'n Robot:
Originally posted by Turbulentium:
Hi, another Linux (Ubuntu 12.04 x64) user here. It seems that in my case the save feature is working, but something is wrong with it.
Any luck with the 32bit version of Unicorn?
I've already tried both versions and I've just tried one more time, but no, same result.
Started new game, passed a couple of levels, exited, resumed, and here I am, somewhere below, wearing a cake-hat:
http://cloud-3.steampowered.com/ugc/795187630918551090/4BBCB0201C3646A974810FE60D12E908B034A07F/
repartoferramenta Feb 24 @ 1:59pm 
Same issue here. Also my score is not being added when returning to the tavern.
Cap'n Robot  [developer] Feb 24 @ 6:16pm 
Originally posted by Turbulentium:
I've already tried both versions and I've just tried one more time, but no, same result.
:\ Can you delete the local content and re-download? Other players on Linux are reporting that it's working.

Originally posted by repartoferramenta:
Same issue here. Also my score is not being added when returning to the tavern.
Are you also running linux? What do you mean the score is not being added? it's not going to the highscore list when you return with the treasure?
anachoret Feb 24 @ 6:58pm 
Deleting all local content (not just re-verifying the cache), and then re-downloading the beta just now fixed the Save Session / Game issue for me. Any idea why Steam updating didn't seem to work?
Cap'n Robot  [developer] Feb 24 @ 9:12pm 
Oh good! Someone else mentioned re-installing had fixed things for them, so I was just hoping it was a batch of bad installs. No idea what's up with steam
repartoferramenta Feb 25 @ 1:06am 
Originally posted by Cap'n Robot:
Are you also running linux?

Ubuntu 13.10 x64, NVIDIA 460 GTX with 319.60 driver. Neither 32bit version is working.

Originally posted by Cap'n Robot:
it's not going to the highscore list when you return with the treasure?

Exactly. And it was a VERY GOOD score... XD

BTW, reinstalling (twice) didn't work for me.
Last edited by repartoferramenta; Feb 25 @ 1:10am
Turbulentium Feb 25 @ 1:16am 
Originally posted by Cap'n Robot:
Originally posted by Turbulentium:
I've already tried both versions and I've just tried one more time, but no, same result.
:\ Can you delete the local content and re-download? Other players on Linux are reporting that it's working.

Well, I must be the unlucky one. I've deleted all local content and reinstalled the game again, I've tried different versions of video drivers (just to be sure) - nothing helps.

I've done some more testing and found out that if I exit the game just after I've entered a new level (no monsters killed, no walking around this new level) resuming works. In some strange way, but works.
Here I've just entered a new level:
http://cloud-2.steampowered.com/ugc/795187630932895876/79294EE2E9CC5DAA2C3E0A47D54E58F4BEF85A2D/
Then I exited, resumed (a couple of seconds of black screen again) and found my character floating in the air:
http://cloud-3.steampowered.com/ugc/795187630932921705/39FE7C5B821ED879BF2DF6ACA6F129FB2A5A0808/
Then I fell over the edge:
http://cloud-2.steampowered.com/ugc/795187630932938104/9398B810C3FF506E49FAC4A2B3EBE59FAC3D8AA0/
... and "respawned" on the previous level:
http://cloud-2.steampowered.com/ugc/795187630932943813/A4AF4168E8F790014BDBD7870F6367CC1BB2FD6F/
And then I could continue to play.
But if I try to kill some monster or walk around a bit, I still get this falling-through-black-screen thing I described before.
Showing 1-15 of 23 comments
< >
Per page: 15 30 50