L'autre. May 29, 2013 @ 7:31am
Proasm ShadowWarrior port: OpenGL, HD textures, 3Dmodels, multiplayer
Proasm shadow warrior port is based on jonof port (the same guy who worked on the duke3D port which Duke3DMegaton and eduke32 are based on).

homepage: http://www.proasm.com/sw/swp.html

Original files are required to play, just unzip Swp432.zip in SteamApps\common\Shadow Warrior Original\gameroot\ and run SWP.exe.

be careful there a bug with savegames sometimes.
To fix sounds set compatibility mode to "Windows Vista".

there also an HD textures pack with 3d models if you are interested, look over duke4net forums (http://forums.duke4.net/topic/3412-shadow-warrior-high-resolution-pack/).
or there the direct link to the files if you don't want to mess with SVN tools :
sw_hrp.Rev 17 2012-07-05 .7z (65.5 MB)[mega.co.nz]


extract everything in SteamApps\common\Shadow Warrior Original\gameroot\ and run :

- HRP.bat (High-Resolution-Pack)
or
- LRP.bat (Low-Resolution-Pack, The LRP contains 75% scaled down versions of select assets from the HRP for use on slower PC's and laptops. It is completely dependent on the HRP)

But the game look way better to me without that texture pack, just use SWP and set texture filter to Linear.
Last edited by L'autre.; May 29, 2013 @ 11:07pm
Showing 1-15 of 62 comments
< >
RenZ() May 29, 2013 @ 7:52am 
Thanks. I also forgot it was long time since i tried it
Joker Mole May 29, 2013 @ 7:57am 
Good information but I don't think it's fair to call DOSBox "crap". Someone worked very hard on dosbox and without it we wouldn't have access to a large number of older games.
RT May 29, 2013 @ 8:11am 
Yeah. Also this SWP stuff doesn't work.
HenitoKisou May 29, 2013 @ 9:02am 
It's working but sound is badly disorted no matter what setting is made on Win7 and Win8 (music, ambient, Lo Wang speech).
天龍 Tenryuu (Miky) May 29, 2013 @ 9:06am 
Hmm i can't get working when i run it the game will closed and says dosbox.stopped working.I rename that source port to order play in steam :(.
Last edited by 天龍 Tenryuu (Miky); May 29, 2013 @ 9:06am
Kenshiro3 May 29, 2013 @ 9:11am 
I wouldn't use any of the source ports if I were you. They are incomplete & extremely glitchy/unstable
El Wurmio May 29, 2013 @ 9:24am 
Nice, just tried ProASM. WAY better than the DosBox Version in my Opinion. I hoped they would do such a nice port like they did for Duke 3D, but unfortunately not. Well, at least it's free!
Splooge McDuck May 29, 2013 @ 9:42am 
Any way to get the port running through Steam?
kromando33 May 29, 2013 @ 10:38am 
I've been trying to SW OpenGL Port recently and although it scales fine, the big issue I'm having is that the cool death animations from the DOS version don't seem to work in the port. In the DOS ver when you kill an enemy with the sword they get cut in half, but in the port they just collapse with blood. Really lame
Last edited by kromando33; May 29, 2013 @ 10:39am
>origami< May 29, 2013 @ 10:42am 
I don't know about running the port through Steam but it definitely works if you install and run it following the SWP instructions that are included with the port download.
Have fun! :-)
SANIC May 29, 2013 @ 10:47am 
AMAZING. PROASM WORKS WITH THE SW OF STEAM. :3
Matt May 29, 2013 @ 10:57am 
Originally posted by Chainworm:
Nice, just tried ProASM. WAY better than the DosBox Version in my Opinion. I hoped they would do such a nice port like they did for Duke 3D, but unfortunately not. Well, at least it's free!

Its been worked on as we speak, this is just a promotion
Cae May 29, 2013 @ 11:55am 
Originally posted by Kfoolu:
Any way to get the port running through Steam?
I made an .exe file that you can replace the original DosBox.exe with. It runs SWP.exe as long as it's placed in the correct folder, nothing else.
I've uploaded it to http://steamcheeves.com/SWP/DosBox.exe if anyone wants to try.
Last edited by Cae; May 29, 2013 @ 11:56am
L'autre. May 29, 2013 @ 2:23pm 
i have some sound crackling problems, looking for a fix hmm..
Voxel May 29, 2013 @ 2:58pm 
Originally posted by kromando33:
I've been trying to SW OpenGL Port recently and although it scales fine, the big issue I'm having is that the cool death animations from the DOS version don't seem to work in the port. In the DOS ver when you kill an enemy with the sword they get cut in half, but in the port they just collapse with blood. Really lame
In Options > Game Options > More, turn off "Ninja Sliced Hack". Not sure why that option is on by default.
Last edited by Voxel; May 29, 2013 @ 2:59pm
Showing 1-15 of 62 comments
< >
Per page: 15 30 50