Realms of Arkania: Blade of Destiny

Realms of Arkania: Blade of Destiny

View Stats:
 This topic has been pinned, so it's probably important
Chris Firefox  [developer] Nov 15, 2013 @ 1:38pm
Fatal Error in GC: DuplicateHandle Failed
As this Unity-Related error still seems to appear after several years, here is some information on how to fix some of the Problems:

When using AVAST Antivirus: The problem seems to be caused by UPGRADING from Version 7 to Version 8 of AVAST. Problem fix appears to be Uninstall, reboot, Clean install. Source:

Another Fix for Avast: Uncheck: Settings -> Toubleshooting -> Enable hardware-assisted virtualization. Source:

When using ESET: Don't know if this still applies, but it seems that adding an Exclusion for WebAccess protection does the trick. Source and Step-by-Step-Guide:

We had also reports of users that successfully prevented this from happening when running the game in "Compatible Mode" (which basically forces it to run in DX9 instead of DX11).

Another compatiblity mode that worked for some users was the windows compatibility mode. Try to run the file "schick.exe" in the installation directory directly, but with windows execution compatibility (Steam -> Library -> Right click to Realms of Arkania -> Properties -> Explore local files, then Right click to schick.exe -> Properties -> Compatibility) set to Windows Vista or even Windows XP. Backed up by Source:

The earliest reported instance of a problem with the GC was discussed on the Unity Forums as early as 2009. Although I doubt that it is still the same problem, it seems to be a reoccuring problemset with Mono and Windows and certain AV Software in General. Anyways, if there are any further suggestions for the solution of this problem, even permanent ones, I'm happy to add them here or try them out.
Last edited by Chris Firefox; Nov 15, 2013 @ 1:45pm
< >
Showing 1-4 of 4 comments
Wereant Feb 5, 2014 @ 1:32am 
I got this problem nearly everytime i start a game. So i load different save files one after another and after 2-8 restarts it eventually works fine.
Marshall Mar 16, 2014 @ 3:23am 
well, the problem is back. I have Avast (clean install), even tried to turn off the virtualization, but still the error. When I uninstalled Avast, everything works fine (win 7 64bit).

will try AVG...
EDIT: Ok with AVG, it works fine. Still I described the problem to Avast uninstall questionare...
Last edited by Marshall; Mar 16, 2014 @ 4:11am
wk37781 Jun 15, 2014 @ 8:31pm 
i have this problem and i'm running it on a Mac. any fixes for that?
Perihelion Jun 15 @ 8:59pm 
I made a new save (empty slot) at the spot where i was getting the error message and reloaded from that. It worked.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50