Expeditions: Conquistador > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Lilltiger 19 Οκτ, 2013 @ 7:08πμ
[Linux] Game crashes when rotating the battle map.
When playing the 64-bit lunix version and i got into battle, if i rotate the battle map byt using the right mouse botton for more thern a fw seconds the game freezes and i have to terminate the process.
Εμφάνιση 1-15 από 16 σχόλια
< >
Nova  [δημιουργός] 19 Οκτ, 2013 @ 1:01μμ 
Does it happen if you use the Q and E keys as well?
Lilltiger 19 Οκτ, 2013 @ 3:28μμ 
No, Q and E works just fine, noticed right now when I tested that it happens in the regular view as well, not only in battlemap. And if I Alt+Tab and wait a while the game starts responding again (it does not start to respond ever, if I do not alt+tab out). And if i hold the right mouse button and move the mose realy slowly it works fine, but if i do any larger mouse movements the game freezes, and sometimes blacks out.
The more I move the mouse with the right button pressed, the longer the game will appear frozen, so it's like the game get so meny instructions to rotate that cant handle anything else for quite a while. So the game appears to be frozen while it's actually not.

Normaly the game uses about 107% CPU (one full core+a litte of another), and the X process takes about 5%, when i rotate using Q or W the X process takes 12% cpu and the game takes 107%. Same when I move the mose slowly, but when moving it faster the game process usage drops to 33% and the X process spikes at 100%. Untill I tab out, then the X process drops to 10% again and after a little while (from 1sec to 1min depending on how much i moved the mouse) the game starts to respond again.

Anything else I should test to help you find the issue?
Τελευταία επεξεργασία από Lilltiger; 19 Οκτ, 2013 @ 3:31μμ
Nova  [δημιουργός] 19 Οκτ, 2013 @ 5:19μμ 
Could you please try to disable the Steam overlay and tell me if it helps in any way?
Lilltiger 20 Οκτ, 2013 @ 3:41πμ 
Disabling the steam overlay did no difference at all.
Nova  [δημιουργός] 20 Οκτ, 2013 @ 7:57πμ 
I'll ask our programmer on Monday. This seems very strange, as I believe we use the same call for right click as for Q and E.
If you could, it could be helpful if you could play the game and trigger the issue, then quit the game and find and upload your player log (Located in "~/.config/unity3d/Logic Artists/Expeditions Conquistador/Player.log"). It might shed some light on the issue.
Lilltiger 20 Οκτ, 2013 @ 8:47πμ 
Here is a player log of it:
http://pastebin.com/yytF20XF

here I load the game, rotates with the mouse, game stalls, i alt+tab out, wait for game to respond. Rotate again with the mouse, game stalls, alt+tab then when the game responds again I press esc and quit the game.
Nova  [δημιουργός] 21 Οκτ, 2013 @ 1:25πμ 
Ok, I've talked to Juan, our programmer and it seems this is one of the ways in which Unity and Linux doesn't work together so well (Unity. in general, doesn't like the mouse in Linux). Linux support is still fairly new to Unity, so hopefully it'll get fixed downstream at some point.
Until then, I recommend using Q and E.
Lilltiger 21 Οκτ, 2013 @ 7:13πμ 
Then I recommend that you change the default behaviour of the mouse in Linux, so mouse rotation is disabled by default, and add a notation about why itäs disbled in the gui. Just so others wont run into this and starts to dislike a great game because a silly engine related bug like this.

Btw, Kerbalspaceprogram is also using the unity3d engine and mouse rotations works for them(while zooming dosent work well, way too big steps), you might send them a message and ask them how they solved it. Just an idéa.
Lilltiger 21 Οκτ, 2013 @ 3:18μμ 
I just noticed that this happens when rotating with Q and E as well if one hold them so it rotates for a few seconds.
anborn  [δημιουργός] 22 Οκτ, 2013 @ 12:56πμ 
Αναρτήθηκε αρχικά από Lilltiger:
I just noticed that this happens when rotating with Q and E as well if one hold them so it rotates for a few seconds.
Thanks for the info. We'll take a look into it.
malevolent 17 Νοε, 2013 @ 3:10μμ 
Well, I'm with the same issue here... it's a bit frustrating, because I'm used to other games to rotate with mouse and I did uncounciosly
Pawel (LINUX) 18 Νοε, 2013 @ 12:59μμ 
Same here - problems with rotating exist everywhere on main map on fighting scene etc. Q and E works properly. It's a good idea to switch mouse rotation off in linux version.
Τελευταία επεξεργασία από Pawel (LINUX); 18 Νοε, 2013 @ 1:03μμ
Lilltiger 19 Νοε, 2013 @ 8:35πμ 
Q and E rotations dosent work for me as i said erlier, they are less broken, bu if you hold them the same issue as with the mouse will occure for me.
Kakila 23 Ιουν @ 2:12πμ 
Version 1.6.6 Problem remains in Ubuntu 14.04 with or without primusrun.
Mouse rotation hangs immediately and CTRL-Tab is needed to reactivate it.
Q and E keys are a little it more robust but eventually they also hang the game.

Please give us the link to the Unity bug report so we can heat it up.
Thanks
Tak! 30 Ιουλ @ 3:46μμ 
Others are reporting that this issue is fixed with Unity 4.5.2.
Εμφάνιση 1-15 από 16 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 19 Οκτ, 2013 @ 7:08πμ
Αναρτήσεις: 16