maaktmijwatuit Apr 19 @ 1:49am
Battle enter, CTD.
It appears that everytime I enter a battle, I crash to desktop. It gives me an error code and says it made a report, but I'm not good with reading reports, it's all gibberish to me. Can someone help me?
Showing 1-4 of 4 comments
< >
Nicholas Apr 19 @ 2:01am 
It's all too common, unfortunately. Systems with 4GB or less of RAM really struggle, even where they meet the "recommended" specs on the store page (which is something which should probably be revised).

Try turning down the graphical settings. It at least helped me get a bit further, though I got to a later point where it crashed all the time.

I wound up uninstalling it until I got a new computer (on which it runs flawlessly).
Last edited by Nicholas; Apr 19 @ 2:03am
maaktmijwatuit Apr 19 @ 2:04am 
Yeah, I must say that since the warranty on this old thing expired, it's become more and more ♥♥♥♥. I'll try turning down the graphicals. Thanks for the tip.
smokin.gizmo Apr 21 @ 10:43am 
I have the same problem. Every time I start a combat I get to the loading screen and then the game just crashes to desktop - without any error message thou. Weird thing is, the first (tutorial) fight worked without problems.
Nicholas Apr 21 @ 9:06pm 
There are different battlegrounds and troop numbers, so some combats are more demanding on the system than others. I had constant crashes at one of the final combats on the first map, then upon leaving the first map, and then at a combat in the early stages of the second (at which point I gave up).

I guess all you can do is turn down your graphical settings as much as possible or, as I did, wait until you upgrade your system.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50