Argus Jul 15, 2013 @ 5:47pm
Dust Crashes On Startup
I've searched the forums for a solution - other people have reported the problem but as yet I've found none with an answer.

The game loads until the ESRB screen fades out, then crashes. ("Dust: An Elysian Tail has stopped working.")

Windows 8
Intel(R) Core(TM)2 Quad CPU Q9550 2.83 Ghz
Nvideo GeForce 670 GTX
4 Gigs ram

I've run the game in compatibility mode for both Windows 7 and XP (SP3). I've run as an Administrator (for both.) I've checked my XNA framework - up to date at 4.5. Checked that .wma and .wmv run with the Windows Media Player (although I think that is a separate bug.)

Any suggestions, @noogy?
Showing 1-15 of 57 comments
< >
yanwei Jul 15, 2013 @ 7:13pm 
Having the same problem too. Did what you did.

Windows 8
i7-2600k and 8 gb ram
GTX 580
Single monitor setup

Can this be a windows 8 problem?
Yeiazel Jul 15, 2013 @ 7:49pm 
I not saying its the prob but since its a game coming from XBOX live be SURE you

1- got a compatible gamepad plugged on your port **Xbox gamepad** many game CRASH if the pad is not compatible.

2- if you got a imcompatible pad plugged unplug it so you can play it with you keyboard and mouse.


If your pad is incompatible use the program called *motionJoy* this program will act like a proxy and will fool your pc by hiding you actual pad and making it pass for a Xbox pads.

Hope it will help you guys i wish you luck!
Molebucks Jul 16, 2013 @ 8:01am 
I'm having this problem too. It worked yesterday and stopped working today.

Windows 7, x64
AMD Phenom II X4 945 Quad CPU
12GB RAM
ATI Radeon HD 5800

acehawk Jul 16, 2013 @ 3:11pm 
I had this EXACT same thing happening to me. I found that it was caused by having all audio devices, e.g. speakers, diasabled. Fixed by enabling at least one audio device.

I figured it out because I have a media player that freaks out if I don't have any audio devices enabled when it starts. I gues Windows Media Player does something similar.

Hope this helps!!!
tyberzann11 Jul 17, 2013 @ 5:50pm 
nice it worked 4 me
Argus Jul 17, 2013 @ 6:57pm 
Thus far this doesn't help. Any other ideas?
yanwei Jul 17, 2013 @ 9:01pm 
Not sure if it works for you guys. But i found that disconnecting the hdmi cable (from tv) thats connected to my gfx card works. Only video out is the DVI cable to the monitor.
I'm using wireless xbox controller, gtx580, i7 2600k and windows 8.
Avarah Jul 17, 2013 @ 11:02pm 
I'm also having this problem =(
[OT]Nekrage (Banned) Jul 18, 2013 @ 1:56am 
same problem wasted money
Gohanks Jul 20, 2013 @ 11:46am 
same here, waiting for any solution
tpbutch Jul 20, 2013 @ 8:52pm 
Same. I played 3 hours earlier in the week and now this. Nothing has changed on my end.
Sahri Jul 21, 2013 @ 11:14am 
Originally posted by tpbutch:
Same. I played 3 hours earlier in the week and now this. Nothing has changed on my end.
You sure? It could be that something like your virus scanner received an update that could conflict with the game.
Gohanks Jul 21, 2013 @ 12:16pm 
No such thing in my case, every redist pack & driver installed correctly. Additionally that's the only game I have from steam, that has no shell icon so I guess it might be a download problem, or corrupted file. Tried to reinstall and redownload, unfortunatelly no improvements.
Rio Jul 21, 2013 @ 12:48pm 
I got the same problem and tried lots of different things and none of them worked. I finally decided to reinstall Windows and now it's working fine. Seems like some DirectX, XNA, dotNET issue which can only be resolved with a clean Windows installation.
Nicholas Steel Jul 21, 2013 @ 12:55pm 
If you use an Nvidia card, try doing a Clean Install of the nvidia 314.22 display drivers. The newer drivers in the 320.xx and 326.xx driver series are problematic for various users.

Run the Driver Installer, choose to do an Advanced Install, then tick the bottom check box to do a clean install.
Showing 1-15 of 57 comments
< >
Per page: 15 30 50