tech-no-logical Jan 4 @ 4:16am
game won't even start, eventviewer shows errors
when I start the game, the screen goes black, and in a second I'm back to the desktop. no errors show, but in the event viewer I see this :


Application: DustAET.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Microsoft.Xna.Framework.Content.ContentLoadException
Stack:
at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(System.IO.Stream, System.String, Int32 ByRef)
at Microsoft.Xna.Framework.Content.ContentReader.Create(Microsoft.Xna.Framework.Content.ContentManager, System.IO.Stream, System.String, System.Action`1<System.IDisposable>)
at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String, System.Action`1<System.IDisposable>)
at Microsoft.Xna.Framework.Content.ContentManager.Load[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String)
at Dust.Game1.LoadContent()
at Microsoft.Xna.Framework.Game.Initialize()
at Dust.Game1.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean)
at Dust.Program.Main(System.String[])

followed by :

Faulting application name: DustAET.exe, version: 1.0.0.0, time stamp: 0x522a507f
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18229, time stamp: 0x51fb1116
Exception code: 0xe0434352
Fault offset: 0x0000c41f
Faulting process id: 0x19dc
Faulting application start time: 0x01cf09457945a312
Faulting application path: E:\SteamLibrary\steamapps\common\Dust An Elysian Tail\DustAET.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: b810830c-7538-11e3-bce6-005056c00008

I've reinstalled the game, steam verifies the files as OK. reinstalled .NET, reinstalled xna, nothing works.

any ideas ?
Showing 1-6 of 6 comments
< >
Revy | Dream Of The Sky Jan 5 @ 10:04am 
I'm getting the exact same errors. Is there anything you can do to fix it?
tech-no-logical Jan 6 @ 4:07am 
I've tried everything I can think of, but nothing worked so far. I suspect it might have something to do with :

- the fact that my steam library is not on c:\
- the fact that I've hard-linked my windows 'Users' folder from c:\ to e:\

I can't easily change either of these, so I can't test :(
-=(Luffiy)=- Jan 6 @ 6:53pm 
same problem here :-/ Doesn't even load up, My steam will show i'm playing it and 2 min later goes back to "not on a game".
tech-no-logical Jan 7 @ 2:28pm 
I finally got it to work ! I had already reinstalled xna 4.0, but I noticed I also had xna 3.1 installed. I uninstalled both, reinstalled xna 4.0 from the redistributables, and it finally worked ! I hope this'll help someone else...
DestroyerNixon Jan 8 @ 7:53am 
^ This works! Someone pin this answer as working. To all: do not uninstall Visual Studio, Visual C#, and especially XNA 4.0. This is a key API.
Shamu450 Feb 18 @ 4:11pm 
Worked for me as well, thanks a bunch!
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Jan 4 @ 4:16am
Posts: 6