Noogy  [developer] Dec 19, 2013 @ 12:46am
Dust:AET now available for Mac & Linux!
Due to overwhelming demand, I'm happy to announce that Dust:AET is now available for Mac and Linux!

Dust:AET is a Steamplay title, meaning that if you already own the Windows version, you get the other platforms free of charge! Many thanks to flibitijibibo for his work on the port. Please keep all Mac or Linux support issues in this thread. Thanks, everyone!
Showing 1-15 of 181 comments
< >
[LapFox] Elysian Maybe Dec 19, 2013 @ 12:52am 
yay!
MAD Minori Dec 19, 2013 @ 12:55am 
Finally! I bought it from the current Humble Bundle and waited so long for this day! Unfortunately, I can't install it, the download finishes with 0 Bytes of data. Needless to say, I'm not able to play it. Guess the game data isn't provided completely yet. Jeez, I fear I'm gonna die ;_;
Noogy  [developer] Dec 19, 2013 @ 12:56am 
@MAD Minori, Mac or Linux? The builds should be up, but maybe I've missed something.
FoulCrow Dec 19, 2013 @ 1:10am 
My download doesn't work as well, it says that it's finished downloading instantly after i press download, and of course the game wont start without anything actually downloaded. i'm hoping this problem will be solved over the next 24 hours, i just cant wait to try this game out!
ezekiel000 Dec 19, 2013 @ 1:11am 
The linux version downloads 0 bytes at the moment.
A Crazy Mind Dec 19, 2013 @ 1:12am 
+1, I can confirm the error for linux.
Noogy  [developer] Dec 19, 2013 @ 1:15am 
Alright, thanks everyone, I'm seeing the same problem online. I do know that 'some' people are able to download it, I'm wondering if it's slowly rolling out regionally. I'm looking into this, thanks for your patience!
flibitijibibo  [developer] Dec 19, 2013 @ 1:16am 
Should be downloadable now. Had to add the depots to the public Dust subscription.
Noogy  [developer] Dec 19, 2013 @ 1:19am 
Ah, thanks for saving the day, flibitijibibo!
Flugsio [Archlinux] 🐧 Dec 19, 2013 @ 1:19am 
Yes, download just started, yay! :)
ezekiel000 Dec 19, 2013 @ 1:27am 
It's working now.
koyal13 Dec 19, 2013 @ 2:03am 
Oh yes! I was wishing play this game on Linux. Download it's perfect to me...
Gripz Dec 19, 2013 @ 2:20am 
Thank you for the port I have only tested about 10 minutes in game but it's working exceptionally well on Gentoo Linux 64bit with an AMD HD6870.It's the first game I can recall that needed zero configuration for my playstation 2 controll pad, which worked straight from the menu and the button layout was as expected (big thanks for that)
Koscum Dec 19, 2013 @ 2:41am 
First of all, thank you so much for the Linux port; you're awesome and I can't wait for your next project to hit the shelves.
I thought I'd have some issues running it as I have yet to compile 32bit MESA 9 drivers successfully on Debian 7, but then you decide to blow my mind by including 64bit binary as well. The game is working Taricly (fabulously for those who are not that much into LoL); had to tone down some eyecandy on HD4000, but it's flying like RD on anything with proper driver set that I tested it on. Keep up the great work!

P.S.
Is it just me or are cloud saves disabled for now?
[LINUX]Letik Dec 19, 2013 @ 3:01am 
Thanks for the Linux Version ! :) Bought it on the Humble Store !
Showing 1-15 of 181 comments
< >
Per page: 15 30 50