Tetrobot and Co.

Tetrobot and Co.

통계 보기:
Tetrobot and Co. > 일반 토론 > 제목 정보
 이 토론은 고정되었습니다. 중요해서 그렇겠죠?
nitram  [개발자] 2013년 12월 17일 오전 6시 16분
Tetrobot and Co. - Level Editor Technical Support
Hi everybody!

Since the v1.1.0, we are including the Level Editor in the game. Accessible through the Community Menu.

If you have some technical issues (bugs, crashes, etc), please drop us a comment here so we can list all the issues, and give there status here!


Known issues
- under Linux/Mac, only the local edition of level is working, the synchronization with the workshop is failing (stay stuck on "synchronizing")
< >
1-1515개 댓글 표시
Deadpool 2013년 12월 17일 오전 7시 20분 
Just found a couple of minor bugs

If I create a level and add portals, then leave the editor and play on a different level, the portal ID will be shown on the screen. Here's a couple of screenshots:



I easily fixed it by removing the portals from the level I was editing
Restarting the game also fixes it

Another small one:

When creating a level, if you play the level and put Psychobot into a cannon, go back to the editor and then go back to play the level again, he will start inside the cannon instead of at the beginning

Only minor bugs, just thought I would point them out :P
Deadpool님이 마지막으로 수정; 2013년 12월 17일 오전 7시 23분
nitram  [개발자] 2013년 12월 17일 오전 11시 59분 
thanks for poiting that out AdpApt*!

added to the tofix list!
Tbaggi 2013년 12월 18일 오전 4시 25분 
More minor display bugs. :p

Top line:

Bottom Corner:

French switch:
J'ai aussi eus un bug lorsque je veux relier 2 salles en allant de celle de droite vers celle de gauche. La liaison ne se fait pas, il y a un bloc de décors qui coupe le tuyau.

Thanks for this update btw, editor is really easy to use.
Tbaggi님이 마지막으로 수정; 2013년 12월 18일 오전 4시 27분
Deadpool 2013년 12월 18일 오전 6시 16분 
Just found another

The ghost switch ID isn't showing when I play or edit a custom level
It only shows the ? sign and not the switch ID shape
Deadpool님이 마지막으로 수정; 2013년 12월 18일 오전 10시 39분
Voomby 2013년 12월 18일 오후 4시 32분 
Is it possible to have an undo button - many a time I've deleted something by accident, or replaced an item with the wrong thing, or even hit the delete key without thinking and ended up deleting a whole page, and racked my brains to work out what was on there. To be able to undo my mistakes would be really helpful. Thanks
agsjmitchell 2013년 12월 20일 오후 2시 00분 
Agree with Voomby that an undo button would be really helpful. I keep dragging blocks all over the screen overwriting what is already there!
Voomby 2013년 12월 24일 오전 6시 10분 
Have had a few issues where deleting an item hasn't deleted it properly - for example, I placed Big Mama in a level, but when I went to reposition it the initial one disappeared, but the level wouldn't let me place a new one. On another occasion I ended up with a screen showing about three Big Mama's because the old one's wouldn't disappear from the screen after being deleted. Also, when copying a screen and pasting it, sometimes the background images disappear on the pasted screens, and then trying to delete the existing screen causes it to still be shown. Exiting the game and reentering helped in each case, but thought you'd like to know of these bugs. Thanks.
Raszlo 2014년 1월 6일 오후 6시 51분 
placing pipes on the edges wont connect to the next screen, if it was not created earlier (by adding anything there). Connecting pipes between two freshly made screens and attaching exits wont make the pipe work, before one does load the level (which saves the file and apparently changes some stuff) twice. Adding and deleting pipes on the edges may result in unremovable pipe pieces atuck somewhere soutside the screen - I noticed this when looking at the text file, there were no more pipes in the map, but the file contained like 10 extra pipe elements.
Sloth 2014년 1월 11일 오전 8시 54분 
I published a level to the workshop but it wasn't showing up after a week on the list even though newer levels were so I deleted it from the workshop then tried to republish it. Every time I tried to publish the level it kept saying File Not Found and also wouldn't let me take a screenshot of the level. Changing the name of the level didn't resolve it; I think the only way to fix it may be to recreate the level from scratch.
Raszlo 2014년 1월 11일 오전 9시 31분 
recently it appears that levels show on the list after quite long wait...
Sloth 2014년 1월 11일 오전 9시 51분 
I thought so too but levels posted several days after mine were showing up. I just deleted the level completely and recreated it from scratch and it is now showing up in the workshop under new levels after only a few minutes.
Raszlo 2014년 1월 11일 오후 12시 36분 
They appeared, but they were posted even earlier. In other topic we posted a few levels that didnt want ot show up, but after quite some time they suprisingly appeared. I think it might have been over a week. You can try posting a direct link to Your level in that topic ;)
TheGlecter 2014년 1월 20일 오전 4시 51분 
Which file or folder stores the custom maps you're working on? I'd like to make backups now and then... ;)

The only 2 things in the editor I miss are a 'Move' tool and a Undo feature, but it is pretty user-friendly already!

About bugs... the game froze a couple of times when using the rewind button, but I think it has something to do with shooting blocks out of the play area with cannons. If the problem persists once the level is complete, I'll let you know!

I'll be posting about cosmetic things and other bugs whenever I find them.
TheGlecter님이 마지막으로 수정; 2014년 1월 20일 오전 4시 52분
Raszlo 2014년 1월 20일 오전 10시 11분 
The levels folder couldnt be simplier lol
I have no idea what "10796330" is for, but its the only folder inside "userdata" for me, "235980" is for Tetrobot and co.
There is also completely different folder with maps you download, so you can actualy work on published levels.
TheGlecter 2014년 1월 20일 오전 10시 58분 
Thanks! :)

The first number is probably a Steam User ID since I have a different number.
< >
1-1515개 댓글 표시
페이지당 표시 개수: 15 30 50

Tetrobot and Co. > 일반 토론 > 제목 정보