METAL GEAR RISING: REVENGEANCE

METAL GEAR RISING: REVENGEANCE

View Stats:
Fix this game on AMD Cards
When I had Nvidia the game's hud never flickered now with my radeon r9 290x the hud flickers like crazy fix please and thank you. (Running the latest stable 14.4 drivers)
< >
Showing 1-11 of 11 comments
Zard Jul 21, 2014 @ 10:07am 
strange im running a Asus Radeon HD 7770 1GB GDDR5 with the same drivers and i run the game fine maybe you have some software issue ?
[MGSFC] Maniac_34 Jul 21, 2014 @ 10:22am 
Not sure. I have another friend who has the Sapphire AMD Radeon HD 7850 and he tells me he sees flickers (14.4 driver). I don't think it's a software issue because I had to reinstall the drivers once before because battlefield 4 didn't have the mantle option. Once I reinstalled it I got the option
[MGSFC] Maniac_34 Jul 21, 2014 @ 10:24am 
Also running Windows 8.1 Pro 64 bit (so is my friend) with nvidia though I ran it on 8.1 pro 64 bit and no issues at all.
I have win 8.1 Pro 64 bit. Works fine.
Zard Jul 21, 2014 @ 11:48am 
i have windows 7 btw
Last edited by Zard; Jul 21, 2014 @ 11:48am
[MGSFC] Maniac_34 Aug 25, 2014 @ 8:36am 
I fixed it with Radeon Pro. Turns out the HDMI 24 hz bug also applies to DisplayPort... Lol
Erik Aug 25, 2014 @ 2:30pm 
One solution is to play the game in windowed mode. You can then use Borderless Gaming to make it look like it is is full screen anyway: https://github.com/Codeusa/Borderless-Gaming/releases
Last edited by Erik; Aug 25, 2014 @ 2:30pm
SonsOfLiberty86 Aug 25, 2014 @ 8:20pm 
R9 270X here, and I had this same problem with screen flickering ( I also have Win 8.1 64 bit) and I just found a fix!

Here is HOW TO FIX (don't know if this works for everyone but worked for me and a few people below so far):

- Close your game if it is open. Goto your MGSR directory (Steam/steamapps/common/METAL GEAR RISING REVENGEANCE/)

- Right click on the main game exe file and click on properties.

- Goto the Compatibility tab and check Compatibility Mode > Run this program in compatability mode for: Windows XP (Service Pack 3).

- Also be sure to check "Disable display scaling on high DPI settings".

- Click apply, then OK. Run the game.

Again I don't know if this will work for everyone but this just fixed my flickering problem. Hopefully this helps someone else out there.
Last edited by SonsOfLiberty86; Aug 29, 2014 @ 4:19pm
tommyshaw Aug 29, 2014 @ 9:29am 
Originally posted by SonsOfLiberty86:
R9 270X here, and I had this same problem with screen flickering ( I also have Win 8.1 64 bit) and I just found a fix!

Here is HOW TO FIX:

- Close your game if it is open. Goto your MGSR directory (Steam/steamapps/common/METAL GEAR RISING REVENGEANCE/)

- Right click on the main game exe file and click on properties.

- Goto the Compatibility tab and check Compatibility Mode > Run this program in compatability mode for: Windows XP (Service Pack 3).

- Also be sure to check "Disable display scaling on high DPI settings".

- Click apply, then OK. Run the game.

I don't know if this will work for everyone but this just fixed my flickering problem. Hopefully this helps someone else out there.
good job. it`s helpful.
[MGSFC] Maniac_34 Aug 29, 2014 @ 9:35am 
Originally posted by SonsOfLiberty86:
R9 270X here, and I had this same problem with screen flickering ( I also have Win 8.1 64 bit) and I just found a fix!

Here is HOW TO FIX:

- Close your game if it is open. Goto your MGSR directory (Steam/steamapps/common/METAL GEAR RISING REVENGEANCE/)

- Right click on the main game exe file and click on properties.

- Goto the Compatibility tab and check Compatibility Mode > Run this program in compatability mode for: Windows XP (Service Pack 3).

- Also be sure to check "Disable display scaling on high DPI settings".

- Click apply, then OK. Run the game.

I don't know if this will work for everyone but this just fixed my flickering problem. Hopefully this helps someone else out there.
Fixed it for me too. Thanks. Now I don't need Radeon Pro
Mother Beef Sep 6, 2015 @ 11:43pm 
Originally posted by SonsOfLiberty86:
R9 270X here, and I had this same problem with screen flickering ( I also have Win 8.1 64 bit) and I just found a fix!

Here is HOW TO FIX (don't know if this works for everyone but worked for me and a few people below so far):

- Close your game if it is open. Goto your MGSR directory (Steam/steamapps/common/METAL GEAR RISING REVENGEANCE/)

- Right click on the main game exe file and click on properties.

- Goto the Compatibility tab and check Compatibility Mode > Run this program in compatability mode for: Windows XP (Service Pack 3).

- Also be sure to check "Disable display scaling on high DPI settings".

- Click apply, then OK. Run the game.

Again I don't know if this will work for everyone but this just fixed my flickering problem. Hopefully this helps someone else out there.


Holy ♥♥♥♥, this worked for me (was running HD7970 on Windows 10) thankyou so much the game was previously giving my monitors screenburn (temporary and easily fixed with flashing colour videos) but now it's pretty much perfect. Thankyou!
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: Jul 21, 2014 @ 7:38am
Posts: 11