Conrad le Roturier May 20, 2013 @ 7:25am
Can't start a game since patch applied (not resolution issue)
I posted this issue in other threads, but it didn't seem to get any attention, so I'm trying with a new thread before giving up.

Since the patch has been applied on my side, I can't start a new game. Once I enter a level, I click to start it, but it won't start, it would only float around the level as it at the beginning of each maps. Clicking would only restart the music... I'm on a mac.

I tried to:
- change the resolution
- windowed and full screen
- reinstall the game twice

and these had no effect. Am I alone with this problem ?
Showing 1-15 of 16 comments
< >
Segal May 20, 2013 @ 7:41am 
Hm, that's the first time I hear about it. Sent it to programmers team.
Alexander May 20, 2013 @ 7:46am 
Could you please repeat all actions (start level and try to start to play it) and send us your log file from location after that.
Log file location is: ~/Library/Logs/Unity/Player.log
Thanks in advance
Conrad le Roturier May 20, 2013 @ 10:13am 
Hey, thanks for the reply. My actions are:
1) Launch the game from Steam
2) Click "Play" in the first screen
3) Select any level and click play
4) Once level loaded, the camera floats around the level and the hud says "Click to play/start"
5) I click and nothing happens, the camera still floats around and I can't exit
6) Shutdown the game ungracefully

How can I send you the file? I've tried to find an email on your site(s) but I miserably failed.
Last edited by Conrad le Roturier; May 20, 2013 @ 10:15am
Conrad le Roturier May 20, 2013 @ 10:20am 
While I wait, I looked at the log for fun and I noticed at the end a repeat of the same stack trace and I associate the repeat to the number of times I clicked with the intention to start the game while it was stuck. Just in case it gives you a quick hint:

--
Unloading 6 unused Assets to reduce memory usage. Loaded Objects now: 4180. Operation took 35.880955 ms.
ArgumentException: An element with the same key already exists in the dictionary.
at System.Collections.Generic.Dictionary`2[System.String,com.nival.td.statistics.TowerCardUsage].Add (System.String key, com.nival.td.statistics.TowerCardUsage value) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.ToDictionary[Card,String,TowerCardUsage] (IEnumerable`1 source, System.Func`2 keySelector, System.Func`2 elementSelector, IEqualityComparer`1 comparer) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.ToDictionary[Card,String,TowerCardUsage] (IEnumerable`1 source, System.Func`2 keySelector, System.Func`2 elementSelector) [0x00000] in <filename unknown>:0
at com.nival.td.statistics.SessionState..ctor (com.nival.td.model.LevelStatistic ls, Single startPrime, Single startLife, com.nival.td.model.Card[] towerCards, com.nival.td.model.Card[] magicCards) [0x00000] in <filename unknown>:0
at GameManager.OnStateChanged (GameStates state, System.EventArgs args) [0x00000] in <filename unknown>:0
at GameManager.SetState (GameStates newState) [0x00000] in <filename unknown>:0
at GameManager.SetState (GameStates newState, System.EventArgs e) [0x00000] in <filename unknown>:0
at SessionHUDController.StartGameButtonHandler () [0x00000] in <filename unknown>:0
UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)
UIButtonMessage:Send()
UIButtonMessage:OnClick()
UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)
UICamera:Notify(GameObject, String, Object)
UICamera:ProcessTouch(Boolean, Boolean)
UICamera:ProcessMouse()
UICamera:Update()

(Filename: Line: -1)

--
Alexander May 21, 2013 @ 1:56am 
Great, this should be enough to find out the problem.
Thank you very much!
Alexander May 21, 2013 @ 2:19am 
Sorry, one more question. Could you write your Steam account name,please ?
Conrad le Roturier May 21, 2013 @ 5:49am 
Yes it's tet750.
Alexander May 21, 2013 @ 6:03am 
Sorry, and your in-game name as well, that you've entered in the beginning ?
Thanks
Conrad le Roturier May 21, 2013 @ 12:42pm 
Hmmm, I don't quite remember. I might be Guliavan or Guli. How can I get it? I checked in the options and I'm only able to reset my account from there :-o
Conrad le Roturier May 21, 2013 @ 12:44pm 
Ok, got it from the Leaderboard. It's Guliavan.
Alexander May 22, 2013 @ 3:04am 
Ok. We've found a bug. It's strange, but you have one card in a deck twice (Fire tower).
We'e fixed your deck right now.
And we will fix this bug on release.

Thanks for your feedback and patience.
Conrad le Roturier May 22, 2013 @ 8:28am 
Wonderful, it's working now! Thanks!
NetMastr5 Jul 22, 2013 @ 2:49pm 
I am having the same type of problem.

I am trying to play any of the 3 support levels on the Urd-Nag level. All 3 bring up the level and the click to start text, but clicking does nothing (the level is being displayed in B&W in the background encase that matters). I can play normal levels without issue, but not the 3 support levels.

I am running Win 7 X64 and my in game name is NetMastr5.

I hope you can help,

Thanks.
InfectReality Aug 28, 2013 @ 7:40pm 
Same here as above and main poster, support levels are unplayable.
NetMastr5 Aug 29, 2013 @ 1:52pm 
Infectreality,

After posting this issue here, I went on to post it on the official Steam support page for PWD, the publisher's official support forum on their website and a few other palces. After no comment on it from any one (developer or otherwise) after 3 weeks, I ended up resetting my progress and starting over. I just finished the 1st playthrough last night without issue, so you might have to go that route to "fix" your problem.

If you do happen to find an alternative solution that doesn't loose your current progress, please post it back here for others to find int eh future.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50