Segal May 4, 2013 @ 6:56am
Bug reports thread
I think we should collect all the bugs in one thread, so it would be easier to address and fix.

Please, post your bug descriptions here, as detailed as possible. Always indicate your configuration (including OS version, that seems to be most important) and attach screenshots if possible.

I'll create another thread for suggestions, so please don't post them here.
Showing 1-15 of 592 comments
< >
Odai May 4, 2013 @ 7:17am 
Prime Master Talent isn't really granting +10% Prime on killing more like 10% of +1 Prime for a kill.

Slingshot: Attacks flying enemys with "THROWING SPEARS"... (its shooting stones?!)
Lightning Bolt: Lightning causes xx "word damage is missing" and stuns...
Kouterm May 4, 2013 @ 8:23am 
The unity engine can cause the game not to start with the error "Fatal Error in gc".
This was fixed for me by replacing the mono.dll in the steamapps/common/prime world defenders/mono directory with this one:
https://docs.google.com/a/unity3d.com/file/d/0Bz4rtnpF8SvMNm0tLUpRdUxrVzA/edit?pli=1
Last edited by Kouterm; May 4, 2013 @ 8:24am
Micgoo May 4, 2013 @ 8:31am 
This might come across to you as falling under 'suggestions' but I consider a prime mortar not dealing any damge AT ALL because the ONE targeted touched is killed before the ordinance hits a BUG.

Sorry if this irritates you but I'm letting you know it irritates me and many other players and would-be players.
Ionizer May 4, 2013 @ 9:35am 
I'd consider the Mortar thing a bug too. I assume the same happens for any tower with an AOE.

Here is another minor one. If you click the mute buttons in the sound control panel, if you close it you loose the sound level and can't unmute and have to drag the slider back into place manually.
Last edited by Ionizer; May 4, 2013 @ 9:36am
StrikACE May 4, 2013 @ 10:05am 
Im stuck on first level becuase camera is stuck at ground level and is unresponsive.
THIS IS A GAME BREAKING BUG. can't even play game I just payed for. The viewing mechanics are completely broken for me.
alright game works in windowed but fullscreen is still unresponsive this is a big problem.
Last edited by StrikACE; May 4, 2013 @ 10:12am
War Cock May 4, 2013 @ 11:28am 
I've found a couple of bugs. I accidently put the game into windowed mode, then tried putting it back into fullscreen, however the button doesn't work. Then I used Alt+enter to put the game into fullscreen mode, however now it will display in widescreen at my laptops native resolution. So now I have a tiny picture on my laptop and it's kind of hard to play. Please help.
Zino May 4, 2013 @ 12:37pm 
The story boards are scaled to 16:10 on a 16:9 resolution. So the top and bottom parts dissapear. This cuts off or hides text boxes in the top and bottom.

Running 2560x1440
War Cock May 4, 2013 @ 12:40pm 
I still don't understand how some people can run at higher resolutions but all I have is 1024x768, but my laptop runs at 1366x768. I am seriously confused.
What about some man action? May 4, 2013 @ 12:41pm 
first level bug? http://steamcommunity.com/id/tiagoc/screenshot/848078277531596587
Also i only can choose 1024x768 resolution in laptop?
FattyMooMooMan May 4, 2013 @ 12:50pm 
My game crashed after a certain level late in the game, it may be the final or next to last level I am not sure,

It does stand out from the others I have done so far:

I think it could be the final level as it is 89 waves long, I finished the final wave with 11 lives left and shortly after completion the game just sat there - I could not scroll, zoom or place towers but I could move my mouse pointer and the music still played. As soon as I clicked the options button the game crashed with the usual windows program has stopped working error. Is it possible there is an error with the ending or going onto the final boss level?

Update on the bug:

Crashed in a similar way again when I lost my last life on wave 77. I can play the game for many hours without any hitches and it runs as smooth as silk all of the time, on this level around wave 60 or so the game starts to get some judders and slow-downs. Thought it might be an issue with the engine on 32 bit windows (uses unity engine I believe - has some issues with memory management on 32 bit machines), however my nephews PC also starts to hitch on this level (but not crashed yet) and he has a much more powerful PC than mine running a 64bit OS.
Last edited by FattyMooMooMan; May 4, 2013 @ 1:17pm
Sombra May 4, 2013 @ 12:53pm 
Whenever I try to complete the second level, it always gives me a "missing data parameters" error after beating the boss. Then I can either reload to the menu or exit the game itself. I'm on OS X 10.8.3
ElcomeSoft May 4, 2013 @ 2:32pm 
Every time I quit the game by going to the menu and quit program, the program locks up and requires me to use Task Manager to close it.

I run the game in Windowed Mode and if I use the small X to close the game it responds as expected and the game closes but not if I do it 'the proper way'.
Sirbond May 4, 2013 @ 4:22pm 
Keep getting error message after misson 2 saying (no connection to the server. check your internet connection, then click the reload button.) (i was connected i was on teamspeak the whole time)
Ratchet May 4, 2013 @ 6:33pm 
I always get a fatal error saying 'Get ThreadContext Failed'. I literally can't play the game because it crashes even before i get to the main menu screen.
Unit3 May 4, 2013 @ 7:15pm 
Per resolution issues thread, I'm seeing terrible in-game scaling and cut off graphics during cutscenes when playing at 2560x1440.
Showing 1-15 of 592 comments
< >
Per page: 15 30 50