The 39 Steps > General Discussions > Topic Details
jon101 May 20, 2013 @ 12:20pm
LInux display problem - dual monitor?
Hi, I have two monitors. The primary one is 1680 x 1050 (main one) and the second smaller one 12080 x 1024. When I run the game the game is only partly visible on the my main monitor. no sign on the other one. i cannot see the whole game screen. running ubuntu linux 12.10, all other games run fine and focus on the main screen perfectly. the resolution seems fine for this game, so its not that. any ideas? would apreciate it as the game looks good and its also relatively expensive. thanks. jon
Showing 1-8 of 8 comments
< >
TheStoryMechanics  [developer] May 21, 2013 @ 2:54am 
Originally posted by jon101:
Hi, I have two monitors. The primary one is 1680 x 1050 (main one) and the second smaller one 12080 x 1024. When I run the game the game is only partly visible on the my main monitor. no sign on the other one. i cannot see the whole game screen. running ubuntu linux 12.10, all other games run fine and focus on the main screen perfectly. the resolution seems fine for this game, so its not that. any ideas? would apreciate it as the game looks good and its also relatively expensive. thanks. jon

Hi Jon, are you running the latest update of the game - it should automatically resize to your main monitor (an issue we fixed about a week ago). If so, if you could send us a screenshot (support@thestorymechanics.com) we'll look into it. It could well be an issue with the dual monitor set up, but it's not something we've seen happen.
jon101 May 21, 2013 @ 11:35am 
thanks for your prompt reply. as far as i can see its the most up to date. yes, i'll send you the screenshot. Thanks.
jon101 May 21, 2013 @ 11:42am 
sent!
TheStoryMechanics  [developer] May 23, 2013 @ 8:30am 
Originally posted by jon101:
thanks for your prompt reply. as far as i can see its the most up to date. yes, i'll send you the screenshot. Thanks.
It seems this is a Unity platform issue for dual-motor Linux steups. We have discovered one guy who found a workaround: http://www.youtube.com/watch?v=cFJFZLYioJw . Hopefully that helps
jon101 Jun 21, 2013 @ 1:48pm 
or even easier, just turn off the second monitor in the display app and it works fine!
MaTachi. LINUX + BITCOIN Jul 19, 2013 @ 1:47am 
Haven't tried this game, but I'm experiencing the same problem with multiple games. I always turn my secondary monitor off with 'xrandr ––output DVI-I-0 - - off'
Mischka Jul 24, 2013 @ 5:22pm 
In /home/[user]/.config/unity3d/The Story Mechanics/The 39 Steps/ there is a prefs file. In which you can specify your correct resolution. You can then change permissions to read only, otherwise the game will change it back every time you launch it.

Nothing else fixed it for me, not even disabling the second monitor.
km3k Sep 3, 2013 @ 6:39pm 
I have two 1920x1080 moitors. I used the prefs file to set it to 1920x1080 instead of 3840x1080. The menus and text look right and only display on one monitor, but the backgrounds still seem off center as if they were displaying on both monitors.

The menus look ok: https://dl.dropboxusercontent.com/u/3285273/39stepsmenu.png

And the text looks ok, but the backgrounds are off: https://dl.dropboxusercontent.com/u/3285273/39stepsoffcenter.png

Any idea how to fix this?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50