Anodyne > IMPORTANT STUFF > 主题详情
seagaia  [开发者] 2013年3月23日上午11:43
common windows/linux fixes
windows black screen

need to install msvcr100.dll usually

http://camstudio.org/forum/discussion/1238/msvcr100.dll-missing/p1

---
Sorry about that. I'm planning to add "recommend Ubuntu" to the Linux reqs, and I probably should have to start with. To be perfectly honest I'm not really a Linux guru, especially with stuff like this.

If you run a distro and can't get it to work, I can send you a Desura key which'll let you download a Standalone SWF version. It won't have achievements but it's better than nothing - I could give you the soundtrack for free too. Sorry!

email me at anodynegame@gmail.com

sean

----
SOUND FIX (probably only for pulseaudio - i.e. Ubuntu distros)

Fix for Sound Delay (Ubuntu)
I don't know if it works for all Linux distributions, but if you have a sound delay in Ubuntu, you can fix it with the following steps:

1. go to "~/.steam/steam/SteamApps/common/Anodyne"

2. rename "run.sh" to "run2.sh"

3. create a new file "run.sh" with the following content:
#!/bin/bash
PULSE_LATENCY_MSEC=20 ./run2.sh

4. make the new "run.sh" executable


--------

FIX if you get the dpkg error etc. This works with Arch 64 bit appparently, I assume other distros as well. Give it a shot!

So, I ended up with a really simple solution after figuring out how Adobe Air works and all:

Like Hyeron mentioned above, add this to application.xml within the <application> element:
<supportedProfiles>extendedDesktop</supportedProfiles>

And, in run.sh, you can replace everything (sans the export of LD_LIBRARY_PATH) with:

/opt/adobe-air-sdk/bin/adl share/META-INF/AIR/application.xml share/

Then run it in Steam. Of course, /opt/adobe-air-sdk/bin/adl might point to somewhere else on your distro.
最后由 seagaia 编辑于; 2013年5月2日下午11:48
正在显示第 1 - 8 条,共 8 条留言
< >
MillieBug 2013年9月1日下午1:20 
I am running windows 7 and having the black screen issue, nothing I have tried (uninstall/reinstall, reinstalling flash, updating windows and drivers, manual install of msvcr100.dll) has fixed it. Are there any other suggestions?
eccentricCheese 2013年9月1日下午6:42 
引用自 MillieBug
I am running windows 7 and having the black screen issue, nothing I have tried (uninstall/reinstall, reinstalling flash, updating windows and drivers, manual install of msvcr100.dll) has fixed it. Are there any other suggestions?

I'm pretty much having the same issue only with XP 32-bit. I've tried updating Windows, drivers, uninstalling/reinstalling, confirmed msvcr100.dll is in the system 32 folder... nothing. It did actually briefly work, but without any sound (my entire system, not just the game). I decided to do a system restart and now the game won't work again.
theFlyingDutchman 2013年11月15日下午11:29 
I run Lubuntu 13.04, and I'm having no sound. I've tried the sound delay fix, and I've also tried pasting shortcuts to libopenal.so everywhere (did the trick with SPAZ), but nothing seems to help. I've tried googling it, but even that yields no results. Can someone help me, please? I really want to play this game...
最后由 theFlyingDutchman 编辑于; 2013年11月15日下午11:32
JP 2013年12月24日下午2:45 
Running Ubuntu 13.10 64-bit here. I did everything in other howtos and Adobe AIR still didn't install. Manually (sudo dpkg -i) installing the package on this page is what finally made the installer work:

https://launchpad.net/ubuntu/saucy/amd64/libhal1/0.5.14-8ubuntu1

It seems quite possible that this package won't install without problems in future versions of Ubuntu et al, which is a real . Thank you for providing support here at least!
cy 2013年12月28日上午11:53 
If you are having problems with root password during Adobe AIR install, run in terminal:
sudo ~/.steam/steam/SteamApps/common/Anodyne/install.sh
It will ask you for your own password instead of root's.
cartman-2000 1月26日下午10:01 
For the pulseaudio delay I needed to use 40 ms for the delay for it not to have static.
LMNO Goldfish 3月29日上午11:16 
Trying various fixes (Fedora 20 x64) but as far as I can tell, Adobe dropped support for Air-on-Linux way back in v2.6.0, so it would seem that this game simply will not work for some Linux users. Shame, having bought the Humble Bundle specifically because of Linux compatibility.
Specifically, in case it matters, Air refuses to install on FC20, and won't report a reason why. I've tried manually installing Air, as well as allowing the game package to install it for me, and both fail completely.
Naceira 4月1日下午4:31 
After trying all advices to install Adobe Air, finally I found the one that worked thanks to mattias_oh!!

引用自 mattias_oh
Hi

For me neither the steam installation (~/.steam/root/SteamApps/common/DefendersQuest/install.sh) nor the easily alvailabe deb-file of Adobe air (https://launchpad.net/ubuntu/lucid/i386/adobeair/1:2.6.0.19170-0lucid1) nor the helpful guides for 13.04 (http://www.thepowerbase.com/2013/06/how-to-install-adobe-air-in-ubuntu-13-04/ & http://ubuntuhandbook.org/index.php/2013/07/install-adobe-air-linux-mint-32-64-bit/) worked and I couldn't start the game :(

It all seamed to boil down to that the packages "ia32-libs" and "libhal1" are no longer available in 13.10.

"Libhal1" doesn't seem to be necessary, or at least I didn't install it on purpose :P
"ia32-libs" seems to have been just a 'meta package', i.e. a link to a bunch of other packages that are still available. I randomly took pieces of advice from http://community.secondlife.com/t5/Second-Life-Viewer/Ubuntu-13-10-and-the-death-of-ia32-libs/m-p/2269003 & http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10 & http://ubuntuforums.org/showthread.php?t=2181649

And now the game works :)

Summary: To install Adobe Air on 64-bit Ubuntu 13.10 simply follow http://ubuntuhandbook.org/index.php/2013/07/install-adobe-air-linux-mint-32-64-bit/ BUT instead of step 3 install the following packages:

"""
sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 gstreamer0.10-pulseaudio:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386 gstreamer0.10-ffmpeg:i386
sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386
sudo apt-get install libnss3-1d:i386
"""
* Disclaimer: Some of those packages might not be needed

Good Luck!
http://steamcommunity.com/app/218410/discussions/0/666826069039698014/
正在显示第 1 - 8 条,共 8 条留言
< >
每页显示数: 15 30 50