Tropico 3 - Steam Special Edition

Tropico 3 - Steam Special Edition

Vis statistikker:
c4pt1v1ty 14. jul 2013 kl. 16:50
game will not launch
I can not get the game to launch and have tried everything I can think of from; uninstalling and reinstalling, to changing monitors and playing with settings nothing has worked. PLEASE HELP!!!
< >
Viser 1-14 af 14 kommentarer
Rodrigues 17. jul 2013 kl. 10:48 
which monitor resolution do you use? i had the same problem. the game doesn't accept 1366x768
HeadClot 17. jul 2013 kl. 20:13 
Try and Verify the Game Cache of Tropico 3. I am expierncing problems with this.
c4pt1v1ty 18. jul 2013 kl. 15:15 
thanks for the help. i think it is resolution related but i just havent figured it out yet. i have tried three different monitors including my tv. i got sound on one monitor but still wouldnt let me in, the others just black screen no sound. i have done verify and will keep tring that too.
HeadClot 18. jul 2013 kl. 15:34 
What OS are you running the game on? Microsoft released an update that botched steam users. Look for kb2803821 in Add and remove programs. Once you remove it Restart.
Skinny_Obelix 22. jul 2013 kl. 9:13 
Try changing the compatibility settings of your steam>steamapps>common>tropico 3>tropico 3.exe : check disable visual themes and disable desktop composition
osterejen 30. jul 2013 kl. 4:38 
Oprindeligt skrevet af Zyphus:
Try changing the compatibility settings of your steam>steamapps>common>tropico 3>tropico 3.exe : check disable visual themes and disable desktop composition

This worked! Thanks
JestaBlunt 2. aug 2013 kl. 3:51 
yeah, thx...worked for me too...and now i can even start it with the compatibility settings unchecked again...only needed it for the first start.
Zebrakiller 14. aug 2013 kl. 12:42 
I have done all of that but I do not have disable visual themes or disable desktop composition options. I am running Windows 8.
Auzrael 19. aug 2013 kl. 4:03 
If you work with 2 screens, type windows key + P, select your main screen.
You won't have to do it next times.
Sidst redigeret af Auzrael; 19. aug 2013 kl. 4:03
Zebrakiller 19. aug 2013 kl. 13:39 
No, I only have one screen.
Wildfire 19. aug 2013 kl. 14:42 
Oprindeligt skrevet af STaR~NiX:
Oprindeligt skrevet af Zyphus:
Try changing the compatibility settings of your steam>steamapps>common>tropico 3>tropico 3.exe : check disable visual themes and disable desktop composition

This worked! Thanks

That worked for me also, thx
Matty J 24. aug 2013 kl. 8:10 
Oprindeligt skrevet af Zyphus:
Try changing the compatibility settings of your steam>steamapps>common>tropico 3>tropico 3.exe : check disable visual themes and disable desktop composition

This worked for me aswell thanks a bunch thought i had wasted my money :)

Union 7. jan kl. 15:23 
wait where do you find disable visual themes and desktop composition in compatibility?
mclovin 14. jan kl. 15:55 
Oprindeligt skrevet af TheTactitian:
wait where do you find disable visual themes and desktop composition in compatibility?
same problem for me, i can't find them
< >
Viser 1-14 af 14 kommentarer
Per side: 15 30 50