c_note_1001 Aug 21, 2013 @ 8:49pm
Part of game not loading
I am at the part where you infiltrate the Brotherhood. Right now my last save that actually loads is in the Runners safehouse in the basement of the Seamstresses Union. When I get all of my gear and a crew together and try to load the next section, it will not load. I am wanting to know if this is a common issue, and how or if it can be fixed.
Showing 1-5 of 5 comments
< >
BorisBadinov Aug 22, 2013 @ 10:42pm 
I am having a similar problem. I try to load Pikes Place Market and it stays loading at 3/4 of the bar. I tried rolling back to a previous save in Seamstress and then redoing that section but again I have the same problem. The game is officially unplayable by me, and Im only about 45 minutes in.

I'm on a mac if that matters.
c_note_1001 Aug 25, 2013 @ 9:41am 
The thing is, when I try to load the Brotherhood, it just goes to the load screen and does nothing. The bar doesn't fill, it just sits there. Is there any way that it can be fixed?
Stoan Sep 6, 2013 @ 10:02pm 
same issue, gonna email them about this. Seems to be a common bug on mac
Graagh Dec 24, 2013 @ 8:02am 
Did anyone get a resolution on this?
Delicious_Salad Feb 15 @ 11:56pm 
I just bought this game on mac and I'm having the same exact problem as BorisBadinov. I tried rewinding my save back to when I entered the Seamstress Union but it just freezes again once I try to leave for Pike's Place. Is there no fix for this?
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Aug 21, 2013 @ 8:49pm
Posts: 5